Manjaro Live USB doesn't boot

grub

#1

Hi. I know that there are a lot of posts like this on the forum, but I have searched and found only one case slightly similar to this - it did not help.

I have the latest stable Manjaro KDE on a USB stick, and it won’t boot on my computer. It only shows “GRUB” on a black command prompt screen. And that is the absolute first thing that appears on the display after selecting the boot device from the BIOS menus.

Tried on USB 3.0 and 2.0 ports; tried on a USB 3.0 and 2.0 stick; unplugged all USB and SATA devices so Grub wouldn’t get confused; checked the SHA1 of the downloaded ISO; installed on the stick using Etcher on OS X or plain dd on Ubuntu.

The laptop has an Intel SandyBridge Core i5-2410M (pre-UEFI). The USB stick works perfectly fine on another first-gen i7 Mobile laptop - using it right now.

What can I do to understand what is going wrong? Thank you for the help :slight_smile:

Edit: grammar.


#2

can you give more details on boot

you see only on Bios for USB stick

  • KDE on USB like disk or
  • KDE on USB like disk + partition 2
  • or both

#3

Sorry but I don’t get exactly what you mean.

The computer never reaches the boot loader, the BIOS lets me select only whole drives. I start up the computer, the first screen is the BIOS with the computer logo; I press Esc to open the BIOS menu and then choose the boot drive selector; here I get 3 choices:

  • Internal SATA drive, would launch Clover bootloader to boot OS X if the drive is attached (btw don’t get confused this is just some random HP Pavilion DV6)
  • DVD drive, it’s empty
  • USB stick [name], should launch Grub bootloader but hangs at that empty screen with the “GRUB” text

Hope this explains the situation. Later I will try to boot Manjaro using Clover from the SATA drive and to play a little with the BIOS settings (especially the drive modes, IDE/AHCI). Hope someone can help me figure this out, thank you.

Update: Clover doesn’t start the Manjaro stick. It’s probably just not configured for it and touching it will potentially mess everything that is working with it and OS X. It’s not worth it, since I will not have Clover when I switch to Linux only.
Changing HDD controller mode in the BIOS settings does nothing.


#4

Try letting it sit with the “Grub” text for about 5-10 mins. My computer takes about 8 minutes to actually load the menu off a flash drive.


#5

I think I let it sit for a bit over 15min. I’ve booted from USB sticks Ubuntu, several OSX installs, Clonezilla, a Windows install, all using the same USB sticks that I am using rn, everything I have thrown at it has been relatively snappy.

I will now turn it on and try again.
Edit: 1h now.


#6

Did you try rewriting the usb? If you have a Mac, you can use sudo dd bs=64k if=manjaro.iso of=/dev/disk(n) N is the number you find in disk utility. Manjaro.iso is the absolute path to the iso you downloaded


#7

If the USB stick works fine on one laptop, then that’s a pretty good sign that the USB is just fine. Likely a setting in the Bios of the laptop of question, or that laptop is finnicky about the brand of USB drives it eats. :wink:


#8

As I said, I used Etcher on OSX and dd on Ubuntu (tried dd twice because I tried with a different USB stick). Every time the USB stick booted just fine on the other laptop.


#9

Oh. Sorry. So the issue is definitely not the USB stick.


#10

I’m not sure if it will help but you could try using a different ISO. Assuming that you have been trying with 18.0.x it may be worth trying from the 17.1.12 iso. https://osdn.net/projects/manjaro/storage/kde/17.1.12/ The 17.1.x iso’s used the 4.14 kernel whereas the 18.0.x ones use the 4.19.


#11

Thanks for the suggestion, I am going to try this now, updating here later.


#12

Okay, tried the 17.1.12 stable and this time the output is slightly different:

GRUB loading.
Welcome to GRUB!
_

Again, this is the first thing that appears on screen, and also where it hangs.

I recognize these lines from other posts, so I am going to search the forum again and see what other people have tried.

But if you have any concrete ideas please let me know, thank you.


#13

you have to check any option in your bios ,
maybe you have to update

if any other DE linux works , please give return
you can try https://sourceforge.net/projects/systemrescuecd/files/sysresccd-x86/6.0.0/systemrescuecd-6.0.0.iso/download?use_mirror=netix
the base is now on arch

inxi -Fxxxz

#14

Hi, thank you for your reply.
Sorry if I am a bit confused, do you want me to provide the output of that command from any Linux or should I first try Manjaro with a different DE?
I already have a USB stick with Ubuntu so I’d rather use that to output the system info.

Regarding the BIOS, the laptop is ~8yrs old, it hasn’t been updated in a long time. I loaded a slightly modified version of the BIOS that adds a few advanced options (I use this to turn off power to the GPU, so it consumes less and heats up less). This is guaranteed not to cause such a problem, I have used the laptop with this for everything, since forever.

I can try and check some options in the BIOS, but do you have any specific ideas? The system just works with anything else.

Thank you.


#15

Here is the output from inxi in Ubuntu:

ubuntu@ubuntu:~$ inxi -Fxxxz
System:    Host: ubuntu Kernel: 4.15.0-29-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.28.2 (Gtk 3.22.30-1ubuntu1) info: gnome-shell dm: gdm3
           Distro: Ubuntu 18.04.1 LTS
Machine:   Device: laptop System: Hewlett-Packard product: HP Pavilion dv6 Notebook PC v: 058F110000244610000620100 serial: N/A
           Mobo: Hewlett-Packard model: 3388 v: 10.31 serial: N/A
           BIOS: Hewlett-Packard v: F.1B date: 10/05/2011
           Chassis: type: 10 serial: N/A
Battery    hidpp__0: charge: N/A condition: NA/NA Wh volts: NA
           model: Logitech Wireless Keyboard K360 serial: <filter>status: Discharging
CPU:       Dual core Intel Core i5-2410M (-MT-MCP-) 
           arch: Sandy Bridge rev.7 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9179
           clock speeds: min/max: 800/2900 MHz 1: 798 MHz 2: 798 MHz
           3: 798 MHz 4: 798 MHz
Graphics:  Card-1: Intel 2nd Generation Core Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:0116
           Card-2: Advanced Micro Devices [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT]
           bus-ID: 01:00.0 chip-ID: 1002:6740
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.04hz, 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
           version: 3.3 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1c20
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 4000
           bus-ID: 07:00.0 chip-ID: 10ec:8168
           IF: eno1 state: down mac: <filter>
           Card-2: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller
           driver: wl bus-ID: 0d:00.0 chip-ID: 14e4:432b
           IF: wlo1 state: dormant mac: <filter>
           Card-3: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
           driver: rtl8192cu usb-ID: 002-006 chip-ID: 7392:7811
           IF: wlx801f02d0f7e2 state: N/A mac: N/A
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 500.1GB
           serial: <filter> temp: 0C
           ID-2: USB /dev/sdb model: Cruzer_Micro size: 4.0GB
           serial: <filter> temp: 0C
Partition: ID-1: / size: 3.9G used: 799M (21%) fs: overlay dev: N/A
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A gpu: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 230 Uptime: 7 min Memory: 1606.1/7924.1MB
           Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191 running in gnome-terminal-) inxi: 2.3.56

#16
  • you are booting in Bios so only
    one boot form manjaro appears for KDE

  • can you also check with systemRescue V6.0.0 if booting ?
    the base is on ArchLinux , so if it works there is a trouble with Grub in manjaro ( see link before )


#17

Have you tried an other ISO-writer yet? From my own experience I can say that some ISO-writers write an image on a USB-stick that isn’t able to boot.
In Manjaro I mostly use the SUSE Studio Imagewriter and I’ve never had problems with it. I don’t know if this imagewriter is also available in the Ubuntu-repository. But you can search after “imagewriter” in the Software Center.
If you have an android phone which supports OTG you can try the following: Download and install the app “EtchDroid” (PlayStore or F-Droid) on your android-phone and download the Manjaro-ISO. Connect the USB-stick to the smartphone via an OTG-cable and flash it. For me it also works.
So have a look at an other iso-writer that works for you.


#18

Running systemRescueCD from a USB stick, works flawlessly…


#19

can you open a terminal
and report

inxi -Fxxxz
pacman -Qs grub
pacman -Qs systemd 

#20

Hi, thank you for answering.

As I said previously, every time that I flash a USB stick I also test it on an other PC, and that always worked.

Right now I am just running dd from a terminal in Linux, but EtchDroid sounds like a nice plan B to have, so I thank you for the suggestion and I am going to run it on my Xperia Z3 to test :+1:


Installer GRUB doesn't load on my HP DV6