Manjaro live (any edition) won't boot in a AMD A6 7480

Manjaro live won’t boot in a AMD A6 7480, no matter which DE, no matter if 5.6 or 5.9 kernel. I’m not sure about the motherboard model, but is an ASRock.

And I’m not being fully precise when I say it won’t boot: I believe it gets to as it shows boot messages and then the screen goes black. There’s still activity in the numlock key, for instance. So it might be that it’s still there, just with no video.

As I’m still on the pendrive, it gets really complicated to do whatever I know about debugging.
Where to go from here?

Apparently here’s a problem with kernel 5.10 and some AMD GPUs, a laptop I own with a Ryzen 3 3250U won’t boot with 5.10 kernel and only shows a black screen.

Did you try this?

Doesn’t work for me with my 5700 XT, see if it works for you.

You can also try to install via Manjaro Architect, and select a different Kernel to install if that doesn’t work.

Hopefully it’ll be fixed in a newer version of 5.10…

Those options didn’t work for me either, I didn’t look much into it though, so I just boot with the latest LTS kernel.

Although the behavior is pretty much the same, I got that with kernels 5.6 and 5.9.

How could this be applied to the live version?

Ok. I realized I could just edit options for the kernel in the Manjaro pendrive boot screen (or so it seemed to me). So I entered amdgpu.dc=0 and booted away.

This time, instead of a black screen, I got no video signal at all. There was still activity in the caps/numlock keyboard leds, but the monitor screen went off (i.e. not even the backlight behind the black) and the power led blinking.

…and it was kernel 5.9 anyway.

Try the video= kernel parameter. On my computer with a 5700 XT, I HAVE to use video=DP-0:2560x1440@60 video=DP-1:2560x1440@144 video=DP-2:2560x1440@60. It is a workaround due to this bug. Some info here.

Try seeing if that works for you, even though AMD A6 7480 isn’t Navi 10. Obviously you need to set it to what your monitors and connectors are.

If that doesn’t work, try kernel parameter: amdgpu.ppfeaturemask=0xffffbffd

I don’t really recommend this one personally… because for me, it makes Proton Games drop down to 10-20FPS. Native games seems to work fine? (didn’t do long enough tests).

If not gaming, might not matter maybe? Though I think someone reported it made YouTube laggy, but I didn’t test it myself.

Hey bro,i experience the same problem on my computer which installed GPU R9 380X and now i fixed it by adding boot parament amdgpu.dc=0 and iommu=soft.By the first time i just tried adding amdgpu=0 and it works but,when i reinstall my archlinux, it didn 't work anymore.After browseing some posts i find a new solutions that is i mentioned above.I hope that can help you.