Manjaro KDE: Touchpad hangs/freezes up frequently on Lenovo X1 Carbon 6th Gen

Hello all!

After installing Manjaro for the first time on my Lenovo X1 Carbon 6th Gen, I came across some strange behavior. Almost every time I resume from a suspend the trackpad gets into a state where it will move the cursor a little bit then freeze up for another 10-30 seconds and move a little and freeze up, etc. I also had this problem on Deepin (not Manjaro Deepin), and a search online for a fix to this problem did not come up fruitful for either distro. The cursor moves fine when I use a mouse, and the trackpad works perfectly in Windows. The trackpad also works fine right after a hard reboot.

Things that I have tried:

  • Disabling the trackpoint in the BIOS
  • Using both the libinput drivers and synaptic ones
  • Messing around with palm detection and trackpad settings ingeneral
  • Restarting the psmouse module after a suspend
  • Changing the sleep optimization option in BIOS to linux

I’m not very linux savvy so I didn’t go much further than what was in my comfort zone.

Heres the “inix -Fxz”:

  Host: NSA-SPY-VAN Kernel: 4.19.20-1-MANJARO x86_64 
  bits: 64 compiler: gcc v: 8.2.1 
  Desktop: KDE Plasma 5.14.5 Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20KHCTO1WW 
  v: ThinkPad X1 Carbon 6th serial: <filter> 
  Mobo: LENOVO model: 20KHCTO1WW v: SDK0J40709 WIN 
  serial: <filter> UEFI: LENOVO v: N23ET59W (1.34 ) 
  date: 11/08/2018 
  ID-1: BAT0 charge: 44.8 Wh 
  condition: 56.9/57.0 Wh (100%) model: LGC 01AV494 
  status: Charging 
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 
  type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 31880 
  Speed: 796 MHz min/max: 400/4000 MHz Core speeds (MHz): 
  1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Device-1: Intel UHD Graphics 620 vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.3 driver: intel 
  unloaded: modesetting resolution: 1920x1080~60Hz 
  renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 18.3.2 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.19.20-1-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: Lenovo 
  driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi 
  v: kernel port: efa0 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 476.94 GiB used: 8.02 GiB (1.7%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN720 SDAQNTW-512G-1001 size: 476.94 GiB 
  ID-1: / size: 19.10 GiB used: 7.38 GiB (38.7%) fs: ext4 
  dev: /dev/nvme0n1p6 
  ID-2: /home size: 47.81 GiB used: 610.5 MiB (1.2%) 
  fs: ext4 dev: /dev/nvme0n1p7 
  ID-3: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p8 
  System Temperatures: cpu: 62.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 238 Uptime: 1h 01m Memory: 15.43 GiB 
  used: 2.62 GiB (17.0%) Init: systemd Compilers: 
  gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 

Any and all help will be appreciated!

Have you seen this?

Create a script say containing:


echo -n "none" | sudo tee /sys/bus/serio/devices/serio1/drvp 2
sleep 2
echo -n "reconnect" | sudo tee /sys/bus/serio/devices/serio1/drvctl

Make it executable:

chmod +x

Run it with sudo. If that works, it can be put into a unit to run on resume from suspend.

Here is lots of examples of what you may want to use for a service unit.

Okay, so I don’t know what I did (I tried multiple things that could have solved it) but for some reason it just started working. Thanks for the help y’all are great!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark