Manjaro (KDE) stuck on black screen with cursor before login screen

My manjaro-kde just shows black screen with cursor. I can move the cursor though…GRUB is also working fine and it show me all the options.I basically have 2 kernels installed one is 5.8(default running) and other is 5.4(LTS). I tried to boot using both of them using GRUB advanced option but its just stuck on the black screen.I haven’t updated my system recently and neither did I messed with any of the my system files.

Using an live debian-usb I have some gathered some logs see if it helps

sudo parted -l

Model: ATA TOSHIBA DT01ACA0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 491GB 491GB ext4
3 491GB 500GB 8982MB linux-swap(v1)

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 15.6GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 15.6GB 15.6GB primary fat32 boot, lba

sudo fdisk -l

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: TOSHIBA DT01ACA0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: EA5F3FCF-CE0A-5F48-AE00-D5C731C7B56A

Device Start End Sectors Size Type
/dev/sda1 4096 618495 614400 300M EFI System
/dev/sda2 618496 959224260 958605765 457.1G Linux filesystem
/dev/sda3 959224261 976768064 17543804 8.4G Linux swap

Partition 3 does not start on physical sector boundary.

Disk /dev/sdb: 14.6 GiB, 15631122432 bytes, 30529536 sectors
Disk model: Cruzer Blade
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0006e765

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 2048 30529535 30527488 14.6G c W95 FAT32 (LBA)

sudo blkid

/dev/sdb1: LABEL=“D-LIVE NF 1” UUID=“34E0-4973” TYPE=“vfat” PARTUUID=“0006e765-01”
/dev/loop0: TYPE=“squashfs”
/dev/sda1: UUID=“85D5-4EB4” TYPE=“vfat” PARTUUID=“c1e290ea-250b-fc4e-b5f3-fc3854901b65”
/dev/sda2: UUID=“7cf6bd6e-1a5f-49e3-857f-9b5291b87f40” TYPE=“ext4” PARTUUID=“401aebad-ccc5-9046-9910-c28ed1c26148”
/dev/sda3: UUID=“8ef6b5a0-0085-4341-be78-b28e988ec456” TYPE=“swap” PARTUUID=“6135d081-3e31-3345-8b64-997827c852e5”

Disk /dev/loop0: 2.7 GiB, 2886037504 bytes, 5636792 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

switch to tty and reinstall KDE

Any other option beside this?

Hello,

Yes there is, Please do a search on this forum, You will find a solution. Just put black screen in search and a plethora of answers will come up.

Could you find a solution?
I have the same error too

Press Ctrl + Alt + F2 to switch to TTY

Then sudo systemctl start sddm
systemctl reboot

I did it in the first place and I also tried reinstalling KDE but it didn’t work.

can you please share ?
inxi -Fazy
sudo dmesg | grep pci
journalctl -x -p3 -b1