Manjaro KDE - Slow Decryption, Hidden Startup

Hi everyone,

So I installed Manjaro KDE on a Lenovo ThinkPad X220, Intel I5, 8 gb of ram, 500 GB SSD. When I boot from the Thinkpad, my decryption time takes a while, and I lack any form of the boot screen with the green or red text showing me any system failures.


When it first happened, I thought it was a faulty install. So I redid the installation and it behaved in the exact same way.

When I use my other laptop, a toshiba satellite, 4 gb of ram, AMD cpu, and a failing HHD (inferior in every way), the decryption is quicker, and it shows the boot process. It has the same decryption password, so that isn't the issue.

They were both installed from the same bootable USB drive. I wish to have a normalized boot on my thinkpad. I looked through other issues involving slow decryptions, but the steps appeared convoluted (I'm still relatively inexperienced to Linux), and I fear I will lose the work I have put into this install if I attempt to get rid of the encryption.

I appreciate any help you guys can provide,
Moist

Did you install using BIOS or UEFI? Decryption can take a long time when using BIOS because limited system resources are available. It takes around 20 seconds for decryption if I install using BIOS. UEFI is much quicker, but even that isn't instant.

As far as I can tell, it is BIOS, due to there being no /sys/frimware/efi path. However, that may not be the way to check on manjaro. That is what my googlefu has come up with. When I installed, I loaded up live environment from the usb and then followed the installation wizard. When I came to the select partition screen, I had it overwrite the entire hard drive. How would you instal using UEFI? Is there a specific way to switch to UEFI after the fact?

Edit - this machine is pre-windows 8, so it is bios. I also don't have any visable grub loader, which I don't know if that is an issue.

The GRUB loader is hidden by default on Manjaro. You can enable it again by running this command in the terminal.

sudo grub-editenv - unset menu_auto_hide

UEFI has to be selected in the BIOS options before installing. It's the most common way to boot on newer systems, but most older systems only support BIOS booting. As far as I'm aware, there's no way to switch once the system is installed.

I'm not an expert on this topic. I encrypted the disk on my Windows machine with Veracrypt and was experiencing similar issues with long decryption times at boot. I spoke to the developer of Veracrypt who explained that it happens because limited resources are available to do the decryption calculations when using BIOS. I switched to UEFI and the boot times were vastly improved.

My boot times in Manjaro are much slower if I use encryption when booting with BIOS as opposed to UEFI, so I'm pretty sure the same thing is happening in Manjaro/Linux. If your hardware is particularly old, maybe it's just under-powered for the decryption being asked of it.

There could be a way to improve this, but it's beyond my knowledge I'm afraid. Hopefully someone else will come along soon to help you out.

1 Like

once you have done that, also edit /etc/default/grub and take the word quiet off the boot command if you want to see text output all of the time. with an SSD, good luck seeing any of it though :wink:

save the change and run sudo update-grub afterwards.

2 Likes

I just reinstalled using uefi (bless my heart), and it is much quicker. Now I just have to redo everything I had set up for the past 3 weeks - Smart card reader, VPN, customization, everything....

2 Likes

Separate Home is your friend. Automatically keeps your dotfiles...

1 Like

Ouch! I'm sure it will be worth it in the end. :slightly_smiling_face: Glad you managed to improve things.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by