Manjaro KDE Plasma Installation Stuck at [ OK ] Reached target graphical interface

System specs:
3090 Founders Edition GPU
Ryzen 5800X CPU

Secure boot disabled

Current OS: Ubuntu 20.04 LTS

I’ve tried both the main ISO (manjaro-kde-21.0.7-210614-linux510.iso) and the minimal version (manjaro-kde-21.0.7-minimal-210614-linux54.iso). Have tried it on two separate USBs, and I’m using balena Etcher

I’ve verified the SHA1 hashes

I just thought to also check the GPG sig by importing the keys from gitlab as per the instructions here: Manjaro wiki: How to verify GPG key of official ISO images ← jk I can’t include links, but should be first search result from the manjaro wiki following this search

I otherwise followed the instructions on this page and did get

gpg: BAD signature from "Manjaro Build Server <>" [unknown]

for both versions I downloaded

Not sure if a false positive or there is actually something wrong

Anyways, the minimal and regular ISO behave the same way.

What I get is:

If I install with open-source drivers, I get stuck on
[ OK ] Reached target graphical interface
but it isn’t frozen, I am able to alt+f2 to get to the shell and log in that way.

If I try to install with proprietary drivers, it freezes at the same place but is frozen and I am not able to do anything other than shut the computer down. Can’t access the shell.

I suppose I have a few questions:

I was able to install the nvidia drivers manually when I got to the shell when first installing open source drivers, but I realized after rebooting that I didn’t actually get thru to installing manjaro yet… so the fact that I got the drivers installed didn’t matter

There seemingly isn’t anything I can do when I opt to install the proprietary drivers from the very beginning

  1. Am I able to finish installing manjaro from the shell so that I can fully reboot and whatever else I need to do after installing drivers?
  2. If not, any ideas?

I would really appreciate any help on this, as I am quite stuck

edit: also UEFI not legacy boot

edit 2: installation works perfectly and essentially instantly inside a VirtualBox VM running on Ubuntu. Not sure if that information helps with anything (when proprietary drivers are selected)

Install Manjaro with an ISO with latest kernel 5.13 to test.

1 Like