Manjaro KDE plasma boot time is more and RAM utlilization is high


I have been using Manjaro KDE Plasma os for quite sometime. Earlier my boot time was pretty normal and the RAM utilization was under par. But suddenly something got break and I could see the boot time have increased and my 8GB ram is utilized more for my brave browser. Can somebody assist ?

╰─➤ systemd-analyze
Startup finished in 4.202s (firmware) + 5.256s (loader) + 6.239s (kernel) + 1min 46.217s (userspace) = 2min 1.916s reached after 1min 45.254s in userspace

1 Like

Take a look at the output of systemd-analyze blame

Hey @sampath, you can try running systemd-analyze blame --user to check what is consuming so much time in userspace.

@chomsky @CyberOto

╰─➤systemd-analyze blame 130 ↵
39.836s docker.service
33.576s systemd-journal-flush.service
21.354s linux-module-cleanup.service
19.870s NetworkManager-wait-online.service
15.965s containerd.service
15.326s lvm2-monitor.service
14.176s snapd.service
12.890s dev-sda7.device

╰─➤systemd-analyze blame --user 130 ↵
15.601s pulseaudio.service
7.725s xdg-desktop-portal.service
2.246s gvfs-daemon.service
1.093s xdg-document-portal.service

Most of the time you can disable this one without issues. For the rest you have to decide what actions to take, e.g. docker.

@CyberOto - can you let me know what command to disable NetworkManager-wait-online.service ?

For docker should I need to reinstall ? will it fix the issue

Disable and mask NetworkManager-wait-online.service. If I don’t mask the service it always starts anyway.

sudo systemctl stop NetworkManager-wait-online.service
sudo systemctl disable NetworkManager-wait-online.service
sudo systemctl mask NetworkManager-wait-online.service


you can try sudo journalctl --flush as mentioned here: Slow system boot time

@chomsky --Thanks for the input, have executed the commands.

tried flushing the system.

I tried rebooting the system but still the docker resources are consuming more.
I have killed the running container but still see some spike in docker service. Will a reinstallation of docker fix the issue ?

╰─➤ sys systemd-analyze blame
22.707s docker.service
12.710s containerd.service
12.631s snapd.service
11.554s lvm2-monitor.service
9.514s polkit.service
9.493s dev-sda7.device
6.524s systemd-journal-flush.service
4.264s systemd-udevd.service
3.975s var-lib-snapd-snap-brave-80.mount