Manjaro KDE - Limited connectivity

Hello everyone,
yesterday network manager on my lenovo laptop started showing limited connectivity and i’m unable to reach the internet. The issue only seems to appear on my home wifi network, connecting to phone hotspot seems to work just fine. Despite that the wifi works fine on all my other devices.
My phone has the ability to share internet connection over usb. My laptop connects to the internet when sharing my wifi this way.
I’m also unable to ping any website, google’s dns server ( and other devices on my home network.
I’m been running manjaro kde for a few months now and i never encountered the same issue.
I tried looking for solutions in other posts but nothing seems to work.
I would be grateful for any suggestions on what might be the problem. I’m not really sure what additional information to provide, so if you need to know more, just tell me.
Thanks in advance.

Try this:

There are various ways of dabbling with the 20-connectivity.conf file but a false setting is a quick way of determining if the connectivity check is the problem.

Thank you for you suggestion. Unfortunately this didn’t solve the issue. The “!” sign next to my wifi disappeared, but i’m still unable to reach the internet.
Another thing I just found out is that rebooting my router makes the connection work, but only for a limited period of time (5 minutes or so).

The router could be due for DNS cache flushing. Usually that means a complete reset.

1 Like

I had the same problem with my Lenovo Laptop. Fresh install could not find my in house wifi. Tried a number of things but couldn’t get wifi to work. Then I tried this. I plugged in an ethernet cable that was found instantly. Then I plugged in an old small TP Link USB Wireless Adapter I had hanging around. Bang, it found my wifi, I input my wifi password and I was good to go. Works for me. Happy Camper I am.