Manjaro KDE : Konsole and some applications which based on KDE display problems

JPEG_20190705_192059|666x500
Like this. Not only konsole has this bug,but krita has it too.
I have tried many solutions, such as renewing my video drivers, using non-free drivers, but it's all useless.
Other applications are normal,such as settings,vscode,vmware and so on.
My computer is GIGABYTE AERO 15 Classic XA ,i7-9750H,NVIDIA GeForce RTX2070 with MAX-Q Design.

Isn't that theme thingy?

Yeah , I have tried all the themes inside in KDE.
I also closed all window effects,but it is useless .

Change your compositor to opengl 3.1 and see if that fixes it.

System Settings -> Display and Monitor -> look on the right and you'll see Rendering Backend, use the drop down and select OpenGL 3.1. -> click Apply.

Thank you for your solution but it is useless either.
Another weird thing is ,when I want to print screen, it will disappear,so only can I use my phone to take a photo.

Output of

inxi -Fxxxz
1 Like

OUTPUT:
System: Host: DS-10001-RX Kernel: 4.19.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.2
tk: Qt 5.12.4 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: GIGABYTE product: AERO 15 Classic-XA v: N/A serial: Chassis: type: 10 v: y.y
serial:
Mobo: GIGABYTE model: AERO 15 Classic-XA serial: UEFI: American Megatrends v: B02 date: 03/28/2019
Battery: ID-1: BAT1 charge: 66.6 Wh condition: 94.2/94.2 Wh (100%) volts: 16.4/15.2 model: GIGABYTE Aero 15 type: Li-ion
serial: status: Charging
CPU: Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62232
Speed: 1742 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 3124 2: 3057 3: 3689 4: 3134 5: 3428 6: 3378 7: 3365
8: 3256 9: 3170 10: 3436 11: 2896 12: 3093
Graphics: Device-1: Intel UHD Graphics 630 vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile] driver: nvidia v: 430.26 bus ID: 01:00.0 chip ID: 10de:1f10
Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 resolution: 1920x1080~240Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.1.1 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a348
Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:10f9
Device-3: SteelSeries ApS type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2.2:25 chip ID: 1038:1282
serial:
Sound Server: ALSA v: k4.19.56-1-MANJARO
Network: Device-1: Intel Wireless-AC 9560 [Jefferson Peak] vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 5000
bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: up mac:
Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Gigabyte driver: alx v: kernel port: 3000
bus ID: 02:00.0 chip ID: 1969:e0b1
IF: enp2s0 state: down mac:
Drives: Local Storage: total: 476.94 GiB used: 51.69 GiB (10.8%)
ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW512G8 size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial:
rev: 004C scheme: GPT
Partition: ID-1: / size: 229.70 GiB used: 51.61 GiB (22.5%) fs: ext4 dev: /dev/nvme0n1p6
Sensors: System Temperatures: cpu: 59.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 297 Uptime: 3h 39m Memory: 15.52 GiB used: 1.65 GiB (10.7%) Init: systemd v: 242 Compilers: gcc: 9.1.0
alt: 4.9/4.9.3/8 clang: 8.0.0 Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34

Since its laptop are you using
Optimus manager or optimus switch to use nvidia??

2 Likes

No,I haven't used it before.

Then you are on bumblebee so you won't get to use nvidia to its potential

1 Like

OK,I have installed the optimus-manager and the problem is solved,
Thank you very much!!

1 Like

I am sorry to disturb you, but the problem comes back again..


I have reinstalled bumblebee and potimus-manager, and I haven't upgraded the kernel recently.

when I firstly noticed the problem coming again, I have run $ oprirun ,
and it shows:
[ 45.102151] [ERROR]The Bumblebee daemon has not been started yet or th
e socket path /var/run/bumblebee.socket was incorrect.
[ 45.102232] [ERROR]Could not connect to bumblebee daemon - is it running?
Then I reinstalled the software and checked my drivers.
and run $ systemctl enable bumblebeed
and reboot serval times,
but the bug exists anyway!

Recently I renewed my disk partition on Windows and grub has been broken, linux partition has changed its ID, but I fixed it. Is this something related to this thing?

I use the optirun to run Krita,and I recieved this:

If using optimus manager
Install optimus-manager-qt
Disable bumblebee.

1 Like

I get this as well on my computer.
I think it might be the nvidia driver itself and how it's working with Plasma or how Plasma handles transparency maybe?
I haven't found any kind of fix for it. It wasn't doing it before on my machine with the previous nvidia driver.

1 Like

I disabled bumblebee and it couldn't poweron now ...... I have reinstalled Manjaro linux.

I know how to solve this problem !
Disable your window zoom setting and all problems dissappeared .
But we can just set the font size to adapt screen.

1 Like

Glad you found a fix. Unfortunately, it doesn't work for me. :frowning:

I'm pretty convinced it's, in my case, the propietary nonsense from nvidia. I have two systems running the exact same Manjaro KDE. One has nvidia graphics, the other AMD.

Actually, I do have a fix. As soon as the AMD 5700 XTs come out from AIBs with better coolers (Not that stupid blower) I'll get one of those. Problem solved for me. :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by