Manjaro KDE Desktop does not fit in my 1080p Smart TV screen

Fellow Forum Members,
I am running my Raspberry Pi4B 4GB with Manjaro KDE Plasma which I am using as a set top box for my 32" Samsung Smart TV which is 1080p and has a 1920x1080 screen resolution.

The problem is my Manjaro desktop does not fit 100% onto my Smart TV screen space. The menu button on the lower left corner is mostly hidden as well as the entire taskbar at the bottom. How do I get my Manjaro desktop to fit perfectly within my Smart TV screen space?

My research told me to add the line of code shown below to Manjaro’s config.txt file to fix the 1080 problem:
hdmi_ignore_edid=0xa5000080

I tried it out and it made the problem worse. So I do not think the hdmi_ignore_edid=0xa5000080 code fix is right for my situation.

I hope someone out there can help me understand what solution I need to try so I can fix this problem because it is preventing me from controlling my Manjaro KDE OS. Thank you for your time.

I think what you are hitting is called overscan. I had to deal with that years ago when working with XMBC STBs… havent used a TV for a monitor in a long time though.

Check your TV Settings, you maybe able to disable/de-zoom: https:// www.howtogeek. com/252193/hdtv-overscan-what-it-is-and-why-you-should-probably-turn-it-off/ (remove spaces for link to work)

I did a few more searches, there are several articles about implementing “underscan” to compensate for fixed TV overscan in linux – i cant vouch for any of them as I worked with TV settings in the past to disable overscan, but you could search.

If you want to read more about the history of overscan and why it exists, there are lots of links out there, but it goes back to how CRTs used to work with the electron beam scanning…

I in the past a couple of times went into my smart tv settings and was able to shrink/expand the picture to fit my screen like @lrissman suggested.

1 Like

I believe Xrandr can handle overscan/underscan, maybe checkout metamodes in xrandr

It can indeed. Unfortunately I am currently not sufficiently well-versed to advise on the details. :slightly_frowning_face:

Yeah, I saw that in many of the links i found as well, but having never done it, I wasnt comfortable recommending one link over another. Here is an example of somebody using it for Linux Mint: https:// forums.linuxmint. com/viewtopic.php?t=291832

To me, if the TV supports turning off overscan, then all the problems go away… :slight_smile:

Thank you to everybody for your postings. Fortunately, I did not have to mess around with Xrandr because that software looks like it has a high learning curve. Nevertheless, what Irissman and Darksky posted about underscan and picture resizing gave me an idea. Why not just call Samsung TV Tech Support? Glad I did because the Tech showed me that buried deep in a menu within several submenus is an option called “Picture Size”. Here I was able to choose among 5 picture resizing options. I picked one called “Screen Fit” and that solved my problem.

Now my Manjaro desktop fits perfectly within the TV screen and I am finally able to watch all my favorite YouTube channels without being bothered with commercials which for those that don’t know, YouTube has recently increased in frequency by a ridiculous factor. I am controlling all of it using a mini Rii keyboard which is the coolest bluetooth keyboard I have ever used. In short, I think Raspberry Pi 4B with Manjaro KDE makes for an excellent set top box.

2 Likes

This same issue with my LG TV, there’s a setting in the TV for ‘just scan’ which brings the desktop to pixel perfection with no overscan… it’s a TV issue.

Maybe so, but the output of that xrandr command (on its own) will provide useful output so we can see whether it’s showing as a different display output when connected directly vs. via the dock. No parameters needed.

Agreed. But not all TVs have this option exposed in their menus (by default, anyway).

I have the same issue with one of my mates’ TVs by the way. Might experiment at some point.