Manjaro (KDE) completely black screen

Yesterday I updated some packages with pacman and today after logging in, my screen is completely black, the only thing that I can see is my mouse cursor and dropdown terminal.

It’s strange because I can open any program from the dropdown terminal and use it. But I’m not able to see my home desktop and taskbar.

has anyone had a similar problem and knows where I can look to fix this problem?

check with

sudo systemctl --failed
sudo journalctl -b0 -p4
1 Like


Maybe the same issue as mentioned here?


Ok, I think I got something with journalctl. It outputed those lines in red.

pam_env(sddm-greeter:setcred): non-alphanumeric key 'DISPLAY:0' in /etc/environment', ignoring
pam_env(sddm-greeter:setcred): non-alphanumeric key 'DISPLAY:0' in /etc/environment', ignoring

Yes, It was it!
Thanks man!

1 Like

hello I tried the journalctl i got a bunch of errors that show various functions are not working properly
what to do please help

Same here. Already tried these instructions wich are updating:

sudo pacman-mirrors -f3
sudo pacman -Syyu

Then startx that says:

Couldn't exec startkde: No such file or directory.

I have no: ~/.local/share/plasma/plasmoids/
There is /usr/share/plasma/plasmoids/
But no org.kde.plasma.eventcalendar in there.
Should I delete org.kde.plasma.eventcalendar or should I try this chroot thing ?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.