Manjaro KDE and Nvidia

kde
nvidia

#21

If your nvidia card required a legacy 390 series driver then you should probably be using … make sure though.

video-hybrid-intel-nvidia-390xx-bumblebee

You can switch using mhwd by removing one and adding the other … all driver management in Manjaro is done through mhwd.

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Also take a look at the bumblebee acpi kernel parameters thread I linked to above, some optimus laptops require these to work.


#22

1050ti uses the latest nvidia drivers, your problem booting can most likely be fixed with kernel parameters added to /etc/default/grub
sudo nano /etc/default/grub

find and modify the following line (copy/paste, this fails often because of syntax errors)

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2015\""
CTRL+X, then Y, then ENTER
sudo update-grub

reinstall your video drivers.
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

reboot


#23

Right you are, I didn’t check the OP, just the quoted text.

If this is a brand new optimus laptop then these have the most trouble with bumblebee.

Prime or Optimus-Manager may be better bets if the acpi kernel parameters don’t work.


#24

Perfect - thanks dglt / sueridgepipe.

This will be my mission tonight - to try this and see if I can get them working.

Kind Regards


#25

i agree completely with @sueridgepipe that prime or optimus-manager will always perform better than bumblebee.
if you really dont care about gpu performance, bumblebee will do fine and also your easiest option since mhwd installs it. its easier to disable one of the gpu’s in bios but iirc you dont have that option?

nvidia prime keeps both gpu’s on at all times so it uses a bit more power but works very well at all times, no need for switching (bbswitch,optirun,primusrun)

optimus-manager can be set to run X session in intel only or nvidia/intel mode, to switch between modes you have to log out and back in again but if battery is more important to you then this option is better for battery life than prime.


#26

@dglt

I thought I would respond to this as it has taken me a while to find the time to try this again.

I had success and then ultimately failure.

Using the ‘acpi’ and ‘Windows 2015’ commands in Grub didn’t work.

But adding the following did…

acpi_osi=! acpi_osi='Windows 2009'

This allowed me to have Manjaro running fine on the Intel Chip. So I updated Grub and I then followed your advice to use MHWD to install the hybrid intel/nvidia drivers.

after a reboot everything was fine, the drivers performed fine and all was good, until I realised it was still a fresh install so Octopi had 576 updates waiting for me. Stupidly I just let Octopi update them all without thinking about driver updates or anything else that may be included in the 576 packages.

Low and behold as soon as the update was done, I was back to a system that wouldn’t boot. I just got a black screen after Grub appeared and after I selected ‘Manjaro’.

So I need to retrace my steps until I get to the updates and try and work out what update may have thrown everything out.

But at least I had some success (of sorts).

Regards


#27

so as a quick recap, what drivers did you install with, what changes did you make, did you change drivers after install and if so which?

also, did you attempt optimus-manager and if so did you run
optimus-manager --cleanup before disable/uninstalling?

in any situation, you can make manjaro boot straight to a tty instead of a graphical environment by editing grub during boot,
on the manjaro grub selection hit E and then replace quiet with the number 3 and hit ctrl+x to boot.
login and try re-installing video drivers
mhwd -li (to list which drivers are installed)
sudo mhwd -r pci video-nvidia
(replace video-nvidia with the drivers that are currently installed, uninstall any/all listed drivers)

delete any video related configs (sudo rm -rf /directory/filename in:
/etc/X11/
/etc/X11/mhwd.d
/etc/X11/xorg.conf.d

now reinstall video drivers (example is for bumblebee in your case)
sudo mhwd -a nonfree 0300

given all those steps complete without any errors, check your grub config
cat /etc/default/grub | grep LINUX_DEFAULT
and make sure the desired parameter are listed, if not then
sudo nano /etc/default/grub
make changes, save/exit. then
sudo update-grub
reboot


#28

don’t disable nvidia gpu in bios. it makes not much sense to buy a laptop with dedicated gpu and disable it in bios.

just dont buy laptops with nvidia (if you’re disabling it anyway)

sorry didn’t want to repy to @torvic (not sure why that happened)


#29

i agree, its a waste, but some people prefer battery life over graphics performance, some have systems that just wont work with bumblebee like this one. or if it does work, needs acpi_osi parameters that make bumblebee work but also breaks touchpad or other devices functionality.
then there is also those who have a dGPU and just simply dont see the use for it with what they will use the system for.
different folks, different strokes and all that… :man_shrugging:


#30

Thankfully for me it is not the end of the world if the GPU doesn’t work. The laptop itself is really for programming and building Python classes and a bit of Java.

It was more a ‘nice to be able to’ jump into Steam every now and then to make use of the GPU, but really isn’t the end of the world.

What I will probably do just for sheer easyness, is to have Manjaro run via the Intel, and for Steam i woll probably have Ubutnu running Nvidia Prime (as that just works fine) for the occassional use of Steam.

In a couple of years I will be moving to a desktop anyway, so i can go down the AMD route rather than Nvidia.

Thanks for all your help with this.