Manjaro KDE and Nvidia

kde
nvidia

#1

Hello all,

I am due to take delivery of my nice new shiny laptop any day and I have a nice big M.2 SSD in which to have Windows and Manjaro KDE to dual boot into.

The laptop comes with a Graphics card (4Gb of Nvidia 1050ti) and uses the Intel I7-8750h CPU, however I have heard issues about getting Linux installed as many distro’s do not come with adequate drivers out of the box in terms of working with the Nvidia 1050ti.

My past laptops just have integrated grahics so this has never been an issue.

Does the KDE release of Manjaro have relevant Nvidia Drivers out of the box or will I need to follow a specific process to get Manjaro running through this graphics card?

Regards


#2

Each release has the same nvidia drivers, several sets are available, 340.xx and 390.xx for older cards, and 415.xx for the new cards.
The latter should support your 1050Ti.

However I have no clue about dual graphics, bumblebee etc.


#3

Thanks.

Given that the 1050ti has been around a while now, I am hoping it will be fine from the get go.


#4

search through the forum, lot of guides and instructions. I had a dell xps 9570 while back with the 1050Ti and never got it completely working as I wanted.

It also had other problems (mainly because dells bad BIOS stuff) so I sent it back and got full refund


#5

There are several different versions of the 1050Ti.
CHeck output of lspci and see whether the device ID appears in the supported list: https://us.download.nvidia.com/XFree86/Linux-x86_64/415.25/README/supportedchips.html


#6

I don’t particularly have a laptop with a GTX 1050ti but I do have a desktop with a GTX 1070 and I have never had any problems with it. On other distros I have had much more problems with graphics drivers. But not in manjaro. So I would assume that it will work with no problems, but I’ve heard and seen people having problems especially if they wanna use the bumblebee drivers.


#7

With laptops they tend to use optimus tech so you need to fiddle with bumblebee/bbswitch/prime and that can be a hassle


#8

Can you successfully boot the latest KDE live ISO selecting non-free graphics drivers?

If so what is the output of mhwd -li ?


#9

sueridgepipe - I shall find out when I get it tomorrow. It has only just been dispatched from the people that built it. Hopefully it will just work as is.

Thanks everyone else for the info. I will just have to see what occurs and then serach the forums to see any possible solutions if indeed there are issues with the drivers.

I can’t honestly say I wanted the Nvidia GPU - it just came with it and I had the option of the 1050ti or 1060.


#10

which laptop it is actually?


#11

If you don’t need it at all, it should be possible to disable it in BIOS, which would save you from a lot of trouble.


#12

yes it definitely should be but alot of times it isn’t. @sx200n if you have this option to disable the integrated gpu in bios, do it before you install and then select nonfree drivers and your setup should go smoothly. if not you can try booting as is with nonfree and that will install bumblebee (a boot/kernel parameter might be required for it to fully boot into a graphical desktop, ie, acpi_osi=! and/or others).

after install you can change to whichever optimus solution if your not happy with bumblebee. heres a couple tutorials for some alternatives.

PRIME tutorial
Optimus-Manager tutorial
note: there is also a brief explanation of the different optimus solutions on those tutorials. read up and decide which option fits you best and go with it.


#13

If video-hybrid-intel-nvidia-bumblebee works in a live environment you are golden.

If not you may require kernel parameters to get bumblebee working …

If that fails then optimus-manager or prime manual install may be required, depending on how much you want to use your nvidia gpu.

@dglt already linked threads for those.


#14

All,

Thanks for the responses.

The laptop in question is one I put together through PC Specialist which is based in the UK.

I have tried a good 5 or 6 distro’s on USB sticks just to see what happens, and all fail to boot. THey get part way through launching before failing.

With Manjaro it always gets stuck at the MHWD part of the boot.

Does anyone know a way of getting the LIVE USB to at least boot? I know I am likely to need to perform the install using the .modeset=0 command to get it installed, but I need to be able to boot the USB first, and I cannot get any Distro’s to boot fully (Ubuntu, Mageia, Manjaro (Deepin, KDE and Gnome all tried), OpenSuse).

Seems like I am stuck unless I can find away to get the USB’s to boot before I can alter the install method.

I will have a look in the BIOS and see what options I have to disable the GPU.


#15

this would be your easiest option. even if you intend to turn the intel back on at a later time and install drivers accordingly. it would at the very least make installation easier. if you dont have the option to disable the intel or nvidia gpu then adding kernel parameters are your best option to get manjaro to boot into the live environment. starting simple with adding acpi_osi=! may be all you need to get it to boot there are many others to try but that one often works. do you know how/where to add them?


#16

Thanks for the response.

Unfortunately no I do not. I have been a linux user for years over many Distro’s, used Manjaro and installed onto multiple machines over the last 5 years, yet never had any installation issues and therefore installing any form of linux differently to just pressing install on the live boot USB is an unknown to me.

Any pointers would be greatly appreciated.


#17

ok, start with this. im assuming your able to get to the installers grub screen? (where you select free/nonfree)

select nonfree, hit enter and then move selector to the “boot manjaro” selection (something like that) but dont hit enter and instead hit "e" and then find the word ‘quiet’ and delete it (it in the first line or 2) and replace it with exactly this :
acpi_osi=!
make sure there is a space before and after acpi_osi=! and then hit CTRL+X to boot. if that works, then install. if not there are other parameters that you can try. and after install is finished and you reboot, you will have to do the same at the manjaro grub line hit "e" and replace quiet with acpi_osi=! and CTRL+X to boot.

you’ll need to make this permanent after you install and boot into manjaro.
sudo nano /etc/default/grub
and edit the following line to look like this
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=!"
CTRL+X, then Y, then ENTER to save
sudo update-grub
and your done.

also, how you wrote the iso to the usb matters. etcher works fine, suse image writer, rufus, if you used rufus it must be written in “DD” mode. some of the others will result in not finishing boot.

here are some other parameters you can try if acpi_osi=! doesnt work, again replace quiet with one of the following:
nomodeset
acpi_osi=! acpi_osi="Windows 2015"
acpi_osi=! acpi_osi="Windows 2009"
acpi_osi=Linux


#18

I already gave you one … see the bumblebee acpi parameters thread I linked above.

Can you boot the live ISO using the vesa driver?

Did you research this laptop’s Linux compatibility before purchasing? Some laptops and their optimus implementations are Linux unfriendly.


#19

All, just thought I would update…

I have a working Manjaro, although I am sure it is not correctly using my Nvidia card.

Basically I found that I needed to edit the Booting of the USB image, but instead of using ‘acpi=off’ which didn’t work, I found I needed to ament ‘nouveau.modeset=1’ to ‘nouveau.modest=0’ and I was able to boot the live USB fine.

From here I was unable to install using the normal installation program as that just installed drivers that did not let me boot on re-start. So i used Architect to install and had to install only the ‘video-vesa’ drivers. All other drivers crashed when tried.

I also then editted Grub in architect to again use the ‘nouveau.modeset=0’ command at the GRUB_CMDLINE_LINUX_DEFAULT line.

Doing this now allows me to boot Manjaro perfectly well, despite being pretty sure Manjaro is not actually utilising my GPU.


#20

Now, following on from this, I have had Manjaro automatically detect the drivers from the system menu and it opts for the ‘Intel-nvidia-bumblebee’ option. If I install this, Manjaro seems to work fine, until I re-boot and then it just freezes. If I force it to install any of the other Nvidia drivers from the settings screen, it just hangs instantly.

So my quest is now to find correct drivers that will run it.

I can get Ubuntu running fine using the ‘acpi=off’ command and then installing the Nvidia drivers. But Manjaro seems to be finding it hard getting the right drivers.

In Ubuntu I installed the Nvidia 390xx driver and this worked perfectly, but the same driver in Manjaro does not.

Any thoughts on possible drivers as I am sure this is the last piece of the puzzle.

But if I cannot find one that likes my GPU in Manjaro, I will just dual boot along with Ubuntu (I have now removed Windows). It is really only for the occasional use of Steam that I wanted to get the GPU working.

Kind Regards