Manjaro KDE and dual monitor setup worst experience ever


I switch back to 2x 25 inch 144Hz monitors and use Manjaro KDE. First of all I thought my AMD 6600XT was the problem or maybe Kernel 5.13 but I try Cinnamon and there was no issue at all.
So, whats the problem?

  • after reboot/start, sometimes my second screen is black or got a wallpaper, which I never chose, one time it was the stock one, its working but changing the wallpaper almost every time I boot/restart
  • when the screens turn off (go in standby) anything is broken after they turn on again. I get huge borders on any window, this sometimes, not every time
  • when I open Spotify or a Browser, it’s unreal small, like 400x200 (need always to maximize)
  • going in standby means all effects are gone after I turn monitor on again

I update KDE and now I use 5.14 but nothing helps.
When the effects are gone I need to press shift + alt + F12 and anything works again.

I thought maybe it’s a AMD RX6000 problem and will be fix in future, because I only find issues like that with the new cards. Maybe someone can help me or confirm it.


There is an old bug in KDE, try to enable Background Contrast desktop effect (make sure it is ticked) in System Settings β†’ Workspace Behavior β†’ Desktop Effects. Once it is ticked, make sure the compositor in enabled in Display and Monitor β†’ Compositor. Reboot and see if it still β€˜breaks’ the desktop effects when monitor is plugged/unplugged/shutdown.

You can set windows rules for specific program, right click the window title bar, go to Additional Actions, and here you can select Window Rules, and add rules (like the windows size).
//EDIT: on my side Spotify remembers its window position and size so I don’t know why it doesn’t on yours. Pretty much the same with most/all programs.

1 Like

@omano thx! How old is this bug?
I will try this with Window Rules!

It’s that old 394890 – Compositing disabled on external monitor connection if background contrast effect is disabled Reported: 2018-05-31
See if it works for you.

For the Windows Rules you can see/modify them also from System Settings β†’ Windows Management β†’ Windows Rules

What? :smiley:
Thank you, I will try it later, need to go but I hope it will help.

You should’ve got this notification when connecting eternal monitor . As it says Alt shift F12 will make that dark demonic border go away .

so kde has problems with multi-monitor setups, not that surprising.

If you’re using wayland, try using X, if you’re using X, try using wayland.

if neither of these help you can try kwinft (it’s not entirely stable though so it could crash on you sometimes) it might handle multiple displays better.

If it comes down to it though, just use something else than kde.

plz post result of

Sudo pacman -S neofetch  &&

And do you have amd drivers

try running with tilling wm like i3

As someone who has 3x 144hz Monitors with Nvidia:

I have pretty much the same issues when it comes to Monitors going to Sleep resulting in Refreshrate being wrong and Effects not working anymore.

My only solution was to disable Monitor Standby in the Energy-Settings - I personally don’t mind it not going to β€œSleep”.

Then, when it comes to Applications like Dolphin starting not on the primary Screen and starting in a wrong resolution resulting in it being cut off because of different monitor sizes: I had to go into the Settings β†’ Window Management β†’ Window Rules and set a custom Window Rule for all buggy applications.

It’s not great. Multi Monitor setups don’t get much love sadly. In the past years it was also very recent, that Highrefreshrate Monitors got a bit of love by Linux Devs - but it’s still not perfect.

1 Like

Try what I suggested.

@Thenujan I never get this notification
@rabcor I dont even know, which one I use (it’s a display manager, right?) kwinft?

β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   xxxxxxx@manjaro 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   --------------- 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   OS: Manjaro Linux x86_64 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Host: MS-7B78 1.0 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ            β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ       Kernel: 5.14.10-1-MANJARO 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Uptime: 40 mins 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Packages: 1313 (pacman), 17 (flatpak) 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Shell: bash 5.1.8 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Resolution: 1920x1080, 1920x1080 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   DE: Plasma 5.23.3 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   WM: KWin 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Theme: Edna [Plasma], Breeze [GTK2/3] 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Icons: Tela-circle-dark [Plasma], Tela-circle-dark [GTK2/3] 
β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ   Terminal: konsole 
                               CPU: AMD Ryzen 7 3700X (16) @ 3.600GHz 
                               GPU: AMD ATI Radeon RX 6600/6600 XT/6600M 
                               Memory: 3139MiB / 32028MiB 

@alkl shift + alt + F12 is the only way for now, today my second screen get the stock wallpaper :smiley: it’s really bad :confused:

Try using different de like xfce

haha :smiley:
I like KDE but it looks like I need to switch.

Now I install new Kernel 5.15 and after screen turn down they dont turn on again, need to press reset button.

Kernel 5.15.2 has been causing some issues for a number of people. Try 5.14.18 (the version currently in Manjaro stable) just to be sure.

try kernel 4.14 and above as on mine many driver problem are solved by kernel 4.14 but come error on 5.10 and 5.15

I dont know why but it works now with the animatiion after standby but its still really bad with second screen.