Manjaro KDE 22 not booting

I am successfully logged into the not-booting Manjaro KDE 22 using a different Manjaro 22 installation using ‘manjaro-chroot’.

What can I do to fix the non-booting Manjaro KDE 22. It is encrypted. But I have successfully logged in as explained above.

I have updated it using pamac and tried to boot but it is stuck at the manjaro logo that comes after grub.

I have tried to boot it (directly) with various old kernels (already installed on it) but failed. It has kernel 6.3 to kernel 6.1 including respective recovery modes and backup initrams.

Nothing works. It takes the password and executes grub each time successfully, but after that it remains at the black and white Manjaro bootup screen that was introduced in Manjaro 22

Well, it depends on what you mean that you can login to that install. Non booting also depends what non boot is for your. If you can launch a TTY then the system boots:

  • Go to grub and select a boot entry. Press E on your keyboard to edit.
  • Look for the line with linux. It is the line above initrd. There you remove splash, quiet and add a 3 instead.
  • Press the keyboard combo CTRL+X to boot.

If your able to login to the TTY try sudo dmesg > output.txt. you can scroll thru the output via less output.txt. It is better to reboot into your other install and share this output.txt here with us.

1 Like

Hi Philm, thank you for responding. What is a TTY? Also, where was I supposed to add the 3? There was already a 3 after log priority.

I removed splash and quiet.

Then rebooted (see attached screenshot) using ctrl + x.

The attached screenshot is where everything stopped. You’ll see the mouse cursor there. Cursor was moving normally. But nothing progressed beyond the screenshot you’ll see attached to this message.

What next? I know how to ‘manjaro-chroot’ into this stuck installation, using another (properly working) manjaro kde installation, if that will help.

Screenshot is here: https://i.imgur.com/YRujoRR.jpg

Hi Philm,

Here is my output.txt that you asked for, at this link:

Remove/disable plymouth…

Hi cscs, how to remove/disable plymouth? My Manjaro KDE 22 (UEFI install) is encrypted.

You should be able from chroot
https://wiki.archlinux.org/title/Plymouth

By plymouth do you mean the black and white boot screen? If yes It is disabled already by removing ‘splash’ from the boot entries

Plymouth just appears to be the last thing shown here https://i.imgur.com/YRujoRR.jpg
Its possible its failing to terminate … I’ve seen it be the cause of failed boots before.
If you dont intend on using it then consider removing the associated packages.
(and removing it from initramfs at /etc/mkinitcpio.conf if it exists - then sudo mkinitcpio -P)

1 Like

Referring to your link:

I chrooted, then,
I removed plymouth from hooks in mkinitcpio and executed mkinitcpio -P and rebooted, same issue.

Should I add plymouth.enable=0 disablehooks=plymouth to /etc/plymouth/plymouthd.conf?

I’ve noticed that your system reported a hardware error. While this should not prevent machine from booting, maybe you should check it,
You can alse check the output of system journal (type journalctl and press “end” key to see recent entries). It shows more information than dmesg. It may be that your system is booting but X.org (or wayland or display manager) fails to start.
You can switch to different TTY when you see black screen by pressing CTRL+ALT+F2, and CTRL+ALT+F7 should bring you back to GUI session. In fact you can try to start another GUI session from TTY2 this way, at least when using xorg.

[ 1.098907] mce: [Hardware Error]: Machine check events logged
[ 1.098930] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 4: e600000000020408
[ 1.098960] mce: [Hardware Error]: TSC 0 ADDR fef5c000
[ 1.098977] mce: [Hardware Error]: PROCESSOR 0:506c9 TIME 1688152966 SOCKET 0 APIC 0 microcode 48

1 Like

I successfully disabled plymouth (by adding the commands to grub) but now the boot process is stuck at “Reached Target Graphical Interface” . The mouse appears and functions but nothing else. The attached screenshot is the last screen and nothing progresses beyond it.

https://i.imgur.com/4XZLF2Q.jpg

What should I do next?

can you in the stuck screen enter into tty, by pressing: ctrl+alt+f2 or f1-f6 keys, enter your username and password, and type:
startx
and take a picture of it…
also post pic of:
mhwd-kernel -li
mhwd -l -li
if you cant, post the output of the 2 commands, not the startx one from chroot…
and what did you do prior to the stuck screen? installing/ updating/ uninstalling … etc?

1 Like

Hi Brahma,

Attaching screenshot of mhwd commands from tty2:

https://i.imgur.com/ZoaEPar.jpg

Attaching screenshot of what happened after I used ‘startx’ on tty2.

After the “timeout in locking authority” message the screen went 100% blank for a minute (no GUI no mouse cursor) and then the rest of the messages appeared.

https://i.imgur.com/9JIUtF0.jpg

When I used ‘sudo startx’ it booted into the root GUI normally however my browser refused to run, dolphin ran but did not respond properly. I did manage to uninstall a few unnecessary programs using the ‘add/remove’ button while in the root GUI. System settings are accessible in root GUI.

What next?

I don’t remember what I did before this problem started but yes, the problem had started after installing and running kernel 6.3, after which I had switched to kernel 6.2 and everything was running ok. However I had switched back to kernel 6.3 after it updated recently, and this problem re-started and did not resolve itself after that, even when I tried logging in using 6.2 or 6.1 or the fallback initrams of 6.3, 6.2, 6.1.

Thanks!

Hi Sobrus,
Thanks. Yes, the hardware errors are not the cause.
StartX works but only when I execute ‘sudo startx’ at tty1 or tty2. If I execute just ‘startx’ at tty1 or tty2, I get a blank screen and error messages.

I posted the results of startx (without sudo) to Brahma’s message, but here it is again.

https://i.imgur.com/9JIUtF0.jpg

you dont run startx with sudo!!!


from tty remove the .Xauthority file:
rm /home/vikram/.Xauthority
reboot:
systemctl reboot
if it fails again, run again:
startx
without sudo!!!, and post pic

1 Like

Well,did you check if you ran out of disk space? XFCE sometimes still boots, but Plasma needs more bytes to write. Another option is to check if your home directory is still owned by the user and not got some files it has no access to. ls -lashi . would give you an info of the current directory. Maybe poke around. sudo pacman -Scc wouild clean your pacman cache and create some space.

du -h
df -h

1 Like

Thanks philm, cscs, sobrus, for your helpful insights!

Brahma, thanks, that worked!
And ok, will not use sudo with startx!!

Deleted the .Xauthority file and rebooted through kernel 6.3 and everything is back to normal. My files are back and programs are running as they always did.

What had gone wrong?

I’d like to understand, in order that I don’t make the same mistake again.

My installation is encrypted (UEFI installation, encrypted during installation)

Thanks a lot! :slight_smile: Problem resolved.

Hi Philm,

what is the difference between “sudo pacman -Sc” and “sudo pacman -Scc” and “yay -Yc” and “yay -Ycc”.

“yay -Yc” works on my installation but currently has nothing to clear.

“yay -Ycc” is offering to remove a lot of things amounting to almost 600 MB and giving some warnings as well, in the format of “XYZ optionally requires ABC”.

Removing optional requirements using “yay -Ycc”, would it be safe for a newbie like me?

I tried google for explanations, but the explanations were not clear.

I use bleachbit (junk remover) from AUR regularly (with some selected options only.)

Thanks!

we can also use paccache (use -h for infos or man)

exists option -d (no delete) et -vv (verbose)

examples

 ❱ paccache  -k0 -d       # rm all
==> finished dry run: 1488 candidates (disk space saved: 3.79 GiB)

 ❱ paccache  -u -k0 -d      # uninstalled packages
==> finished dry run: 122 candidates (disk space saved: 202.61 MiB)

 ❱ paccache  -k1 -d       # only keep the latest version
==> finished dry run: 48 candidates (disk space saved: 690.17 MiB)

 ❱ paccache  -u -k1 -d       # uninstalled packages,  keep the latest version
==> no candidate packages found for pruning

 ❱ paccache  -vvu -k0 -d       # uninstalled packages
==> Candidate packages:
/var/cache/pacman/pkg/blas-3.11.0-2-x86_64.pkg.tar.zst
/var/cache/pacman/pkg/blas-3.11.0-2-x86_64.pkg.tar.zst.sig
/var/cache/pacman/pkg/blosc-1.21.3-1-x86_64.pkg.tar.zst
/var/cache/pacman/pkg/blosc-1.21.3-1-x86_64.pkg.tar.zst.sig
...
1 Like