Manjaro-KDE 19.0-pre3 (stable branch)

I am really liking how this version of KDE is shaping up. I really like the simple menu. I do have a couple of questions.

  1. Can I set the "meta"/ "windows" key to open the simple menu? As it stands right now, in my KDE VM this is not possible (even when the shortcut is set to the reccomended alt+F2).

  2. With the new settings package, is KDE finally simplifying their settings menu, or will I still have to go to three different places to change the theme or disable animations, for example, instead of one section in the settings?

  3. Minor niggle - I KNOW this is bad practice, I KNOW this is not recommended, I KNOW this is dangerous, etc... and I do this only when I am working on a project, can one open Dolphin as root?

I would love to switch over to a "lighter-weight" DE than Gnome, but questions 1 and 2 are why I still use it. Question 3, as I said is a minor niggle but would be a "nice to have". I hope the questions make sense.

Thanks!!!

There is a discussion here (https://github.com/thesofproject/sof/issues/2134) that seems to apply. Maybe the best path here is to wait for upstream fixes to make their way?

We have to see...

  1. Set it to Alt + F1, and Meta will work then too.
  2. With this number of settings in KDE it is a hardly doable thing. However, Plasma devs do all they can.
  3. This will be implemented in some way soon according to what I read recently.
2 Likes

One thing that is not clear to me: shouldn't those changes already be in unstable branch, including newest KDE version?

Or are parts of "-pre" release actually available via different packages?

Basic flow of upstream -> unstable -> testing -> stable is very clear to me, but I'm not clear on why things that are mentioned to be available in stable are not in unstable... I guess I must be missing a piece..

And yeah I've refreshed mirrors and cache :slight_smile:

Yes, the new breath2 theming comes via new package(s), see


Older versions are already available in stable as well.

Look a few posts up! :wink:

1 Like

I believe the approach will be like what was recently implemented with kate. That is, use polkit to ask for your password when you need it. So, if you use dolphin to mv cp or rm a file you do not own, then it will ask for your password.

1 Like

All you should have to do is switch to the alternative menu. For me the keybinding just continues working.

1 Like

@linesma, @openminded I hate to break it to you cause I want the feature back but if you believe for even a tenth of a second that the KDE devs are actually going to restore root to Dolphin I truly feel sorry for you. They have had way more than enough time to restore it and yet they haven't.

Thank you everyone for your replies. I truly do appreciate it.

@openminded Unfortunately that key combination did not work. I even rebooted the VM before testing it again.

@oberon The "meta" key works properly on what is used by default. However, when I switch over to "simple menu" or "application dashboard", the setting did not transfer over to the "new" layout. It also does not "come back" if I switch back to the default "menu". I even waded through the myriad of settings in the "settings" program to try and find if there was another setting that was conflicting with it. I was unable to find anything.

@mparillo That would actually be perfect. I actually prefer a solution like that over opening the whole of Dolphin as root.

@xXWhackerXx I know that they might not, but one can dream.

Once again, thank you everyone for your replies.

You did rightclick the panel, chose edit panel, then mouseover the application button, and from the dropdown menu select show alternatives, and then switch you launcher from there?

Yes, that is how I changed what I was using as an "Application Menu".

The it Sounds like you have a bug. I'd suggest you head over to KDE's bug reporting site any file a report.

It depends on the VM software. Sometimes some key combinations are reserved for the host and not for the guest. Try to set it in settings with keys that are working.

I cannot reproduce this. For me Super Key opens the menu, no matter which, also in virtualbox.
The only issue I have recently with vbox is that both the host and the guest menus respond to the Super key :wink:
This would be a bug not of KDE, but of virtualbox. At least the one in my case.

@philm and @oberon Thank you both for the information. I use VMWare Pro for all of my VM's. I do not think it is a problem with VMWare Pro. I use the same settings when setting up my VM's and in my Gnome and XFCE VM, the Super Key will open the Application Menu. Since it is a VM, I have no problem wiping it out and re-installing. Maybe I did something to it when I was messing around with some customizations. I will let you all know what happens.

Thanks again!

When Manjaro-XFCE 19.0-pre3?

Okay, a re-install in a VM fixed the issue. I must of changed some obscure setting somewhere that disabled the Super Key. It is now working properly with Simple Menu.

Thank you all for your ideas and help.

1 Like

Best look in the announcement section:

2 Likes

Forum kindly sponsored by