Manjaro KDE (17.0)

release-final
gellivara

#42

Is there any difference in single stream output if i use the alsasink with mpd for example vs JACK?


#43

Glad that you like it mate. Things are going great here I think, been reading news all over the internet about Manjaro new release.

Howdy guys, long time no see. :slight_smile:


#44

its true. Ive converted 4 ppl to Manjaro. With that rate we are going to be millions within 2-3 years :slight_smile: havent seen you here in a while


#45

My update to version 17.0 did not go well on deepin and xfce, but they are solved now and I’m a happy Manjaro user again! Due to the problems I encountered, I downloaded also the KDE iso. I’ve never took it for a spin, because I didn’t like the DE when I tried it with Mint, a year ago, but THIS KDE IS BEAUTIFUL AND SEXY!!! Kudo’s for the developers. I’m still running it in virtual box, because I’m not very familiar with the enviroment, but I think Deepin (and Gnome, because the Deepin problem isn’t solved yet and I switched to Gnome) will be replaced by it.


#46

With the announcement of 32-bit Arch going the way of the dodo later this year, I knew the writing was on the wall for my Asus netbook (didn’t like it anyway, really slow), so I bought a refurbished Dell laptop with an i5, swapped out the hard drive for an cheap SSD and installed the new KDE ISO last night using the automated full erase option.

My first install worked but I received an Invalid Partition Table message on each startup before GRUB, so I changed some BIOS settings to allow a UEFI install and so far so good!

One question for the community: Is there anything special that needs to be done post-install when installing to an SSD in the year 2017 or is all setup optimally automatically by default nowadays?


#47

I did a fresh install (manjaro KDE 17.0) and two bugs appeared.

1st: After every boot when I click the default buttom in desktop, the whole screen turn to black and the interface restarts.
2nd: Afte a few minutes of use when I try to turn off the computer it tooks some time (like 20 seconds after a froozen screen) to show me the pop up with the action buttons.


#48

This the most easy Manjaro KDE installation ive ever did. No problems at all. Everything worked OOTB. There was a small issue when trying to reboot after updating kernel to 4.10.1.1. PC was stuck and i rebooted manually. After that no such problems. But i got this prob every time so i got used to it :smiley: Well done guys. Best release!


#49

You want to check if fstrim.timer is enabled.

systemctl |grep timer

Then you want to peek at your /etc/fstab ad look for any lines that have the option “discard” and remove that option. This will prolong the life of your SSD.

A new explanation by the guy who wrote or maintains much of the Linux filesystem low level drivers, Ted Ts’o:

This is his long standing recommendation: use fstrim triggered by a timer, and avoid discard in the fstab.

Its a follow up on his original 2009 article, and he is basically doubling down on this recommendation.


#50

In the KDE distro I followed this different approach in which you run PulseAudio through JACK. Seems to work OK so far and I retain system sounds/notifcations.

https://wiki.archlinux.org/index.php/PulseAudio/Examples#PulseAudio_through_JACK


#51

Just news from distrowatch.com

Hits per day: 12 months: 4 (1,268), 6 months: 3 (1,453), 3 months: 3 (1,711), 4 weeks: 3 (1,671), 1 week: 2 (2,233)


#52

Good to see you again!


#53

I couldn’t find anyone on the web who got Jack to work with MPD so here’s how I did it and got Cantata to play PulsuAudio Jack Sink. It might help someone sometime.

Just follow the the wiki in my previous post to allow PulseAudio through Jack then modify mpd.conf as shown making sure your system settings has Jack Sink selected.

Cantata works fine now and plays nice tunes :slight_smile:


#54

any quality differences between jack and direct alsa sink (playback usage only)?


#55

Subjectively I’d say very much so. In QjackCtl you can adjust parameters to suit your system and the way you use it.

I believe also, that as of v 52 Firefox no longer plays ALSA sound so another reason to use PulseAudio.


#56

@philm
Someone (@dlitvak98) has the same error (segmentation fault) with both 17.0 versions, KDE and Xfce. It is something about locales.

Logs are here:


#57

Am I doing something wrong when trying to install with a custom filesystem in a 32 bit vbox?

I select manual partition, then partition the entire virtual disk as / with xfs as filesystem. After clicking next the installer crashes after a while.

Do I need to set up the /root and /boot manually when doing this?


#58

if you are doing EFI install i think you must make a FAT32 partition with /esp flag but for legacy install i think just “/” partition have to be enough. Try re-downloading and check hashes.


#59

Nope, I used MBR (msdos).

I reinstalled by entire system the other day and didn’t have this problem with the x64 KDE edition, choosing manual partitioning and partitioning one single / partition as xfs worked fine. So this could be an issue specific to virtualbox.