Manjaro KDE (17.0-rc3)

release-candidate
gellivara

#1

Manjaro Fringilla was a great release! Now we are proud to announce our third release candidate of our next release, we call “Gellivara”. It took us more than two month to prepare this new release series for 2017.

During the development cycle of Gellivara we optimized and changed few things:

  • In the past we have used numbered versions. Currently we are using versions based on the release target month which, on a rolling release, might point to a monthly based versioning of our install media. However, they only reflect the status of our tools and installer. Also this creates the impression of some of our community releases being newer than the core releases, when in fact they are using the same base and were simply published on a later date. Therefore we are back using numbered versions, however slightly different than in the past.

  • Depending on the development we might release three major sets of install medias with new features. If we find some issues in the original install media, we may update them for fixing bugs, which will then be a point release of the same series. Also we will discuss if we change the code name of the releases this year, or keep one for the whole year.

So what will be the features of the new release series:

  • We updated the stock kernel to linux49 4.9 LTS
  • We updated the Xorg-Stack to v1.19 series
  • We enhanced and improved our Manjaro Tools & Profiles
  • MHWD we adopted to handle a more efficient way to handle libglx binaries
  • Some of our themes got updated and new got designed

Changes since RC2 release:

  • without plymouth installed
  • kernel v4.9.13
  • newer linux-firmware
  • wayland v1.13.0
  • fixes to octopi

Changes since RC1 release:

  • updated Breath wallpaper
  • updated gstreamer packages
  • updated mesa-stack
  • updated documentation
  • [CAL] Add optional config value neverCreateSwap in partition module.
  • [CAL] Improve EFI configuration check in grubcfg.
  • [CAL] Improve EFI configuration check in bootloader.
  • [CAL] fixed two bugs in packages module

Changes since Beta3 release:

  • Plasma 5.9.2
  • KDE Frameworks 5.31.0
  • Full profile

Changes since Beta2 release:

  • Plasma 5.9.1
  • KDE Apps 16.12.2
  • VLC Nightly added
  • Manjaro Hello 0.4.10
  • Fixed some crashing issues with Xorg-Server
  • [CAL] partition: use always double click to activate a partition tree view item
  • [CAL] netinstall: moved module to a tree based UI
  • [CAL] welcome: Add fallback check for internet connection
  • [CAL] partition: Don’t hardcode /dev/sd* as device path.
  • [CAL] packages: Make try_{install,remove} more robust.

Changes since Beta1 release:

  • Plasma 5.9.0
  • Mesa 13.0.4
  • Manjaro Settings-Manager 0.5.0
  • Network Manager 1.6.0
  • Octopi 0.8.7
  • QT 5.8.0
  • [CAL] fix for an issue in the users module, which could break login if the chosen password had non-Latin1 characters
  • [CAL] proper exception handling in the networkcfg module
  • [CAL] improved autologin configuration handling for sddm.

Changes since Alpha releases:

  • fixes for EFI installation
  • gcc updated to v6.3.1
  • xorg-stack v1.19
  • KDE Apps v16.12.1
  • KDE Framework v5.30
  • Calamares 3.0 includes countless fixes and improvements to the core application and to the modules, as well as an all new PythonQt-based module interface. The PythonQt interface is optional, and allows module developers to create view modules in Python with Qt.

For those, who already want to test our latest install media, you can find them on SF.net.


Critical boot failure
#2

Unable to find mirror… :disappointed:


#3

Same problem as was for rc-2 iso … From your link i get this:

Then browsing for the file in the rc3 folder i get this:


#4

Guys, I’ve just uploaded the ISOs. Why do you all have the need to install these ISOs right after my announcement? SF.net had changed the way they mirror. It takes longer now to get it done with larger files bigger than 700 MB. For XFCE it took about 5 hours to sync to their mirrors. Be more patient …


#5

The best time for me to do things for my own is when i drink my coffee, then i have to get back to my commissions. I was thinking that if SF shows modified 20 minutes ago is a sign that they already have the file ready for download. My bad! please don’t take it as a sort of harassment :grinning:
I was never so excited about a linux distro, and i tested a few (more than 20), and this is the first time i got involved in a distro forum. Thanks for moving so fast to get the final release done!!! Cheers!


#6

So do I. No offence.


#7

All good. SF.net fixed it now.


#8

The download was very fast this time. Installation went smooth and even faster on VM than previous rc.


#9

I have recieved the updates, but ‘lsb_release -a’ says Fringilla 16.10’.
Am I not running '17.0-rc3?

Regards


#10

The all black screen reported for kde-17.0-rc2 still occurs for kde-17.0-rc3.

FWIW, I tried the xfce-17-rc3 and the desktop loaded & displayed normally, except that the windows are placed on the non-viewable screen/display(same issue as with kde-rc2 & -rc3).

:sleeping:


Update: Power outage due to storms (and poor maintenance by ENTERGY) so no tests for two days, or so they say … :frowning:.

Update: Power’s back on …


#11

Why not search the keyword on the forum? https://forum.manjaro.org/search?q=lsb_release
The file /etc/lsb_release gets updated with the next stable release of Manjaro 17.0, AFAIK.


#12

Black screen (nvidia gtx 970) with nonfree drivers

free (nouveau) never worked


#13

Working with video-catalyst nonfree drivers ((radeon r9 280x tahiti xt)
working with video-ati free drivers


#14

I’ve plymouth-legacy installed with 17 RC1, should I remove it?


#15

Install on Macbookpro hybrid GPU mid 2015:

  • IGPU deactivated / dGPU activated => as RC2 works fine
  • iGPU activated /dGPU deactivated => as RC2 works fine
  • iGPU activated / dGPU activated:
    1. RC2 => hangs on loading screen everything is unresponsive
    2. RC3 => Loading screen hangs but TTY is accessible
    MHWD tries to install bumblebee and returns errors about the dGPU
    Tried with free and non free drivers results is the same.
    logs and config files:
    https://expirebox.com/download/d40065c75bcd82a5b094ab5f06512f46.html

Once installed with first 2 options, if mhwd is run, the result is the same as with the install media (bumblebee fails).
I can do more tests if needed.


#16

The problem with swap activation that I mentioned in rc2 still occurs. no swap at all


#17

Installed on an Intel Xeon machine, no problems.


#18

Native install on i7 960 and Nvidia GTX 650. No problems to boot the installer, no problems after first boot, no problems after installing the proprietary drivers using mhwd.
As a side note, on rc2 i could log into plasma-wayland-session with the nouveau drivers, crashing after some time. On rc3 i can’t do that anymore. No chance at all with the proprietary driver.


#19

Easiest way:

aria2c https://sourceforge.net/projects/manjarotest/files/kde/17.0-rc3/manjaro-kde-17.0-rc3-stable-x86_64.iso/download

IF mirror fails, retry :wink:


#20

Company’s sending me a new laptop today, so I’ll be installing this later. Copied to USB.


Getting back to Manjaro