Manjaro is not booting after dual booting

I have a windows laptop, I dual booted it with Manjaro KDE. after restarting the laptop was booted directly into windows (no grub menu).
Please help.

output results of:lsblk -f

This can be caused by:

  1. Wrong boot sequence (can be set in the UEFI Bios)
  2. Can you post /etc/default/grub ?

I turned on my computer and it instantly booted to manjaro without even showing the thing tht suppose to show to boot to Windows 7 or Manjaro. I restarted it many times and the same thing happened.
I also suffered the somewhat same issue just now can someone please help me
Also Im new

I’m also a Linux beginner, and this also happened to my Win10 + Manjaro KDE dualboot machine. I fixed this by running this command in the terminal:

echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

This happened after a behavior change after the latest stable update that changed the behavior of GRUB_DISABLE_OS_PROBER.

This fixed my issue, hope this fixes yours too.

Hey where to type the above command you mentioned, after installing Manajro kde I.e. before rebooting when the installation is done as for me after dual booting kde with win 10 I don’t see Manjaro in boot option just win10

first check your UEFI seting . do you have secure boot ,if has disable it.
then select manjaro as first boot. save and reboot .
if you yoy have done this . if you boot into manjarao without grub should chang grub config to graphical mode.

My secure boot is disabled,

i checked for Manjaro in Boot os list in the bios settings and there was only showing Windows 10 .

For testing purpose I tried same installation method I have used on Manjaro with Garuda Linux - manual partitioned 512MB Fat32 boot-efi flag ; 2048mb swap; rest as Root and on boot menu which is F9 for my HP laptop I see both Windows10 and Garuda Linux and also in BIOS settings Os Boot order ther it showed win10 and Garuda Linux

Again for testing purpose I tried same above installation method(manual partitioned 512MB Fat32 boot-efi flag ; 2048mb swap; rest as Root) with Manjaro Gnome and XFCE which worked with dual booting i.e. I was getting both Gnome+XFCE and Win10 in boot menu and os boot order in BIOS settings. So I think it’s only for Manjaro KDE only which didn’t work.

New Update- the new 21.1.5 version for kde is working