Manjaro Installer does not install Grub Bootloader (I think)

As it is my first time using GNU plus Linux, I am very inexperienced with this subject. I downloaded the XFCE 18 beta-4 ISO from the official website, used Rufus to create a bootable USB and tried to install. The issues I encountered along the way were that the USB would not boot or show up. I fixed these problems by having Rufus use a GPT partition scheme and install in DD mode (Disk image mode) as opposed to the default ISO mode. Through googling, I have found that since I am using a UEFI without CSM system, for some reason, the boot only works with that configuration of Rufus settings. Once the ISO boots up, I select nonfree drivers and continue with the installation. I walk through the installer process, select the 50GB partition I had created for this Linux installation, and continued with the install process. Once the installer completed, I reboot into… Windows 10? Confused, I check my BIOS’s boot options and the grub bootloader and it is not there. IMPORTANT I got no errors during the installation process, however, when rebooting out of the live USB, the outputs on the screen are all prefixed with a green OK, with the exception of one failure: failed unmounting /run/miso/boot. More OK’s appear after that fail and I boot into windows. It is possible that I have missed something because I am so new to this. I am completely stuck and have no idea what to do.

Welcome :slight_smile: , best search tool in town :wink: upper right :smiley:

Hope you also created and selected a small (about 150 MB) fat32 partition and mounted it as /boot/efi.

If you did not, make one and follow the link SGS provided to boot into Manjaro, making sure it is booted in UEFI
o make an fstab entry for it (fat32 partition)
o mount it as /boot/efi
o grub-install

And you’re good to go.

If you need help, after creating that fat32 partition, as in the link, provide
efibootmgr -v
sudo parted -l
sudo blkid
cat /etc/fstab
findmnt /boot/efi

o Please reread the wiki on UEFI installation.

1 Like

Thank you for your help. However, the wiki tells me I should use the windows boot efi partition since I am performing a dual boot. Is that correct?

1 Like

You can use the same $esp as windows and do not format it during partition.
Or you can use a new $esp for linux OS’s.
Whatever you do, you must select and mount that $esp as /boot/efi during installation.

When walking through the graphical installer, the installer says that the windows esp will automatically be used. However, when rebooting after the install process, I run into the same error. Failed unmounting /run/miso/boot

Is a problem with not making a good install usb.
Please tell us how you made this install usb.
But others have to jump in here to help you on this. {thanks to the others who jump in here}.
(I rarely make installation usb’s and when I do, I use linux ‘dd’ commands)

Good night.

I used both rufus on DD mode set to GPT and ImageWriter for Windows, both recommended applications by the Manjaro Wiki. Thank you for all your help with this.

I still and always select and mount any existing $esp.

So I select the manual partition mode then? If that’s the case, do I need to make a home and swap partition, or can I just make a root one and use the windows esp and then home and the swapfile are automatically generated? I can only have the total partition of root, home, and swap add to about 54 GB

Yes, you’re right. I always do my installation in manual mode. I’m now unfamiliar with auto mode installation.

home and swap partitions are optional.
Up to you . I normally do not have these unless swap partition is already existing.

The manual partitioning didn’t work. I set my 54 gb partition as / and my windows esp to /boot/efi. The same failed unmounting /run/miso/bootmnt error appeared

The Grub installer is totally broken. For the moment I use refind but grub should be fixed soon. Spend a whole day to find out that’s a bug.

If that’s the case, what should a newbie like me do?

Morning. Use this link from the given link above.
Read thoroughly and provide the information listed there if need further help.
Not providing information or complaining about it gets us nowhere.

The link above worked! Thank you for helping me.
Following the steps from

did work for me. Thank you again.

1 Like

Similar problem even after a fresh install., I still get this the second time.

Any help?

Read the link above your post.

I exactly had the same problem that op has mentioned here and I fixed it with a simple command in cmd.exe (with admin privileges) in windows 10:

bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi

And if anything went wrong with above command you can fire this:

bcdedit /deletevalue {bootmgr} path \EFI\Manjaro\grubx64.efi

Thanks, I actually did a fresh install. Since it wasn’t a duo-boot.


1 Like

Forum kindly sponsored by Bytemark