Manjaro Installation not visible to other OSes

I have four OSes installed in my laptop -

  1. Manjaro with btrfs,
  2. Widoze 10,
  3. Manjaro with btrfs and
  4. KDE Neon with ext4.

#1 is in a 240 GB SATA SSD. #2, #3, #4 are in a 1 TB HDD.

Yesterday I restored a snapshot in the #3 Manjaro. But after that when I ran sudo update-grub from the other linux distros, the #3 Manjaro installation is missing.
I have tried reinstalling grub, but of no use. I can still boot to the #3 install from system boot menu, though.
The output of efibootmgr from #1 installation is:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,3002,0000,0004,0006,0005,0003,0001,2001,2002,2004
Boot0000* Windows Boot Manager
Boot0001* EFI Hard Drive 1 (WDC WD10JPVX-60JC3T1)
Boot0002* Manjaro
Boot0003* EFI Hard Drive (ADATA SU630)
Boot0004* Manjaro-KDE
Boot0005* EFI Hard Drive 2 (WDC WD10JPVX-60JC3T1)
Boot0006* neon
Boot2001* EFI USB Device
Boot3000* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk

The output of lsblk -f from #1 is :

├─sda1  vfat   FAT32 NO_LABEL EAC6-754A                             298.8M     0% /boot/efi
├─sda2  btrfs                 f4ae58f0-4627-46b4-bcfd-2e8ea973725c  205.3G     4% /var/log
│                                                                                 /var/cache
│                                                                                 /home
│                                                                                 /
└─sda3  swap   1     swap     a7bbc70d-a9e1-4652-88ca-adc8dc8987a8                [SWAP]
├─sdb1  ntfs         Recovery 164E4C2F4E4C0A47                                    
├─sdb2  vfat   FAT32          4A4E-DD30                                           
├─sdb4  ntfs         Windows  F4D45499D4546042                                    
├─sdb5  ntfs         Recovery 2E4441064440D26F                                    
├─sdb6  ntfs         Library  C40A19B30A19A388                                    
├─sdb7  vfat   FAT32 NO_LABEL E846-3EBF                                           
├─sdb8  btrfs                 f9528c8d-9109-4df8-9ac9-585afc499ee1                
├─sdb9  swap   1              4faaaa17-670f-4166-bac2-6ba8bf9ff2b1                
├─sdb10 ext4   1.0            b8aa4c1f-518f-48cb-ace4-d7413b00c8c7                
└─sdb11 vfat   FAT32 NO_LABEL D48B-6A12                                           

What should I do? :face_with_thermometer:

you have 2 x Manjaro ?

anyways you can burn supergrub 2 iso, boot from it and let boot entries be detected, select the missin os entry, boot up and reset grub

Yes, the one on HDD is older. A few days ago I installed the SSD, so I was shifting stuff from older to the newer installation.

OK, I will keep that in mind :slightly_smiling_face:. But the two installations have different boot-loader entries and both of them recognized each other fine until yesterday. I want to know the reason what is causing the issue now.

Btrfs can be a problem in multi boot situations if /boot subvolumes can’t be read by an OS prober. One way around that would be to have only one Btrfs installation and use ext4 for the others. For example, if you’re using #1 Manjaro’s grub menu, and #3’s Manjaro was ext4 instead of Btrfs, both Manjaros should show up in #1’s grub menu no problem.

There’s a technique for getting multiple Btrfs installations showing up in a grub menu. I’ve never done it but it probably involves separate ext4 /boot partitions instead of /boot being hidden from OS probers in a Btrfs subvolume. It’ll also require fstab edits laying out Btrfs subvolumes, and no doubt there are other steps.

Another multi boot issue is that Arch based distros load CPU microde in a way that causes OS probers to skip menu blocks in grub.cfg. A workaround for that would be to manually copy/paste menu blocks from one grub.cfg file to the other.

1 Like

🥲 Thanks a lot for the great explanation! :slightly_smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.