Manjaro installation not booting in uefi

Hi, My hp8470p is now screwed.
The recent update with libcanberra conflicts broke my system. The system has a broken lockscreen and stays only with a cursor on a black screen. The Login screen has some Errors on the theme. I decided to reinstall everything and heres how my 24hours are lost.

I’m reinstalling the Os not via bootable and both mbr and gpt installation are successful.

However once I booted into MBR, Os works fine just until i do the pacman Updates including removing libcanberra. When I restarted, the Os will has a broken lockscreen and will stuck on the loading manjaro splash screen.
Now after second reinstall on mbr, the kernels are lost. Grub only shows memtest.

My Bios is not set to read in UEFI hybrid with Csm.
Resinstalling everything under GPT was much worst.
The Os was successfully installed, allocated Efi partition, swap partition and the root. Problem is the Os now isn’t detected by the laptop. Even Grub. I tried chrooting and reinstalling grub only gives me memtest only . The Kernel installed was 5.8.

On the recent update about libcanberra, I removed them through ‘sudo pacman -R’ not on pamac. Pamac was doing errors and hanging on warning about reils if I’m not mistaken. I tried updating everything on pacman and everything was updated but after a reboot, the system was totally broken right after the login screen.

That’s why I decided to reinstall the whole Os.

Kernel 5.8 is EOL and not there in the repo anymore. And since it is not there, it gets removed. Install a current LTS Kernel:

sudo pacman -Sy linux510


mhwd-kernel -i linux510

No wonder when the kernel is outdated and you installed Manjaro with an outdated ISO. Use a current one.

1 Like

Mhwd-kernel is throwing error, even 510 is specified. It’s showing no target specified.

Then the repo database have to be updated.

Pacman-mirrors -f has been initiated , as well as pacman Syyu. Ni actionto be done uss already returning to pacman updates. That keeps me wondering why it breaks when I Update.

What says?

mhwd-kernel -l
mhwd-kernel -li
1 Like

-li shows 5.8 , but -l shows a list of kernel versions. That’s why I was annoyed because even 510 is in the list, its says not specified

sudo mhwd-kernel -i linux510



1 Like

Still target not specified . Sir

I’m downloading the new Iso, my installer now is failing in creating gpt partition. :frowning:

Are you downloading the 21.0.7 from Manjaro website, or RC (21.1.0 RC3) one from GitHub? [If you download the 21.0.7 iso, if will most probably have to update to get to the latest version, i.e. 21.1.0 RC3]

I just downloaded the newer Iso hopefully skipping the libcanberra update block on pacman which causes problems i removed libcanberra and other related packages.

To skip the libcanberra problem, all you have to do is:

pamac update

Pamac handles it without problems.

1 Like

Yeah, I’ve tried before starting from scratch. As I’ve mentioned, my previous system was hanging with pamac update. No idea why, I have internet, mirrors are updated. Gui isn’t even working so seriously, there’s something wrong with my system. Now after the latest Iso installation, I’m making a time shift backup incase the updates from pacman breaks again

It’s 21.0.7. so I am updating pamac / pacman after making a timeshift backup because I have no separate bootable device. I’m using them both for windows and manjaro so I can not just burn the iso everytime I



up my system again.

You could actually download 21.1.0 RC 3 (latest as of now) from GitHub: Release 202107281031 · manjaro/release-review · GitHub

  • The .iso files in GitHub are stored as split archives (.iso.z01 and They both are to be downloaded and then extracted using 7z.
1 Like

Oh, thanks. I’d take a look on that. That’s gonna be my last resort now.

Did you check pacman logs (/var/log/pacman.log) or system logs (journalctl -b -xe) to try to find the problem?

1 Like

Nope actually, I had no time going back and forth with logs earlier because the work is really on a pending status. I manage to reinstall manjaro successfully again through MBR with the new ISO.