Manjaro installation does not boot

Hi, I’m new to the forum.

I have installed Manjaro on a couple of thinkpads without issues. I’m now struggling to get an installation to boot on a desktop system.

I saw this post: Can't boot manjaro after installing it
which has some similarities, but I’m not dual booting. I think the issue is with the grub installation. When the system reboots, it hangs and I get a message that it cannot find an OS.

Here’s what I get from efibootmgr (I have deleted a couple of entries after reading the above post. Apparently the system had Red Hat on it at some time, whcih were Boot0004 and 0006).

[manjaro Manjaro]# efibootmgr
BootCurrent: 0007
Timeout: 0 seconds
BootOrder: 0005,0003,0001,0007,0002,0000,0008
Boot0000* boot HD(1,GPT,3086d8eb-f446-40be-b527-64fad794d259,0x800,0x100000)/File(\EFI\boot\grubx64.efi)
Boot0001* ST9500325AS BBS(HD,0x0)AMBO
Boot0002* IBA GE Slot 00C8 v1381 BBS(Network,0x0)AMBO
Boot0003* grub HD(1,GPT,9c02426b-637e-47aa-b11c-75e707e40f30,0x800,0x100000)/File(\EFI\grub\grubx64.efi)
Boot0005* Manjaro HD(1,GPT,5505c2ad-324e-4c42-967c-44f02543ee16,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0007* KingstonDataTraveler 2.0PMAP BBS(HD,0x0)AMBO
Boot0008* UEFI: KingstonDataTraveler 2.0PMAP PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(3,0)/HD(1,MBR,0x0,0x6934a4,0x2000)AMBO

and from parted:

(parted) print
Model: ATA ST9500325AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 491GB 490GB ext4 root
3 491GB 500GB 9449MB linux-swap(v1) swap

If anyone has any ideas on what I have wrong, please let me know.

Thank you in advance

I have found that when I reboot, if I leave the usb stick with the Manjaro distribution plugged in and go to “Search for EFI bootloaders”, it finds 2:

  • (hd1, gpt4)/efi/Manjaro/grubx64.efi and:
  • (hd1, gpt4)/efi/boot/bootx64.efi

If I select either of these and press enter, the system boots as expected, into the Manjaro installed on the hdd.

I still have not figured out how to make it find these bootloaders on the normal boot process (without using the usb drive). The output from efibootmgr seems (to me) to indicate that it should be looking for those first. Please let me know what I’m missing or have configured wrong.

In the process of trying, I did repeat the installation with a different disk partition.
Here’s my current information.

Model: ATA ST9500325AS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
4 1049kB 538MB 537MB fat32 boot, esp
1 538MB 158GB 157GB ext4
2 158GB 168GB 10.5GB linux-swap(v1) swap
3 168GB 500GB 332GB ext4

and df -h

Filesystem Size Used Avail Use% Mounted on
dev 3.8G 0 3.8G 0% /dev
run 3.8G 1.4M 3.8G 1% /run
/dev/sda1 144G 8.5G 128G 7% /
tmpfs 3.8G 0 3.8G 0% /dev/shm
/dev/sda4 511M 312K 511M 1% /boot/efi
tmpfs 3.8G 36K 3.8G 1% /tmp
/dev/sda3 304G 124M 288G 1% /home
tmpfs 776M 80K 776M 1% /run/user/1000

BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0004,0003,0001,0005,0002,0000,0006
Boot0000* boot HD(1,GPT,3086d8eb-f446-40be-b527-64fad794d259,0x800,0x100000)/File(\EFI\boot\grubx64.efi)
Boot0001* ST9500325AS BBS(HD,0x0)AMBO
Boot0002* IBA GE Slot 00C8 v1381 BBS(Network,0x0)AMBO
Boot0003* grub HD(1,GPT,9c02426b-637e-47aa-b11c-75e707e40f30,0x800,0x100000)/File(\EFI\grub\grubx64.efi)
Boot0004* Manjaro HD(4,GPT,c3e5e42a-9db8-6a4a-9827-ce08178e28bc,0x800,0x100000)/File(\EFI\Manjaro\grubx64.efi)
Boot0005* KingstonDataTraveler 2.0PMAP BBS(HD,0x0)AMBO
Boot0006* UEFI: KingstonDataTraveler 2.0PMAP PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(3,0)/HD(1,MBR,0x0,0x6934a4,0x2000)AMBO

Output from inxi -Fza is:

Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
root=UUID=8763fae6-0e77-488c-aff4-e41b931720a3 rw quiet apparmor=1
security=apparmor resume=UUID=80c486af-9431-4a74-9e8b-a2578f6d3f53
Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux
base: Arch Linux
Type: Desktop System: LENOVO product: 3238B5U v: ThinkCentre M92p
Mobo: LENOVO model: MAHOBAY serial: UEFI: LENOVO
v: 9SKT40AUS date: 09/12/2012
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial:
charge: 55% (should be ignored) rechargeable: yes status: discharging
Info: model: Intel Core i5-3470T bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2018 high: 2651 min/max: 1600/3600 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1597 2: 2228 3: 1597
4: 2651 bogomips: 23157
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
vendor: Lenovo driver: i915 v: kernel arch: Gen-7 process: Intel 22nm
built: 2012-13 ports: active: HDMI-A-3 empty: DP-1, DP-2, DP-3, HDMI-A-1,
HDMI-A-2, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0152 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
X: loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
s-diag: 599mm (23.57")
Monitor-1: HDMI-A-3 mapped: HDMI-3 model: Dell U2410 serial:
built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
max: 1920x1200 min: 720x400
Message: Unable to show GL data. Required tool glxinfo missing.
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: yes
Sound Server-4: PipeWire v: 0.3.56 running: yes
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e
v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 473.03 GiB used: 8.61 GiB (1.8%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500325AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: rev: LVM1 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston
model: DataTraveler 2.0 size: 7.27 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: rev: PMAP scheme: MBR
ID-1: / raw-size: 146.48 GiB size: 143.13 GiB (97.71%) used: 8.49 GiB
(5.9%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 312 KiB
(0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4
ID-3: /home raw-size: 309.01 GiB size: 303.09 GiB (98.08%) used: 125.6
MiB (0.0%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 9.77 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda2 maj-min: 8:2
System Temperatures: cpu: 43.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 204 Uptime: 24m wakeups: 3 Memory: 7.58 GiB used: 1.8 GiB
(23.8%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1083 lib: 324
flatpak: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.20

This is right after the installation. I know that packages and the kernal needs to be updated. I’m just hoping to solve the booting issue before doing that. Any advice on how to proceed with solving this would be much appreciated.

Thank you.

After more poking around, I have additional questions regarding the output or efibootmgr and the structure of /boot/efi on my machine.

Here’s what’s on /boot/efi

\ bootx64.efi

Is my problem with booting possibly related to the fact that the paths in efibootmgr output in my previous post do not match the directory structure? That is, efibootmgr has:

  • Boot0004* Manjaro HD(4,GPT,c3e5e42a-9db8-6a4a-9827-ce08178e28bc,0x800,0x100000)/File(\EFI\Manjaro\grubx64.efi)

which is a file that exists on my system, and since it’s the 1st in BootOrder, I’d think it’d be OK. However,

  • Boot0003* grub HD(1,GPT,9c02426b-637e-47aa-b11c-75e707e40f30,0x800,0x100000)/File(\EFI\grub\grubx64.efi)

is a file I don’t have on my system. Again, it’s the next in order, so I’d think it’d find Boot0004 anyway. Just wondering if that could be a problem (and curious why it’s there, along with Boot0000, which is another file that is not on my system.).

Again, help appreciated.

Thanks very much.

since you already reinstalled your system and still have the same issue, switch the boot order in your uefi settings and see if it helped…

You mean to switch the boot order with efibootmgr, correct?

you can use it, but i doubt it will work… i mean in your uefi (bios) boot settings, set manjaro as first boot option

In my bios / startup settings, it allows me to set the HDD (ATA ST9500325AS). It was already in the order, and putting it 1st did not resolve the problem. Without the usb stick plugged in, I get “no OS found” and the system just hangs.

The settings allow to select UEFI or ‘legacy’ priority, and I had (and kept) UEFI as 1st in line.

No joy. :frowning:
Let me know of other ideas…

Thanks much.

reinstall grub, and see if it helped:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

if there were no errors, update it:
sudo mkinitcpio -P && sudo update-grub

I did this. No errors re-installing grub, so I updated, as you said.

Here’s the last few lines of the output. Note that I did this while booted into the HDD version, using the bootloader found from the live installation. Because it seems to be looking to install in sdb, should I be doing this while booted into the live/install OS (from the usb stick)?

==> Image generation successful
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
Found memtest86+ image: /boot/memtest86+/memtest.bin

this is from the os prober, that it cannot find any bootable binaries on the usb, and its normal…
so now reboot and see

No luck. Still not finding an OS to boot to with the usb drive unplugged…

post output from:

sudo ls /boot/efi/EFI

[jlb@banff ~]$ sudo ls /boot/efi/EFI
boot Manjaro

jlb@banff ~]$ sudo ls /boot/efi/EFI/boot

[jlb@banff ~]$ sudo ls /boot/efi/EFI/Manjaro

and if you remove the usb, is the output from:

sudo ls /boot/efi/EFI

the same?

yes. Removing the usb and not rebooting, I get:

sudo ls /boot/efi/EFI
[sudo] password for jlb:
boot Manjaro

so remove it:
sudo rm -r /boot/efi/EFI/Manjaro
reinstall it again without the usb plugged in:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

if there were no errors, update it:
sudo mkinitcpio -P && sudo update-grub

Done. With usb drive removed, no errors with installing grub using above command, and updated as well. Similar output as before (I didn’t copy it, but did note that the /dev/sdb1 errors were present… sounds like that was not a problem anyway).

Unfortunately, I still get a “No OS found” message when restarting.

I did then restart with the USB drive attached and used the ‘find efi bootloaders’, found the Manjaro loader and selected it and it booted as normal.

By the way, I mentioned earlier that this system (I got it secondhand) must have had a Red Hat installation at some point, becasue I saw that in the efibootmgr. It has had an arch installation at some point also, which I did not see in the efibootmgr. Does that likely mean that it was install using MBR, and could there be something about that which is causing this problem?

(and thank you very much for your help with this)

the redhat and arch entries are no longer there (efibootmgr and the ls /boot/efi), so i dont think they are causing this issue…
is secure boot disabled in bios?
is fast boot disabled in bios - you may not have this option;
is AHCI enabled?

Quick Boot is disabled.

I’m not seeing entries in the bios setup related to secure boot, or AHCI.

There is a “Boot Priority” which is set for UEFI first, then “Legacy”.

The bios date is 09/12/2012