Manjaro install Secure Boot

Hello, I recently purchased a second hand ex business refurbished lenovo thinkpad W540, its running windows 11, i want to install manjaro xfce, but after lengthy research cannot disable secure boot, to make this possible, any tips to make this possible, i can get into bios, and can see secure boot, but no option to disable, thankyou in advance.

So, where you see it in BIOS - you should be able to use the arrow keys to highlight “Secure Boot,” press Enter, and on the next screen, you can again use the arrow keys to highlight to “Secure Boot,” and a press of Enter will toggle Enabled or Disabled.

I own multiple Thinkpads from that same era, and all function in the same way; I would assume the W540 does, too.

Edited to add: Here’s a link straight to Lenovo that shows you exactly what to do.

1 Like

The problem is I can access the bios, but the option to disable secure boot is greyed out and unavailable

I already had this type of problem (BIOS option greyed out) and to my surprise I found out that only after setup a password to enter BIOS some options can be choosed/modified.

1 Like

I set up password too, saw that on the internet, but after setting up a password was still greyed out and unavailable, tried so hard to find solution, but not finding anything so far, lenovo support do not reply either

just a thought, did the password have to be a certain number of characters, what worked for you peracchi please?

Apparently only needed a password.

1 Like

on mine it says user or user and adminstrator, thats the one I created password for.
I also installed lenovo vantage and updated bios and drivers too, before creating password

What is happening with ine is a seller refurbished from ebay and it has a password so I can’t change any bios settings…

Do you think there would be any way to boot without secure boot?
Someone in another forum said that you can but isn’t officially supported but they didn’t say how to…

X250 Laptop (ThinkPad) - Type 20CL
Machine type model 20CL0026AU
Intel Core i3-5010U Processor (2.10GHz)
Windows 10 64-bit
12.5in 1366x768
Intel HD Graphics 5500
720p HD Camera
Intel Wireless 7265AC(2x2)+BT4.0 M.2 Combo
Bluetooth 4.0

You can still force reset the BIOS in theory, but that would require opening it physically to remove the BIOS battery. Also apparently, there seems to be backdoor codes for the bios Dogbert's Blog: BIOS Password Backdoors in Laptops that you can find here if this site is legit (I don’t know)