Manjaro instalation detects BIOS system as EFI with MBR partition

Machine in question: Fujitsu Lifebook E752 vPro
I checked the WIN10 options and they confirm that the system is running on Legacy.
But when I partition the drive and try to install Manjaro dual boot, the next thing happens.

  1. On the partitioning screen, the left indicator says EFI while the right one says MBR
  2. If I partition it as I (think) should, per BIOS installations (just swap and /), it requests an /boot/efi partition to be made
  3. If I partition it as it was an EFI/GPT, the installation fails near the end because some error.

I am at a loss what to do.
Also, it appears that there are no options in the boot setup to switch from BIOS to UEFI, but HWiNFO says that the laptop supports UEFI…

Welcome here, @lilFishy :tada:

If you want to install Manjaro in legacy mode, you need to boot the installer stick in BIOS mode and you must select the MBR as location for the boot loader.

Hello there, thanks for the reply.
I am trying to find that option right now. Where is it usually located?

Go to your BIOS settings and select the USB disk (make sure it doesn’t start with “UEFI:”) to boot in BIOS mode.

Hello there.
It doesn’t start with uefi, but with USB HDD: JetFlash …
But there is no additional menu for selecting any other options

Can someone mark this as solved. I think I managed to trick my Laptop to think its running in BIOS mode while it is actually running in UEFI now, somehow…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.