Manjaro IB Pro 15 - Error message during shutdown or reboot with kernel 5.7 and 5.8

Some minor issue I've noticed: After installing Manjaro KDE from the WebFAI on my MIB Pro 15 (thanks again for the help!) and upgrading kernel to 5.7 (same with 5.8), when shutdown or reboot, I get the following error message:

ERROR: resume: no device specified for hibernation

It also drives CPUs for a few minutes crazy (or, at least, fans are blowing full power), so I needed to do a hard reset with the power button.

After downgrading to 5.4, the error and the fan "orgy" are gone, I can shutdown and reboot again.

It seems to be specific to this notebook, because I newer had this behavior on my other older Lenovo notebooks with Manjaro and kernel 5.7 and 5.8.

As I said, downgrading helped, so I'm not blocked, no rush here.

Let me know, if you need more data or if I can help somehow.

P.S.: No idea, if this has something to do with it, but I get the following errors during kernel upgrade:

  1. A bunch of:
    ==> ERROR: Hook 'bootsplash-manjaro' cannot be found

...
-> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.7-x86_64-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.
(5/5) Updating Grub-Bootmenu
Generating grub configuration file ...
error: command failed to execute correctly
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.7-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.7-x86_64.img
Found initrd fallback image: /boot/initramfs-5.7-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

Here the complete log:

The following packages will be installed:
linux57
linux57-headers
linux57-ndiswrapper

Starting
resolving dependencies...
looking for conflicting packages...
Packages (3) linux57-5.7.9-1 linux57-headers-5.7.9-1 linux57-ndiswrapper-1.63-15
Total Download Size: 94.18 MiB
Total Installed Size: 193.41 MiB
:: Proceed with installation? [Y/n]
:: Retrieving packages...
downloading linux57-5.7.9-1-x86_64.pkg.tar.zst...
downloading linux57-headers-5.7.9-1-x86_64.pkg.tar.zst...
downloading linux57-ndiswrapper-1.63-15-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing linux57...
Optional dependencies for linux57
crda: to set the correct wireless channels of your country [installed]
installing linux57-headers...
installing linux57-ndiswrapper...
:: Running post-transaction hooks...
(1/5) Arming ConditionNeedsUpdate...
(2/5) Updating module dependencies...
(3/5) Install DKMS modules
==> dkms install --no-depmod -m tuxedo-keyboard -v 2.0.0 -k 5.7.9-1-MANJARO
Error! Bad return status for module build on kernel: 5.7.9-1-MANJARO (x86_64)
Consult /var/lib/dkms/tuxedo-keyboard/2.0.0/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m tuxedo-keyboard -v 2.0.0 -k 5.7.9-1-MANJARO' returned 10
==> depmod 5.7.9-1-MANJARO
(4/5) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux57.preset: 'default'
-> -k /boot/vmlinuz-5.7-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.7-x86_64.img
==> Starting build: 5.7.9-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
==> ERROR: Hook 'bootsplash-manjaro' cannot be found
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: [resume]
==> ERROR: Hook 'bootsplash-manjaro' cannot be found
-> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.7-x86_64.img
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux57.preset: 'fallback'
-> -k /boot/vmlinuz-5.7-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.7-x86_64-fallback.img -S autodetect
==> Starting build: 5.7.9-1-MANJARO
-> Running build hook: [base]
-> Running build hook: [udev]
==> ERROR: Hook 'bootsplash-manjaro' cannot be found
-> Running build hook: [modconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: [resume]
==> ERROR: Hook 'bootsplash-manjaro' cannot be found
-> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.7-x86_64-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.
(5/5) Updating Grub-Bootmenu
Generating grub configuration file ...
error: command failed to execute correctly
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.7-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.7-x86_64.img
Found initrd fallback image: /boot/initramfs-5.7-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done

Done ...

Thank you for reporting!

The update error message seems to be caused by the missing bootsplash package. You can either install bootsplash-theme-manjaro with

sudo pacman -Syu bootsplash-theme-manjaro

Or, if you don't want the bootsplash, you can can edit your /etc/mkinitcpio.conf and remove the bootsplash hook from the hooks array.

The other problem seems to be related to the tuxedo-keyboard module. This might be caused by a missing package, or a regression in the newer kernel packages. Someone from our kernel team will look into this as soon as possible. If you can post the output off cat /var/lib/dkms/tuxedo-keyboard/2.0.0/build/make.log
It might be helpful in resolving the issue.

1 Like

Thanks for the reply! Probably to remove it from mkinitcpio.conf would better match the cooperation goals with Tuxedo, because Tuxedo provides their own splashscreens. I will do it later today and will let you know if it helped.

Wouldn't it be something that should be also fixed in the Manjaro Tuxedo installer?

There is no make.log under /var/lib/dkms/tuxedo-keyboard/2.0.0/build/:

[andriy@mibpro15 2.0.0]$ pwd
/var/lib/dkms/tuxedo-keyboard/2.0.0
[andriy@mibpro15 2.0.0]$ ls -la
total 16
drwxr-xr-x 4 root root 4096 Jul 30 00:51 .
drwxr-xr-x 3 root root 4096 Jul 30 00:51 ..
drwxr-xr-x 3 root root 4096 Jul 30 00:51 5.4.53-1-MANJARO
drwxr-xr-x 3 root root 4096 Jul 30 00:51 5.8.0-1-MANJARO
lrwxrwxrwx 1 root root   30 Jul 30 00:51 source -> /usr/src/tuxedo-keyboard-2.0.0

But a few levels deeper:

[andriy@mibpro15 log]$ pwd
/var/lib/dkms/tuxedo-keyboard/2.0.0/5.8.0-1-MANJARO/x86_64/log
[andriy@mibpro15 log]$ cat make.log 
DKMS make.log for tuxedo-keyboard-2.0.0 for kernel 5.8.0-1-MANJARO (x86_64)
Thu 30 Jul 2020 12:51:08 AM CEST
make: Entering directory '/var/lib/dkms/tuxedo-keyboard/2.0.0/build'
make -C /lib/modules/5.8.0-1-MANJARO/build M=/var/lib/dkms/tuxedo-keyboard/2.0.0/build modules
make[1]: Entering directory '/var/lib/dkms/tuxedo-keyboard/2.0.0/build'
make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
  CC [M]  /var/lib/dkms/tuxedo-keyboard/2.0.0/build/./src/tuxedo_keyboard.o
  MODPOST /var/lib/dkms/tuxedo-keyboard/2.0.0/build/Module.symvers
  CC [M]  /var/lib/dkms/tuxedo-keyboard/2.0.0/build/./src/tuxedo_keyboard.mod.o
  LD [M]  /var/lib/dkms/tuxedo-keyboard/2.0.0/build/./src/tuxedo_keyboard.ko
make[1]: Leaving directory '/usr/lib/modules/5.8.0-1-MANJARO/build'
make: Leaving directory '/var/lib/dkms/tuxedo-keyboard/2.0.0/build'

That splash module should show the tuxedo bootsplash.

Yes, I put the message forward for it to be looked at.

1 Like

Ok, I've tested both excluding bootsplash-manjaro from /etc/mkinitcpio.conf (BTW, bootsplash-manjaro is present 2 times in HOOKS), and installing bootsplash-theme-manjaro. The second option helped, I don't see the error message during boot and shutdown anymore. I don't know if manjaro bootsplash just hides it or if the error is really gone, but it doesn't bother me anymore.

Thank you very much for the help, @Chrysostomus!

Bootsplash doesn't hide errors, but error was about trying to run bootsplash that wasn't installed

I mean the error message I originally had ("ERROR: resume: no device specified for hibernation"). Or did it also had something to do with the bootsplash?

Aah, that one. Do you want hibernation to work or just for the error message to go away?

For the error message to go away. :slight_smile: Before manjaro bootsplash installed, it was shown over the Tuxedo bootsplash during startup and shutdown. Sometimes, during shutdown notebook froze and fans gone crazy, probably because of the high CPU usage. No idea if it had something to do with the hibernation error.

Okay, if you don't want it to try using hibernation (that hasn't been setup), you can remove the resume hook from /etc/mkinitcpio.conf and run

sudo mkinitcpio -P

That should probably also reduce the boot time by a tiny bit.

1 Like

Yes, that was it! Excellent, thanks again! :slight_smile:

Maybe that's also something worth fixing in the Tuxedo installation script (in one way or another), because this was in a new, fresh Tuxedo Manjaro KDE installation.

Thank you very much! :+1:

Forum kindly sponsored by