Manjaro i3 community edition - change tiling manager to qtile

I use i3wm for a some time and I have decided, that I want to change i3 to qtile. I have installed qtile and now I have problem to enable qtile.

I have changed $HOME/.xinitrc: DEFAULT_SESSION to qtile instead of “i3 --shmlog-size 0” but that didn’t work. I also checked X11 folder in etc, but there is nothing what would change tiling manager. Then I also tried to change lightDM config under seat user-session to qtile. That didn’t worked either.

Also in usr/share/xsessions there are i3 and qtile entry. But now I’m stuck. I don’t know what do I have to change. The system still runs i3 automatically.

Does anybody know, how the startup works in Manjaro i3 edition and how to change tiling manager?

Official documentation is very helpful :wink:

Running from systemd — Qtile 0.1.dev51+gd5425ee.d20210628 documentation

have you tried logging out & selecting it from lightdm log in manager.

you sure you should be switching?
you seem to not even know the basics of a linux system.
qtile is python, do you know python?
if your going to need more help, i very much doubt there are many qtile users if any at all.
hope you did the first basic thing & backed up anything important to you.

@kerry_s well yeah… I’m trying to learn about these things. Eg. until now I didn’t know even about lightDM existence. But now I’m trying to understand that.

Also I didn’t noticed that “button” next to name to switch DE. So that solved my issue.

alright, so how is it?
make sure you read through there docs.

Not sure what are you asking to.
Now the issue is solved. Initialy I thought I have to change settings for xinit (and all guides reffered to this config). But as it came out, xinit config changed nothing, because that settings controlled lightDM which has button on log in screen (which I didn’t noticed) for switching enviroments. There I can change which DE (in this case WM) I want to log in.
I know this mistake was kind of dumb. Sorry about that.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.