Manjaro-i3 17.1.1

community-edition
i3

#1

Manjaro-i3 17.1.1 is ready for download

The edition has been re-styled with gtk-theme adapta-maia and matching colors using kvantum-manjaro for qt-applications.
Apart from that some little necessary adjustments to the i3 config were made.

Please test and give me your feedback!
Enjoy :slight_smile:


Nur in english?
Warning: Unable to load any usable ISO8859 font
#2

Torrent available at:
https://sourceforge.net/projects/manjarotorrents/files/community/i3/17.1.1/


#3

It detected and installed Nvidia drivers for my 1050. The month and day are still out of order on the status bar :slight_smile: but everything else works like a charm


#4

The date is in European format.
To change it just copy /etc/i3status.conf to ~/.i3status.conf and edit

tztime local {
        format = " %d.%m. %H:%M "

to

" %m.%d. %H:%M "

How do I change the time from 24-hour format to 12-hour format in i3 status bar
#5

@oberon: congrats on this release. Eddie will enjoy it :wink:


#6

Screen shots look cool, will have to boot this puppy in my VM. Just a few months ago I used VM for the first time and now I’m addicted to it. Edit-lol I had no clue what i3 was when I posted this…God I feel dumb :poop:


#8

Hello,

first of all, thanks for keeping this project running!

After installing the update yesterday, I ran into some issue with the sessionmanager (?). The login screen now looks as follows:
login

And the color scheme, after login, is gone. Please see here (incl. lxappearance window) :

I found some errors in the .xsession-error file, though I’m not sure what to make of it:
https://pastebin.com/y63jDWt6

I’d be happy to supply any further needed info to help resolve this issue,

Philip


#9

Hi Philip.
The error messages in your pastebin seem to be not related to your theming issue.
To me it looks like your settings are using a theme that is no longer installed. Did you remove anything - like vertex-maia-themes maybe?
Please use lxappearance to check the gtk-theme settings and/or re-apply.
Also launch lightdm-gtk-greeter-settings-pkexec to set/re-set the theme for the greeter.


#10

cp: cannot create regular file '/home/philip/.local/share/icons/default/index.theme': No such file or directory
is not big deal. It has to do with the automatic x-cursor theme setting script. I will fix that properly with the next update.

For now you can get rid of the error by running:
install -D /usr/share/icons/default/index.theme ~/.local/share/icons/default/index.theme

grep: /home/philip/.mozilla/firefox/profiles.ini: No such file or directory
Not a problem. Seems you are not using firefox but have ff-theme-util installed.
You can simply remove ff-theme-util.
I can clean that up also in the package in the future.


#11

Looking at the ff-theme-util script again I am a little confused about your error message.
Which browser are you actually using? Neither firefox nor palemoon? Is none of them installed??
Did you install this system from a manjaro-i3 ISO or differently?


#12

Hi oberon,
thank you for helping!

i) the vertex maia themes were gone (I dind’t actively uninstall them). After re-installing them and using lxappearance and the lightdm-gtk-greeter-settings-pkexec things appear fine again (using Vertex-Maia-Dark theme & Vibrancy-Full-Dark-Teal icons in both)

ii) I installed from a manjaro-i3 ISO. But I uninstalled the palemoon browser and use vivaldi from the AUR (firefox is not installed)

iii) after following your advices, the .xsession-error file now looks like this:
https://pastebin.com/QVNHYSWi

btw: what are the default themes and icon-sets in the manjaro i3 installation?

Philip


#13

It used to be vertx-maia but with the latest release it is now adapta-maia (Adapta-Nokto-Eta-Maia).
Icons are Vibrancy-Full-Dark-Teal from the vibrancy-colors package.
If you don’t use palemoon and firefox you can just remove ff-theme-util.
You’re welcome :slight_smile:


#14

Everything seems to be more or less going good in this realse except for one thing, for some strange reason colours in the terminal aren’t working correctly, any ideas?

heres how it looks:
catimg: https://imagebin.ca/v/3oC4BDpVjIih
mpv tct: https://imagebin.ca/v/3oC4PGuzKeZv


#15

Hm. I have no idea. Never used these tools before.
My guess is it might have to do with the settings in .Xresources, although I didn’t change them since last time I think. Did this work in earlier versions?
Just checked with gnome-terminal, no issue there. So the problem seems to be urxvt specific


#16

Sounds about right, I’ve tried with uxterm and I had no issue, I’ve no idea what the issue


#17

How Could i upgrade my previous manjaro edition , im running on 17.1 (Hakoila)


#18

Just do the regular updates, and you will have the same system as people installing from 17.1.2. :slight_smile:
The beauty of rolling release.


#19

Hi, I’m not sure if this is the right place to report it, but the latest update of the packages breaks the urxvt. mod+Enter cannot open a terminal, propably due to this issue. The error is: urxvt: unable to load base fontset, please specify a valid one using -fn, aborting. The rxvt-unicode package version is 9.22-5.


#20

I don’t have an issue on my system. Looks like a problem of your font config.
What does it say in your ~/.Xresources in the line

URxvt.font:

?
If you also have a file ~/.extend.Xresources check there aswell!


#21

~/.extend.Xresources does not exist. My installation is Manjaro i3 version:

Distributor ID: ManjaroLinux, Release: 17.1.3, Codename: Hakoila, Linux version 4.14.15-1-MANJARO (builduser@manjaro) (gcc version 7.2.1 20171224 (GCC)) #1 SMP PREEMPT Wed Jan 24 13:13:39 UTC 2018

Here is the URxvt.font configuration:

cat ~/.Xresources | grep URxvt.font
URxvt.font: 9x15

I also tried changing the above to ‘URxvt.font: -misc-fixed-medium-r-normal–15-140-75-75-c-90-iso8859-1’ with no luck.

Also, the font seems installed:

cat /usr/share/fonts/misc/fonts.alias | grep 9x15
9x15 -misc-fixed-medium-r-normal–15-140-75-75-c-90-iso8859-1
9x15bold -misc-fixed-bold-r-normal–15-140-75-75-c-90-iso8859-1

I resorted into installing st (pacaur -S st) which works out of the box. I might try urxvt again later after couple of updates hoping that the issue will be resolved. I had done no configuration at all in regards to fonts or the terminal, therefore it is more likely to be a global issue (e.g. not limited to my machine). Let me know if you come up with a workaround or fix or a configuration I could try for urxvt.