Manjaro has kernel panic after installing opensuse

Hi Everyone,
I been trying the latest release and love it. But there has been issues with grub messing up other
linux systems on my hard drive. Tried to reinstall grub several times and ended up having to do
a fresh install to get anything to boot. I reinstalled grub on Arch and it now fails also. Now I just loaded Opensuse (I like their bootloadersetup) to configure the other o.s.'s . All will boot except Manjaro.
Hope to use this but need help or suggestions.
Thanks and enjoy you weekend
GS

Manjaro has its own version of GRUB and will only boot from there. So if you installed another Linux OS after you installed Manjaro, its GRUB version will not be able to boot Manjaro.

To solve this problem, you have two options:

  1. Select a boot option inside your BIOS that says something with the word “Manjaro” in it. This should launch the Manjaro GRUB and thus Manjaro itself.
    Once booted up, run the following commands - replace sdX with the drive the bootloader has to be installed on (usually your primary disk):
sudo grub install /dev/sdX
sudo update-grub

This will “overwrite” the default GRUB installation back to a Manjaro-compatible one.

  1. If you cannot find a Manjaro entry in your BIOS settings, you may have a look at this thread:
    Using livecd v17.0.1 as grub to boot OS with broken bootloader

Enjoy the weekend as well :wink:

2 Likes

I have a similar problem. I think this is a specific Manjaro bug. os-prober (grub) does not detect other Linux OS installed on btrfs. openSuSE bootloader must load Manjaro with the option "… fallback initramfs… "

This is a usual problem. You simply use the grub from the other OS not supporting multible initram-fs images. Here is a typical grub.cfg entry for Manjaro:

menuentry 'Manjaro Linux (Kernel: 4.14.47-1-MANJARO x64)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.14.47-1-MANJARO x64-advanced-e9da7593-2d25-46af-b1d7-7844ecea56d0' {
	savedefault
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_msdos
		insmod ext2
		set root='hd0,msdos6'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,msdos6' --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6  e9da7593-2d25-46af-b1d7-7844ecea56d0
		else
		  search --no-floppy --fs-uuid --set=root e9da7593-2d25-46af-b1d7-7844ecea56d0
		fi
		echo	'Linux 4.14.47-1-MANJARO x64 wird geladen …'
		linux	/boot/vmlinuz-4.14-x86_64 root=UUID=e9da7593-2d25-46af-b1d7-7844ecea56d0 rw  quiet resume=UUID=6dd17673-7ddb-4fd5-9c83-e3ef0116a872
		echo	'Initiale Ramdisk wird geladen …'
		initrd	/boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
	}

Please notice: initrd /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img

At least you should have initrd /boot/initramfs-4.14-x86_64.img

1 Like

Thanks all of you . I will give it a try. You have created a fantastic os

1 Like

This is why I love you guy’s. You try to help instead of criticise someone.
Thanks so much

1 Like

Hey Phil,
So, all I would have to do is cut and past this:
initrd /boot/initramfs-4.14-x86_64.img to the bottom of Manjaro /boot/grub/grub.cfg entry
to make it work?
Thanks so much I know how busy you are

Check your boot entry and correct initrd line to the real image.

Thanks again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.