Manjaro - Grub menu

Hello. Manjaro grub menu comes up when the pc starts up. How can I turn it off and my pc will boot faster?

You can hide the grub menu with
/etc/default/grub
and grub contains a line “GRUB_TIMEOUT_STYLE”.
You can set it to “false”.

But: I recommend installing more than one kernel.
In the Grub menu, you can select the kernel version then.

I did it, it wasn’t closed again

How else can I do?

I have written some something false:
GRUB_TIMEOUT_STYLE=hidden

1 Like

it was already like that, then i wrote “false”

Should look like this (or with different timeout) in /etc/default/grub

GRUB_DEFAULT=saved
GRUB_TIMEOUT=4
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="Manjaro"

Don’t forget to

sudo update-grub

after changing grub.

Off Topic, but I need to say here.
Hey, @Manjaro-Team, why do you always change my grub theme without my permission ?

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

?

2 Likes

Thanks :slightly_smiling_face:

That begs the question - when did Manjaro change your local grub theme?

The place a grub theme could possibly be changed is if the default ISO provided theme is updated.

Then - it is possible the grub theme changed.

This is the same issue with the default look-and-feel for KDE. Because it is installed system wide - using /usr path - then a user - unless specifically change in the users home - sometimes experience mysterious changes - which is actually just the defaults which has changed.

It has previously been an issue for some - that certain changes to ISO theming didn’t reflect unless the user actively intervened - now it is a problem when it does.

@banjo - you are probably using some ISO default - which can change if the team or the maintainer think it is justified.

There is no one haunting you :slight_smile:

1 Like

Can you post parts of /etc/default/grub ?

You can also set
GRUB_TIMEOUT=
to a low value.

ibb. co/1QLGxws
erase the space between

Last three updates ? Two pacnew (wich is fine), the last one complete without my permission. Haven’t you updated yet ? If it was something necessary, I would not complain, but just a … theme? That’s fine for the new ISO, but leave out the installed ones.

Oh, I feel totally save in this forum. :face_with_head_bandage:

I agree - I update frequently (unstable) - I have never seen a change to my grub theme - unless I did it myself.

The only thing I can possible think of - is if some theme package got a dependency of a certain grub theme - which may explain why I don’t see it as I don’t use the official editions but Openbox which I am in charge of.

And for the time being I am not even using Openbox but using compiz and cairo dock.

So maybe I kick out manjaro-xfce-settings and manjaro-xfce-minimal-settings. On both notebooks the theme has been changed. But this is not the way things should be done.

User modifications - which is located in the users home are never changed - if one modifies system files then one must expect them to be overwritten by updates.

Neither should configurations in /etc - which differs from the original - be replaced - that is why we have pacnew - so without knowing the exact circumstances it is difficult to have an opinion.

One example is zsh-config package.

It was previously in ./etc/skel and pretty much untouchable on updates. Now it resides in /usr/share/zsh and is sourced - which makes changes to the default Manjaro system reflect to the user even if this is not desired by the user.

You can always change you local .zsh to remove that sourcing but nonetheless it makes it possible on a distribution level to control the end users environment - which some users like because they get the theming changes they want on new releases - and others hate it.

It is somewhat difficult to adjust and please all and everyone.

There is a bug in manjaro-theme-grub that was discovered yesterday and is getting fixed.

4 Likes