Manjaro Gnome Installation fine but no boot after restart

Hello everyone,

I know this topic seems ot be discussed couple of times but I haven’t found a working solution for me yet and it drives me mad. Slowly. Hmpf!

Okay… Situation: I have a Toshiba Portege Z30-B, deselected anything that sounds like Secure Boot or Fast Boot or whatever. Boot mode is set to UEFI only. Next I prepared an USB boot stick with rufus on a Windows machine. Plugged the USB into the Laptop and started. Boot process of the live system is fine. Installation also works fine (btrfs - automatic disk preparation during install). Then comes the reboot and that’s it. In the BIOS I changed the boot order to HD/SSD first, startup screen of Toshiba comes up and then I end up at:

Insert system disk in drive.
Press any key when ready...

Absolutely no way to boot the system. Now I can only start again booting up the USB stick.

I found some infos showing how to enter grub commands when the USB starts up and then pressing the c key but the first command search.file (or so) doesn’t work. Throws back an error. chroot also doesn’t work.

I’m not a very Linux-experienced user and completely lost because I don’t understand what else I could do…

Anyone willing to help me with that? If I’m annoying anyone please delete this posting…


Did you select or create an ESP ?
Only being able to boot from the USB sounds like you may be missing the EFI partition.

I boot from the USB stick and when the live system is up I start the regular Installer. And in this process I have the chance to select and completely erase the SSD, define if or if not I want to have a Swap partition or a swap file and the file system (in that case Btrfs). After installation is done and I start Gparted it shows me the EFI partition (with the flags boot and esp) plus the btrfs partition.
So from this point of view I hope I did everything right until then…

Edit: I don’t do a manual partitioning, instead I trust on the automatic way

Can you check the partioning ?

This is what the partitioning table looks like for the SSD

There is no data on that ESP … so it was not selected during install.

Okay… So any hint how this can be solved? I’m not the familiar with linux commands. Sorry for that.

You can fix it … but since its a new install it may be easier to start over and just make sure to select the esp (again since it is new, you can format it or not) in the drop-down selection under the partition table.

1 Like

Hey @cscs how do I get it corrected. I mean it’s the original installer and it’s a bit confusing that it’s not properly done. Only formatting the ESP partition won’t fix it, right? Do I need any commands to have the EFI partition properly set up? Do I need additional packages installed for that?

@derkolarsky It might be that your live USB was formatted into MBR (Legacy), when for UEFI it should have been formated into GPT. And that is why the system cannot find bootlader in the SSD. Please check. :grinning:

1 Like

Ohhh… Good Point. Will re-create the USB… Thanks a lot :slight_smile:

Okay… Built a new boot stick. In fact that I’m writing an ISO to the USB there seems no way to check if the USB is using GPT, or am I wrong?

@derkolarsky Please format your USB to GPT before writing/adding ISO onto it.

In Windows Disk Management delete all partitions from the USB and this will empty the previous content of USB. After this in rufus Drive Properties the Partition scheme select GPT and Target system select UEFI and in Format Options below the File system select FAT32 and make new live USB.

In Linux system, open GParted and run command Format for the USB and your partitions in you will be deleted and USB turns empty. After that format the empty USB with gnome-disk-utility or similar to GPT.
Now, after this is done, write/add ISO to the USB.

Now you should be ready to re-install UEFI Manjaro over / in place of the previous Manjaro installation. Be carefull not to write over the existing Windows.

Best luck !

Hey everyone…

Thanks for your patience. I created the USB exactly the way @pelka described.
Installing went fine, but after reboot the same message comes up. When re-booting from usb and starting Gparted there seems to be no data on the EFI partition. Again. During installation I see that some data seems to be written onto the EFI partition but after setup is done the data is gone. That really makes my brain go nuts.

I will stop at this point for now, reconfiguring the BIOS settings and install my old SSD running Windows 10 (hopefully 11 soon). Maybe I’ll start a different approach using a virtual machine on my old iMac…

But thanks for all your input and maybe in the near future I might get back to you guys.

Cheers and all the best

1 Like

@derkolarsky Correct partition of installation USB stick should look something like this

Sorry, I do not have gnome-disk-utility in English. Is yours similar to this ?

In your above HP/SSD partition picture 1.) in /dev/sda1 there is no ‘EFI system partition’ for Win, partition is not used, only boot, esp flags (which are correct); and 2.) in dev/sda2 can be only one OS using only 7,59 GiB; is this status still the same ?

The laptop spec looks like BIOS Boot Setup might be capable to booting mode of drive in 3 diffrent modes: MBR (Legacy), Hybrid UEFI (with CSM) and Original UEFI (without CSM). Please check in BIOS which mode your Windows 10 is booting now and oeas it boot now. Please check what happens when booting your Win 10 with other modes.

I understood you are trying to create a dual boot system (Win 10 + Manjaro), correct ?

In case Win 10 is not booting from HD/SSD, then reinstall Win 10 and check again this booting mode issue in BIOS Boot Setup. Please make a snapshot of the HD/SSD partition after Win 10 reinstallation. In case if this Win 10 installation boots, then then reinstall Manjaro with the same USB formats and BIOS booting mode as Win 10. When done, boot your system → wait for EFI menu to appear → select Manjaro line → Manjaro grub menu should open → select Manjaro or Windows.

[[But in case Windows booting mode is MBR (Legacy), keep it and prepare Manjaro ISO USB stick, which is at first made empty and formated to MBR (Legacy), i.e. before adding ISO.]]

Or you can use Ventoy.

You need to change your boot priority in your BIOS. Make sure the hard drive where EFI resides on gets booted first, not USB or other drive. The reason why it asks system disk in drive is because it can’t find EFI in the first system disk according to the BIOS boot order list