Manjaro Gnome doesn't boot after forced shutdown

Hi everyone! As you can read from the title, I had to force shut down my laptop with Manjaro Gnome installed on and external USB drive and now, if I try to boot it up, I get stuck on the Asus Logo. Is there a way to find where the problem is and, possibly, to fix it? You’re my last hope not to install it again from zero.

Have you tried booting the USB drive on another laptop or computer to see if there it is a problem with your laptop?
It sounds like it’s a problem with your laptop and not the operating system (you could try reseting the BIOS) but if you can get to the boot menu (by pressing ESC when starting), try selecting a different kernel from the advanced options selection on the boot menu. Hope this helps.

1 Like

I tried on another PC but it still doesn’t boot. I don’t think it’s a BIOS problem because I still manage to get to the Operating System selection screen, but once chosen Manjaro it crashes and won’t start anymore. If I press ESC after chosen Manjaro a get to a black screen with just a hyphen, but I can’t do anything because it’s stuck

Ok news, after a few seconds in which it remains blocked, I can access the login shell, but if I try to use startx, a series of information appears and then the message: xinit: connection to X server lost. Waiting for X server to shut down (II) Server terminated successfully (0). Closing log file, and I come back to the shell. Is there something I can do from here?