Manjaro Gnome 21.2 rc1 minimal iso-<Alt> F4 Window closing issues and nvidia-wakeup issue

For the past few days, I am working on installing the new iso (as the title shows).

Issue 1: Alt-F4 to close opened windows issue.
Let me explain.
Boot into Live ISO, Alt-F4 works to close opened windows. After installation, Alt-F4 works.
After Updating the system, Alt-F4 stops working.

As of 20-12-2021, I think, after the installation, we get around 50 updates of packages. I did lot of trials and errors to pinpoint the particular package which is creating the issue.
It is manjaro-gnome-settings When it is upgraded from 20211210-1 to 20211212-3, Alt-F4 stop working. I had to use only Ctrl-Q to close the window.
Now for the time being, I am ignoring this one package with updates and the problem is solved.
Has any one got this problem or this is only with my hardware.

If required, I can send more details.

Issue 2: Related to hibernation:
I use hibernation at all times. I use Nvidia Propreitary driver. Latest 470.94 version.
After installation and updates, hibernation works but wake up from hibernation goes to black screen.
I have tried with both btrfs-swapfile and lvm-swap partition. Am able to reproduce.

There were 2 package updates released, I think on 20-12-2021 viz…
xorg-server-common 21.1.2-0 to 21.1.2-2
xorg-server 21.1.2-0 to 21.1.2-2
After the update of these 2 packages, the problem is solved.
This is only for information.
I wish to know whether someone has got this problem.

I am more concerned with the 1st issue as I have not deliberately not updated one package.

P.S I tried with LTS kernel iso also with the same results.

The settings have actually been part of the package for quite awhile, but some were not applying correctly. I recently fixed a lot of things with that package.

The default Close window shortcut is actually Super+Q. :wink:

You can change it to anything you’d like under Settings > Keyboard > Keyboard Shortcuts.

What problem? I thought it was solved. There was an issue with NVDIA + Xorg, but as you noticed, it was recently fixed.