Manjaro Gnome 16.10

gnome
community-edition
iso

#1

Hi community :slight_smile: i am happy to announce the availability of manjaro-gnome-16.10

Highlights:

  • Kernel LTS 4.4 series
  • Lollypop
  • Manjaro Printer
  • Manjaro-user-guide
  • Hexchat
  • Libreoffice-still
  • Arc-Maia-Theme enable in Firefox and in Gnome shell
  • Installed and active LightDM

Plus : Cli app

  • MC ( Midnight Commander )
  • mhwd-tui
  • pacli
    ( Added this cli app for easy management our manjaro box without gui/de )

Unfortunally in certain hardware the boot time of gnome-shell is slow ( i don’t know why :pensive: ) i hope to solve for the future .

Download : Community-Repo - Torrent
Greetings

Stefano Capitani
Manjaro Team


Wayland, Gnome, and LightDM
[SOLVED]Unable to update my fresh installed Manjaro
#2

Cool! Congrats for the great job @Ste74 :wink:


#3

I love this flavor. Keep up the good work!


#4

And Torrents are up!


#5

Thanks a lot @Ste74 for supporting gnome edition! :slight_smile:

I installed this version on virtualbox for testing, everything seems to work so fast and without issues so far except two things:

1) Root-terminal doesn’t launch. When I start the root-terminal icon it asks me the password but after it doesn’t start. Going to /usr/share/applications/root-terminal and properties (with right click) I changed the execute command to gnome-terminal -e “sudo -i” and now works fine.

**2)**Qt5-settings doesn’t also launch. I tried opening it by terminal but I get:

I followed the steps from here by adding the line
QT_QPA_PLATFORMTHEME=qt5ct in /etc/environment but didn’t work.


Manjaro Gnome 17.0-alpha1
Gnome 16.10 issues: terminal, date, input language
#6

Hi kouros17 , try to add also this in your .config path


seem i have lost to import :scream:

for the root terminal want try another way… use a pkexec command via polkit rules and set via pkgs when ready inform you …


#7

@kouros17 , i don’t understand why not want work via pkexec ( this is already set via gnome developer i think ) … i google to search a solution but only your solution seem to works …


#8

I did it but I got the same issue. I had to add also the line
QT_QPA_PLATFORMTHEME=qt5ct in /etc/environment according to this guide.
Now works fine! :slight_smile:


#9

Hi @kouros17 can you try to install dbus-x11 and try to launch with original command via pkexec :slight_smile:

EDIT : Root terminal is a part of gksu pkg… reinstall also gksu pkg and see if the exec command is gksu -l or simply gksu bla bla


#10

Nice dark wallpaper. I really think Manjaro just looks more modern and slick with dark wallpapers.


#11

@Ste74 the only command which works for root-terminal icon is gnome-terminal -e “sudo -i”.
I would like to point out that I’m talking about the root-terminal icon (apk) and not how to get root-terminal from gnome-terminal.

One more issue with LightDM reported here by @Varttaanen @drb and me.
I don’t think that the use of LightDM instead of native GDM is a good choice for gnome edition.
Please take a look.


#12

Why there´s 3 (?) different extensions to open dash/programs on the top bar? It´s going to be really confusing for a new user. Keep it simple. :grin:


#13

Uhmm :grinning: you are right :grin: for the next release ( but also now via settings ) i can patch the extensions and leave only in gnomenu or in dock :wink:


#14

why patch extensions gnome-shell-extentions in the repros. has a perfectly good menu the only other extentions that are essential are dash to dock, frippery move clock, task bar, top icons plus, they are available from gnome extensions and maintained long term.


#15

From 16.08 and earlier, how does one change from gdm to lightdm with 16.10 default settings?


#16

sudo systemctl disable gdm.service sudo pacman -Sy lightdm lightdm-gtk-greeter sudo systemctl enable lightdm.service


#17

What about the webkit2 greeter? I installed manjaro 16.10 in another machine and a fancy greeter with options to select the background right in the login screen.


#18

Yes, webkit2 greeter would work also. I just suggested gtk2 greeter as a generic lightdm greeter.


#19

Really Like the Gnome spin however it does not work with the proprietary AMD graphics drivers. It boots fine from a USB flash drive but Calamares installs proprietary drivers and the desktop will not come up. Tried installing amdgpu drivers from the terminal and I could not get them to work either.


#20

Ati closed driver and gnome not are big friends… gnome developer drop the support …