Manjaro fully freezes randomly

I have was on LTS kernel and it was freezing, changed it to the real-time kernel and it still persists.
A complete freeze, not even caps lock works.
Don’t really know what could be the issue. Had it on a external ssd and installed it again on my internal ssd, nothing seems to work. System log doesn’t say anything.
Could it be a problem with the latest version of manjaro or maybe my ram?

██████████████████ ████████ -
██████████████████ ████████ -------------
██████████████████ ████████ OS: Manjaro Linux x86_64
██████████████████ ████████ Host: 81SY Legion Y540-15IRH-PG0
████████ ████████ Kernel: 5.11.4-1-rt11-MANJARO
████████ ████████ ████████ Uptime: 1 hour, 17 mins
████████ ████████ ████████ Packages: 1319 (pacman), 10 (snap)
████████ ████████ ████████ Shell: zsh 5.8
████████ ████████ ████████ Resolution: 2560x1440
████████ ████████ ████████ DE: GNOME 3.38.4
████████ ████████ ████████ WM: Mutter
████████ ████████ ████████ WM Theme: Matcha-dark-azul
████████ ████████ ████████ Theme: Matcha-dark-azul [GTK2/3]
████████ ████████ ████████ Icons: Papirus-Dark-Maia [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i7-9750H (12) @ 4.500GHz
GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q
Memory: 1700MiB / 23968MiB


Does this work?

Can you post some hardware info ?
inxi -Fza ?

Yeah I tried it, it doesn’t work. Only hard reboot works.

Here you go:


  Kernel: 5.11.4-1-rt11-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-rt-x86_64 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 


  Type: Laptop System: LENOVO product: 81SY v: Legion Y540-15IRH-PG0 
  serial: <filter> Chassis: type: 10 v: Legion Y540-15IRH-PG0 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO 
  v: BHCN38WW date: 05/19/2020 


  ID-1: BAT0 charge: 46.8 Wh (100.0%) condition: 46.8/52.5 Wh (89.1%) 
  volts: 12.8 min: 11.2 model: SMP L17M3PG1 type: Li-poly serial: <filter> 
  status: Full cycles: 249 


  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE cache: L2: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62431 
  Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 2269 4: 1425 5: 949 6: 800 7: 800 8: 800 9: 946 10: 800 11: 800 12: 801 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 


  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Lenovo 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f91 
  class-ID: 0300 
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 1-6:3 chip-ID: 5986:2113 class-ID: 0e02 
  Display: wayland server: 1.20.11 compositor: gnome-shell driver: 
  loaded: nouveau note: n/a (using device driver) - try sudo/root 
  display-ID: 0 resolution: <missing: xdpyinfo> 
  OpenGL: renderer: NV167 v: 4.3 Mesa 21.1.2 direct render: Yes 


  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.4-1-rt11-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.28 running: yes 


  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 07:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp7s0 state: down mac: <filter> 


  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-14:7 chip-ID: 8087:0aaa class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 


  Local Storage: total: 1.36 TiB used: 126.51 GiB (9.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: P2CR033 
  temp: 29.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: LXM3 scheme: MBR 


  ID-1: / raw-size: 301.31 GiB size: 295.51 GiB (98.08%) 
  used: 16.92 GiB (5.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 


  Alert: No swap data was found. 


  System Temperatures: cpu: 46.0 C mobo: N/A gpu: nouveau temp: 40.0 C 
  Fan Speeds (RPM): N/A 


  Processes: 429 Uptime: 5h 34m wakeups: 16 Memory: 23.41 GiB 
  used: 4.05 GiB (17.3%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: N/A Packages: 1377 pacman: 1366 lib: 324 flatpak: 0 snap: 11 
  Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.04

Ok now… it is obviously:

The nouveau driver works with wayland, still the nvidia works also partially with it, but has not full support. The nouveau driver is still not 100% stable with newer cards and has no power management. That means, it runs always at base clock and does not clock up.

I would advice to use Xorg with the nvidia driver with your card.

Btw… did you disable the intel iGPU?

Thanks! I will try and see what I get.

I didn’t I installed the system just a couple of days ago. Not sure if its disabled by default.

1 Like