Manjaro Freezes Randomly everytime

Manjaro freezes randomly, I’m not able to move the cursor. I tried Ctrl+Alt+F2 to switch to virtual terminal, but it does nothing. I have to force shutdown with the power button every time this happens. I think the issue has something to do with the recent updates, this has never happened before the update. Sometimes the freeze happens 15 minutes after booting sometimes after 4 hours.
System: Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1

Desktop: i3 4.19 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux

Machine: Type: Laptop System: Dell product: Vostro 14-3468 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> Mobo: Dell model: 043PJ2 v: A00 serial: <filter> UEFI: Dell v: 3.4.0 date: 05/10/2019

CPU: Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6 model-id: 8E (142) stepping: 9 microcode: DE L2 cache: 3 MiB

Graphics: Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:4 chip ID: 0c45:6a05

Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 driver: loaded: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 112 size: 310x170mm (12.2x6.7") diag: 354mm (13.9") OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.3 direct render: Yes
I am using Manjaro i3 community edition.

Hi @maskedman ,
Welcome!. Did your consider that the content of this post could be your problem?
https://forum.manjaro.org/t/manjaro-freezes-several-times-a-day/50389
Hope it help, regards.

I’m having the exact same problem on a similar system running the same kernel as maskedman.

It would be rather coincidental if it were a memory problem as at lest three people are experiencing similar issues.

As all three of us are using a 5.10 kernel, perhaps that is the problem. I am currently trying the 5.4 LTS kernel to see if that solves the problem.

Issue is similar but,

At first I could do things before it happened, but now it freezes just after starting.

This hasn’t happened to me yet, the freeze always happen in-between sessions.

Here’s my output for sudo smartctl --attributes --info /dev/sda

=== START OF INFORMATION SECTION ===
Model Family:     Seagate Mobile HDD
Device Model:     ST1000LM035-1RK172
Serial Number:    WDEEN8XH
LU WWN Device Id: 5 000c50 0aa7f5881
Firmware Version: SDM3
User Capacity:    1,000,204,886,016 bytes [1.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Form Factor:      2.5 inches
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ACS-3 T13/2161-D revision 3b
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Mon Jan 25 12:34:22 2021 IST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   084   064   006    Pre-fail  Always       -       231590007
  3 Spin_Up_Time            0x0003   099   099   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   095   095   020    Old_age   Always       -       5470
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   084   060   045    Pre-fail  Always       -       244420425
  9 Power_On_Hours          0x0032   094   094   000    Old_age   Always       -       5801 (154 224 0)
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   098   098   020    Old_age   Always       -       2459
184 End-to-End_Error        0x0032   100   100   099    Old_age   Always       -       0
187 Reported_Uncorrect      0x0032   100   100   000    Old_age   Always       -       0
188 Command_Timeout         0x0032   100   099   000    Old_age   Always       -       5
189 High_Fly_Writes         0x003a   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0022   060   052   040    Old_age   Always       -       40 (Min/Max 28/40)
191 G-Sense_Error_Rate      0x0032   100   100   000    Old_age   Always       -       68
192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       47
193 Load_Cycle_Count        0x0032   082   082   000    Old_age   Always       -       37278
194 Temperature_Celsius     0x0022   040   048   000    Old_age   Always       -       40 (0 23 0 0 0)
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
240 Head_Flying_Hours       0x0000   100   253   000    Old_age   Offline      -       5691 (164 47 0)
241 Total_LBAs_Written      0x0000   100   253   000    Old_age   Offline      -       13570173997
242 Total_LBAs_Read         0x0000   100   253   000    Old_age   Offline      -       18654739055
254 Free_Fall_Sensor        0x0032   100   100   000    Old_age   Always       -       0

My laptop is 4 years old, and its dual booted with windows.

young is your graphics Intel ?

After two days of use, there were no random freezes while using the 5.4 kernel. In contrast, my system froze two or three times a day while using the 5.10 kernel.

@maskedman, yes, I am using the Intel on-board graphics.

Note: this all started after last weeks big update. Before that I had no problems with the 5.10 kernel.

1 Like

Same issue also exists in the latest stable kernel 5.10.13-2 .
Kernel 5.9.16-1 doesn’t have the problem.

I haven’t experienced any freeze on kernel 5.10.15-1. I think the issue has been solved.

1 Like

it’s not fixed. Happens randomly with kernel 5.10.15-1 too. Just wait 5-6 days. Can freeze after few hours or after 5-6 days.
Never happened in Windows 10.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.