Manjaro freezes on splash page

Using linux 414, manjaro xfce, everything is up to date

Whenever I try to boot into manjaro, I get on the XFCE splash page, it says starting autostart, then freezes. It will stay on this screen until the machine goes to sleep, when it will go into the system upon wake up. I can also get into the computer by going ctrl-alt-F2then ctrl-alt-F7. I’m unsure in this is a XFCE or a general manjaro issue, but I never had this problem when I had KDE installed (but that was a decent while back.) Thanks in advance.

Do you mean after Login with LightDM?
What setting have you changed?

1 Like

Yeah, sorry should have been more clear. The loading page after login.

That’s a tough question to answer. Almost all of them. The issue was happening though when I had only made minor changes like the colour theme ect. (I’m pretty sure) It has been happening since the first time I installed manjaro.

Look for errors in journal

1 Like

Never really had occasion to use the journal, not 100% sure how it works.
This error appeared a couple times though,

Jul 11 16:48:05 Kelly-linux kernel: ACPI Error: Needed [Integer/String/Buffer], found [Region] ffff9dd3961522d0 (20170728/exresop-424)

Jul 11 16:48:05 Kelly-linux kernel: ACPI Exception: AE_AML_OPERAND_TYPE, Could not execute arguments for [IOB2] (Region) (20170728/nsinit-426)

I don’t know if it has anything to do with the issue, but it’s the only error i can see occurring near boot Scratch that, I found these ones later on.

stat(/home/noah/phonebook/): No such file or directory (2)

and

disconnected: Transport got disconnected

For a journal log excerpt to be useful, you need to post more than a phrase or two lines.
BTW, the ACPI errors are not usually a breakage factor, they are just there for cosmetic reasons :stuck_out_tongue_closed_eyes:

2 Likes
journalctl -p err -b 
2 Likes

thanks man.

Haha, gotcha.

Here’s the entire output of the command tbg mentioned

-- Logs begin at Fri 2018-06-22 20:25:08 NDT, end at Wed 2018-07-11 18:27:35 NDT. --
Jul 11 18:24:57 Kelly-linux kernel: ACPI Error: Needed [Integer/String/Buffer], found [Region] ffff93ed16152438 (20170728/exresop-424)
Jul 11 18:24:57 Kelly-linux kernel: ACPI Exception: AE_AML_OPERAND_TYPE, Could not execute arguments for [IOB2] (Region) (20170728/nsinit-426)
Jul 11 18:24:57 Kelly-linux kernel: sp5100_tco: I/O address 0x0cd6 already in use
Jul 11 18:24:57 Kelly-linux kernel: kvm: disabled by bios
Jul 11 18:24:57 Kelly-linux kernel: kvm: disabled by bios
Jul 11 18:27:34 Kelly-linux obexd[860]: stat(/home/noah/phonebook/): No such file or directory (2)
dmesg -w | grep  'error\|seg\|fail\|broke\|warn\|dump' 
2 Likes

output =

[    0.000000] tsc: Fast TSC calibration failed
[    0.000000] tsc: Fast TSC calibration failed
[    3.363867] random: 7 urandom warning(s) missed due to ratelimiting

@petsam knows way more about your issue than me. I’d listen to any advice he gives you.

2 Likes

I think you might have the entropy bug.

Do this:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged
2 Likes

This has some past reports for conflicts and kernel breakages. You can try blacklisting it.
Create a file like sp5100.conf in your /etc/modprobe.d/ (root rights needed).
Paste in this file this in one line

# For avoiding freezes on splash page (or whatever you like)
blacklist sp5100_tco

Save it and reboot to check if it solves the problem.

2 Likes

Ran through commands, I feel like something went wrong though, as it never asked me for the password to super user.
terminal text copied here:

$ sudo systemctl enable haveged
$ sudo systemctl start haveged

Good catch @petsam. I searched the dmesg errors instead and turned up the entopy bug on that error.

2 Likes

They could be both as a combination :roll_eyes:

Without DDG and yakuake I would n’t be able to answer anything. Just cheating to get bonuses… :grin:

3 Likes

sudo systemctl status haveged

2 Likes

Followed instructions,
Screenshot attached so when things go wrong everyone can easily see what stupid mistake I made. Rebooting and testing now.

1 Like

output =

● haveged.service - Entropy Harvesting Daemon
   Loaded: loaded (/usr/lib/systemd/system/haveged.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2018-07-11 18:58:03 NDT; 1min 12s ago
     Docs: man:haveged(8)
 Main PID: 370 (haveged)
    Tasks: 1 (limit: 4915)
   Memory: 3.8M
   CGroup: /system.slice/haveged.service
           └─370 /usr/bin/haveged -F -w 1024 -v 1

Jul 11 18:58:03 Kelly-linux systemd[1]: Started Entropy Harvesting Daemon.
Jul 11 18:58:03 Kelly-linux haveged[370]: haveged: ver: 1.9.1; arch: x86; vend: ; build: (gcc 7.2.0 ITV); collect: 128K
Jul 11 18:58:03 Kelly-linux haveged[370]: haveged: cpu: (VC); data: 32K (V); inst: 64K (V); idx: 39/40; sz: 59688/59688
Jul 11 18:58:03 Kelly-linux haveged[370]: haveged: tot tests(BA8): A:1/1 B:1/1 continuous tests(B):  last entropy estimate 7.99936
Jul 11 18:58:03 Kelly-linux haveged[370]: haveged: fills: 0, generated: 0
1 Like

@petsam
no dice, still freezes on the “preparing autostart” screen after login