Manjaro freeze live and after installation


#1

Hello
Today I tried install Manjaro Cinnamon 18…

  1. boot live pendrive after few secundes boom screen freeze… restart

  2. boot again screen freeze… restart

  3. boot again … i click fast installation launcher success installation complete

  4. remove pendrive reboot and frest clean manjaro starting … after 1-2min boom screen freeze WTF!

  5. reboot I tried install nvidia driver but not possible …

  6. again boot from live pendrive but this time I set on free driver booting… and nice no problems I installed new fresh manjaro restart.

  7. booting from drive nice I have nvidia drive config config … 5 minutes screen freeze… omg

sometimes only just screen freeze or some strange signs… like this:

Spec:
Intel Xeon E5-2670
GeForce GTX 660
Dell 2560x1440

Please help!


#2

So - the issue is with the NVIDIA driver.

Which driver are you installing, specifically?

Have you tried a different driver series, e.g. the nvidia396 driver package?


#3

No
With free driver I have ussue after few sec with nvidia 410 I have issue after 1-5 min :smiley:

Long time ago I had the same problem with KDE now I have XFCE with latest nvidia and I dont have problem.


#4

I don’t think you wrote that in your first post, but OK.

If Cinnamon doesn’t work please try a different edition. Xfce is a good baseline. That will help narrow it down to Manjaro or your hardware.

You might also try a different distro, e.g. Ubuntu, to make sure it’s a Manjaro-specific issue.


And… you edited your post.

So - if Xfce works, use Xfce.


#5

Heh but this not resolve my problem I wanna use Cinnamon :slight_smile:


#6

But Cinnamon doesn’t work on your PC. :wink:

Does GNOME work?


#7

Whattt? how can be doesn’t work how this is possible?

Long time ago I tried all distro and I had this problem but after install nvidia problem gone
kde
gnome
xfce
deepin


#8

Which kernel and NVIDIA driver series worked when you tried previously?

You also said,

so did KDE actually work?

Also, if you post the output of inxi -Fxxxz (as text) we can see exactly what your hardware is.


#9

This was long ago I don’t wanna use KDE anymore now I use XFCE and is better I like fast and light system today I wanted test Cinnamon looks nice.

this info is from my XFCE

System:    Host: pro-pc Kernel: 4.19.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 
           info: xfce4-panel, kdocker wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Desktop System: MSI product: MS-7760 v: 2.0 serial: <filter> 
           Mobo: MSI model: X79A-GD45 (8D) (MS-7760) v: 2.0 serial: <filter> UEFI: American Megatrends v: 12.8 
           date: 12/08/2014 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 8-Core model: Intel Xeon E5-2670 0 bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 20.0 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 83224 
           Speed: 3164 MHz min/max: 1200/2601 MHz boost: enabled Core speeds (MHz): 1: 3193 2: 3040 3: 3073 4: 3198 5: 3191 
           6: 3265 7: 3222 8: 3220 9: 3262 10: 3279 11: 3193 12: 3256 13: 3201 14: 3167 15: 3234 16: 3207 
Graphics:  Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: ASUSTeK driver: nvidia v: 410.78 bus ID: 02:00.0 
           chip ID: 10de:11c0 
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 2560x1440~60Hz 
           OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 v: 4.6.0 NVIDIA 410.78 direct render: Yes 
Audio:     Device-1: Intel C600/X79 series High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1d20 
           Device-2: NVIDIA GK106 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 02:00.1 
           chip ID: 10de:0e0b 
           Sound Server: ALSA v: k4.19.4-1-MANJARO 
Network:   Device-1: Intel 82579V Gigabit Network vendor: Micro-Star MSI driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
           chip ID: 8086:1503 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel 82571EB/82571GB Gigabit Ethernet D0/D1 vendor: Hewlett-Packard NC360T Dual Port Server 
           driver: e1000e v: 3.2.6-k port: d020 bus ID: 08:00.0 chip ID: 8086:105e 
           IF: enp8s0f0 state: down mac: <filter> 
           Device-3: Intel 82571EB/82571GB Gigabit Ethernet D0/D1 vendor: Hewlett-Packard NC360T Dual Port Server 
           driver: e1000e v: 3.2.6-k port: d000 bus ID: 08:00.1 chip ID: 8086:105e 
           IF: enp8s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 525.51 GiB used: 127.24 GiB (24.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 3B7QCXE7 scheme: GPT 
           ID-2: /dev/sda type: USB vendor: Samsung model: Flash Drive size: 59.75 GiB serial: <filter> rev: 1100 scheme: MBR 
Partition: ID-1: / size: 358.69 GiB used: 127.24 GiB (35.5%) fs: ext4 dev: /dev/nvme0n1p1 
Sensors:   System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 35 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 10% 
Info:      Processes: 327 Uptime: 49m Memory: 31.33 GiB used: 5.87 GiB (18.7%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: xfce4-terminal inxi: 3.0.27

#10

So you’re wanting to test Cinnamon. You found it doesn’t work properly on your hardware. Is troubleshooting the issue going to end up being a waste of time when you find out that Cinnamon is much heavier than Xfce?

Does the GNOME edition work? It’s the DE most similar to Cinnamon.


#11

I had always problem with free graphic drivers and after installing nvidia driver it’s ok but not this time :slight_smile:

I will try more distro and I will back…


#12

You may want to try nvidia-390xx drivers. Sometimes, they are better for cards like yours.


#13

Ok looks like problem is more deep problem is with all new 18 distro kde gnome connamon new fresh nofree install on ssd and botting is very long I need wait ~ 1-2 minutes, I checked systemd-analyze nothing … and problem is still with screen freeze after 1 5 10 15 minutes and yes I tried old kernel and nvidia driver 390 340.

I tried also old distro deepin 17 zero problems instant boot and no problem with screen freeze even after update to manjaro 18 with new kernel and nvidia driver.

My main system xfce is also old 17 and now is updated do latest 18 version and working without any problems.

Problem is only with new fresh 18 distro how I can localize problem?


#14

Maybe the devs could know some relevant differences, but it’s too many IMHO to figure out exactly. I think @oberon creates Gnome ISOs.


#15

Problem is also with kde distro.


#16

The main difference is that the 18-series installers default to the 4.19 kernel. This might explain the issue if there’s some incompatibility or regression with your particular hardware.

If you try a 17-series installation and switch it to the 4.19 kernel afterwards, what happens?


#17

" I tried also old distro deepin 17 zero problems instant boot and no problem with screen freeze even after update to manjaro 18 with new kernel and nvidia driver."

My xfce is also 4.19 check inxi up.
Zero problems is running 24/7.


#18

I have this system and I just tested the Cinnamon Edition.

[manjaro@manjaro-cinnamon ~]$ inxi -MCGAN
Machine:
  Type: Laptop System: LENOVO product: 20CKCTO1WW v: ThinkPad T550
  serial: <root required>
  Mobo: LENOVO model: 20CKCTO1WW v: SDK0E50512 STD serial: <root required>
  UEFI: LENOVO v: N11ET46W (1.22 ) date: 06/06/2018
CPU:
  Topology: Dual Core model: Intel Core i7-5600U bits: 64 type: MT MCP
  L2 cache: 4096 KiB
  Speed: 799 MHz min/max: 500/3200 MHz Core speeds (MHz): 1: 799 2: 798
  3: 799 4: 799
Graphics:
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce 940M] driver: nvidia v: 410.78
  Display: x11 server: X.Org 1.20.3 driver: intel tty: N/A
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
  v: 4.5 Mesa 18.2.5
Audio:
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.19.4-1-MANJARO
Network:
  Device-1: Intel Ethernet I218-LM driver: e1000e
  Device-2: Intel Wireless 7265 driver: iwlwifi

Booted with no issues using free drivers
Booted with no issues using nonfree drivers
Installation installed nonfree drivers
Rebooted having no issues


#19

On my virtual machine also … :slight_smile:


#20

That is really weird.

I just downloaded the official ISO - wrote it to a USB using Mint Stick from the official repo.

Are you sure your ISO is complete? - checksummed?