Manjaro forgets Wallpaper settings after reboot

Hello I am new here
So the problem is after each restart, shutdown and so on. The wallpapaer reset to the breeze dark one, I am using sweet. When I change the apperance setting to desktop Plain color or something else, after the reboot it just forgets it. I also have the kde wallpaper engine plugin and even there they forget the setting. I looked around but nothing helped, I dont have a black screen or triple monitor, its just single monitor.
So if anyone has some help, I am thankful.
Here is also some system info:

  Kernel: 5.15.91-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=deb7b23b-3d28-43b9-b7f9-0749671210d9 rw quiet
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Framework product: Laptop (12th Gen Intel Core) v: A6
    serial: <superuser required>
  Mobo: Framework model: FRANGACP06 v: A6 serial: <superuser required>
    UEFI: INSYDE v: 03.04 date: 07/15/2022
  ID-1: BAT1 charge: 28.2 Wh (56.5%) condition: 49.9/55.0 Wh (90.7%)
    volts: 15.4 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
    status: discharging cycles: 108
  RAM: total: 15.34 GiB used: 4.66 GiB (30.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-1260P bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x424
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB L2: 9 MiB
    desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 786 high: 1098 min/max: 400/4700:3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 952 2: 745 3: 1098 4: 823
    5: 890 6: 664 7: 857 8: 1001 9: 585 10: 665 11: 861 12: 792 13: 881 14: 534
    15: 746 16: 495 bogomips: 79888
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdtscp rep_good sdbg sep serialize sha_ni smap smep smx split_lock_detect
    ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:4626
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2256x1504 s-dpi: 96 s-size: 596x397mm (23.46x15.63")
    s-diag: 716mm (28.19")
  Monitor-1: eDP-1 model: BOE Display 0x095f built: 2019 res: 2256x1504
    hz: 60 dpi: 201 gamma: 1.2 size: 285x190mm (11.22x7.48") diag: 343mm (13.5")
    ratio: 3:2 modes: 2256x1504
  API: OpenGL v: 4.6 Mesa 22.3.4 renderer: Mesa Intel Graphics (ADL GT2)
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:51c8
    class-ID: 0403
  Sound API: ALSA v: k5.15.91-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: a6:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp166s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
    chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 961.22 GiB used: 47.18 GiB (4.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P2SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: P2CR048 temp: 34.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SMI (STMicroelectronics)
    model: USB DISK size: 29.71 GiB block-size: physical: 512 B logical: 512 B
    type: N/A serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 488.28 GiB size: 479.55 GiB (98.21%) used: 47.15 GiB (9.8%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: deb7b23b-3d28-43b9-b7f9-0749671210d9
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.6 MiB (26.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: F41E-8FE4
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 442.62 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 509 MiB fs: ntfs label: N/A
    uuid: 98EE739FEE7373FA
  ID-4: /dev/sda1 maj-min: 8:1 size: 29.71 GiB fs: vfat label: N/A
    uuid: 5623-AD7C
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-4:2 info: Silicon Motion - Taiwan (formerly Feiya ) USB DISK
    type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s
    power: 504mA chip-ID: 090c:3350 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:2 info: Logitech USB Receiver type: Mouse,Keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 98mA
    chip-ID: 046d:c547 class-ID: 0300
  Device-2: 3-4:3 info: Framework HDMI Expansion Card type: Billboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 32ac:0002 class-ID: 0300 serial: <filter>
  Device-3: 3-9:4 info: Shenzhen Goodix USB2.0 MISC type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 27c6:609c class-ID: ef00 serial: <filter>
  Device-4: 3-10:5 info: Intel AX210 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0032
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 329 Uptime: 25m wakeups: 2197 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1455 pm: pacman pkgs: 1448 libs: 421 tools: pamac,paru pm: flatpak
  pkgs: 0 pm: snap pkgs: 7 Shell: Zsh v: 5.9 running-in: konsole inxi: 3.3.24
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 27c6:609c Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC
Bus 003 Device 003: ID 32ac:0002 Framework HDMI Expansion Card
Bus 003 Device 002: ID 046d:c547 Logitech, Inc. USB Receiver
Bus 003 Device 005: ID 8087:0032 Intel Corp. AX210 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 090c:3350 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) USB DISK
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Please correct your post title. Either drop the Majora or write the name correctly …

For your issue, check if you log in with the Restore last session in Settings > Startup and Shutdown > Desktop Session, or if you start with manually saved session and switch to Start with an empty session > Reboot your system and then test again with a wallpaper.
Sometimes helps to clean the ~/.cache folder content.

Unrelated to your issue

but might want to address that. Search the forum how to deal with it.

A swapfile helps to have a more consistent system behavior …

From a quick glance it looks like you are running Manjaro from a live usb.

You cannot make any changes to the live image.

1 Like

Please stop, this is the Manjaro’s default and what it should look like if you use PulseAudio with Plasma.

inxi should be fixed so it doesn’t list running pipewire process as a Sound Server because Sound Server’s process is called pipewire-pulse.

1 Like

How can I find out if I am running it live from USB?

So on codestack I found this code to tell you if you are running live or not.

if cat /proc/1/cgroup | tail -1 | grep -q "container"; then
  echo "linux container"
  full_fs=$(df ~ | tail -1 | awk '{print $1;}')  # /dev/sda1
  fs=$(basename $full_fs)                        # sda1
  if grep -q "$fs" /proc/partitions; then
    echo "regular linux install"
    echo "live OS running from RAM"

I got the response that I have a regular linux install. So am I running live or not?

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Well, I am in no way an expert, but I’m guessing only you can tell, and you don’t need a script.

a Live session is where you install your Linux from, typically from a USB thumb drive, but can also be a CD/DVD.

1 Like

if you got several loop mounts pointing to squash file systems, then you are running a live Manjaro iso.

$ lsblk
loop0    7:0    0  147.7M  1 loop /run/miso/sfs/livefs
loop1    7:1    0   1020M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0    1.1G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 1007.5M  1 loop /run/miso/sfs/rootfs
sda      8:0    0     10G  0 disk 
├─sda1   8:1    0      9G  0 part 
└─sda2   8:2    0 1023.6M  0 part 
sr0     11:0    1    3.3G  0 rom  /run/miso/bootmnt

Oh no, I got this. Also dualbooting Windows, windows is look edit.

loop0         7:0    0  55.6M  1 loop /var/lib/snapd/snap/core18/2679
loop1         7:1    0 169.4M  1 loop /var/lib/snapd/snap/spotify/60
loop2         7:2    0     4K  1 loop /var/lib/snapd/snap/bare/5
loop3         7:3    0 164.8M  1 loop /var/lib/snapd/snap/gnome-3-28-1804/161
loop4         7:4    0  49.8M  1 loop /var/lib/snapd/snap/snapd/17950
loop5         7:5    0  91.7M  1 loop /var/lib/snapd/snap/gtk-common-themes/1535
sda           8:0    1     0B  0 disk 
nvme0n1     259:0    0 931.5G  0 disk 
├─nvme0n1p1 259:1    0   100M  0 part /boot/efi
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0 442.6G  0 part 
├─nvme0n1p4 259:4    0   509M  0 part 
└─nvme0n1p5 259:5    0 488.3G  0 part /

So does that mean I running live Manjora iso?
I just finished customizing all of my desktop and konsole

Edit: So nvme)n1p5 is a linux and nvme0n1p3 is windows

While it looks like you installed Manajro - I looks weird that you have no partitions using a LInux filesystem.

EDIT: found it

Should I maybe reinstall Manjora from USB or try to fix it?

Edit: So you found it, so need to reinstall?

@LordTermor do we have some script/setting in /etc/xdg which runs on startup to set a wallpaper?

So I changed it to empty session and if I change wallpaper it still doesn’t safe after restarting. Don’t know why.
Edit: Could not do swap partitions in Linux so switching to windows to see if it works, because the original partition was created in windows

Nope, we don’t.

So I tried making a partition in the partition manager for swap. But it wont let me resize or add anything on the linux partition. I also tried the same thing in linux and I don’t want to try doing it over konsole(not sure if you even can).

Edit: About to delete the linux partition from my Windows system, (before that saving all files and things I changed). Then doing new and clean install of manjora. Will it fix some stuff or not?

Hmm, sounds similar to this one:

Hey thanks. So I changed my global theme to the default and applied it all. Now it saves, my question is, they talk about moving all the things manually, my question is where all the global themes stored? I cant find the location.

Edit: found the location /usr/share/plasma/desktoptheme/

If both sound servers run then inxi will report it like that. See on my end


  • pipewire-pulse running but
  • pulseaudio not running

and inixi shows this:


So, whatever you explained is not so.

I mentioned swapfile NOT swap partition. Also it can be zram-generator