Manjaro for khadas VIM3-L


I have used Manjaro KDE plasma with vim3-pro board. it’s working nice. now i am looking manjaro os for khadas vim3L board.
are there manjaro os available for khadas vim3-L board ?

We have some Dev images here:

It’s quite a new board for us, so it does not have a release yet.

Hi @ Strit

I have download and installed in Sdcard os from link you given me as above text20119.img.xz

My Issue → Os (Manjaro-ARM-kde-plasma-vim3l-20220119) does not booting.

@spikerguy any idea why this might be the case?

what do you have on emmc storage ?
I will check this image whether it is Bootscript based image or mainline uboot based image.

This image is following bootscript method which needs Android on emmc and in latest update this method is dropped.

Please try latest image to have mainline uboot and can boot os without depending on any os on emmc.

Hi @ spikerguy
thanks for replying me
I have installed from
which latest release but still not able to boot.

frome where i can find this?

Please explain how you installed it. What do you have on emmc?

Hi @ spikerguy

There are Ubuntu image ( by khadas vim3l) in Emmc.
i am installing < > image using baleno echer on SDcard of 16GB.

I am not sure which uboot it is using, so in order to boot into sd card you need to enter into maskrom mode.

You can use the key combination to enter into maskrom/upgrade mode.

Kindly provide uart log for better understanding.

Thanks @ spikerguy

I have already tried with upgrade mode. but not booting.
there are already u-boot.bin file in BOOT_MNJRO partition of SDCard.
do i need add any extra in boot partition ?

No. Do you have extconfig file in /boot/extconfig/ ?

I will test the same image tonight and see what it does.

Hi @ spikerguy

No, There no such file

There are just as below
tushar@tushar-Desktop:/media/tushar/BOOT_MNJRO$ ls
dtbs extlinux Image initramfs-linux.img u-boot.bin

tushar@tushar-Desktop:/media/tushar/BOOT_MNJRO/extlinux$ ls

Everything looks good to me.

Let me test it myself once again with the latest image so I can understand what is the image doing.


Thanks for informing that its not booting.
It had a missing uboot.

Please try the latest image which I just built with updated uboot.
Images here: Manjaro-ARM-20220226

Please share your feedback once you test the image.


Hi @ spikerguy

I tried. but still not able to boot

I have also tried latest release that 5 Hours released . that is also not booting.

I have tried old release which was success to boot as belod link

The lastest image have mainline uboot.
So you cannot boot it over android in emmc.

As for said old image is working that means you have android in emmc.


for release 20220228, I installed Ubuntu 20.04 (linux 4.9) in eMMC . now not Android in eMMC but still not booting.

for release 20220226, I alsotried having Android and Ubuntu in eMMC but not booting.


I think ubuntu 4.9 image is using bsp uboot similar like Android image.

It would be better to move to khadas forum so khadas team can answer as it seems to be the issue of uboot conflict.

If you enter maskrom mode and boot the latest image from sd card then there would no problem any more.

Khadas forum Thread

Will close this topic here.