Manjaro failed to boot

I have Manjaro installed on the secondary nvme on my laptop. Now it fails to boot and freezes at the following screen:

CapsLock and NumLock toggles, but I can’t ssh in, nor switch to any tty.

However, if I boot this Manjaro drive using VMWare, everything works fine.

Please help and feel free to ask for more information. Thank you!

--------------------UPDATE-------------------

I figured out how to boot into the system. My laptop has two GPU mode, Hybrid (Optimus) and Discrete mode. When switching to Hybrid mode there’s no issue.

But now I am trying to make Manjaro work with the Discrete GPU mode.

I tried uninstall the driver mhwd -r video-hybrid-intel-nvidia-prime, then install manually with mhwd -i video-nvidia, with no luck.

did it worked previously on discrete?
since it doesnt work with nvidia only, its probably related to nvidia… try adding this parameter to your kernel:
sudo nano /etc/default/grub
and in this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
ibt=off
dont remove anything from there!, just add it to existing parameters, save the file, update grub:
sudo update-grub
reboot and test