Manjaro dual boot with Windows 11 - Manjaro corrupt NTFS volumes

I have been using a dual boot for some time now. I switch once in a while between the two OS. That work fine but I noticed that returning from Manjaro to Windows, NTFS shares volumes are often corrupt and need repair. I mount some volumes in the “fstab” file In Manjaro. Also, sometime there are a bunch on chk0000 corrupt files in those volumes in Manjaro. It doesn’t seem to impair the functioning but I am not sure if i am loosing data. Is this a known problem ?

Reliable data corruption? No…

Maybe you can describe a bit more what you are doing and how you are doing it.

I have a 5 year old dualboot (win10) with NTFS on the windoze side and I have never seen such a thing.

I can attest to also see this exact behavior.

Although, I thought it had to do with my drive being very old so I didnt really pay much attention to it and just “worked around it”.

I mount with systemd, and sometimes, less since moving from fstab to systemd, but still sometimes, like 1/20 shutdowns (VERY rarely at reboots) my computer freezes with errors around the drive (have none lately and thought it had to do with old drive, but maybe not, if it happens I will paste the journalctl output, or I can link to a post here in this forum if this seems related to op:s problem). Sometimes it fixes itself within a minute or 4, sometimes I can just press esc, sometimes changing tty shuts down the computer and sometimes I even have to REISUO to get it to shut down.

One clue could be the ntfs file journal list (I don’t know what they are called).

This is the scenario:

I haven’t booted into windows for a while.
After loading windows sometimes (more lately tbh, this has been going on for months) says the disk might be corrupted, but never really finds any errors after running the check it offers.

Other times, when the disk is NOT reported as corrupt:
I use a backup program called urbackup. It makes incremental backups by reading the filesystem logs on ntfs somehow, compares to a database and uploads changed files. One client on linux and one on windows, but they share the drive and urbackup is clever enough to realize the 1tb is the same on both, so shares the backup data with the two clients.

Even if I have made changes to the drive in linux, could be moving, removing or adding gigabytes, creating folders etc, it does not detect any changes on the drive in windows when checking until I run fsutil.exe usn deleteJournal /D E: (my drive is e: in windows)
I’m guessing it deletes the filesystem logs or something because after that urbackup detects everything as changed.
If windows warns about errors and I run the offered test, it also fixes so urbackup detects changes.
Doing changes to the drive in windows (writing files, moving etc) does not make urbakup detect the changes made in linux, only the changes made in windows.

I can access the drive and all files (incl the new ones made from linux) in windows just fine. But not even that makes urbackup detect them! :open_mouth:

On linux the drive works flawlessly, with urbackup as well.

Not sure if it’s related, but since the symptoms seems very similar, maybe we can compare setups and stuff.

Microsoft’s filesystems has a tradition of being patented and closed source.

Only in 2019 the exFAT[1] filesystem specification was published - yet is still patented.

This makes it difficult for the reverse enginered implementations to make full use of the filesystems which in turn makes Microsoft Windows complain as the modified filesystem fails one or more validations with regard to data integrity.

The examples mentioned is typical for devices which are used interchanged between Linux and Windows and there is not much one can do about it - except for using exFAT for shared devices.

Since the exFAT filesystem specification was released it is recommended to use exFAT for filesystems shared between operating systems.

Linux has support for exFAT via FUSE since 2009.[4] In 2013, Samsung Electronics published a Linux driver for exFAT under GPL.[31] On 28 August 2019, Microsoft published the exFAT specification[6] and released the patent to the Open Invention Network members.[32] The Linux kernel introduced native exFAT support with the 5.4 release in November 2019.[33]
exFAT - Wikipedia

I also dual boot with Windoze and never had a single issue with the shared NTFS. It’s important to completely shutdown Win before switching OS, Fastboot and all this stuff should be switched off to avoid the system is just in sleep mode.

1 Like

I am doing pretty much similar things in both OS. Web, Mail (Thunderbird),Office, Movies,Steam, etc … All Linux previously mounted drives seems to be randomly affected. When I reboot in Windows, it doesn’t signal any problems. It is only when I force a scan of the those drives that it will tell you that it needs repair. Most of the time, it can be repair, very quickly, on the spot but other time, requires a reboot. Now I am a bit scare to use Manjaro and loose data.

My system is :
AMD Ryzen5 5600
Video Asrock RX6600 8GB
16 GB DDR4 3200
A mixture of very recent Nvme, ssd drives.

For those interested, here’s a snapshot of those strange error files (found.00x) in Manjaro, not the boot drive. It looks like a copy of the file system ??? I have the same file(s) on another mounted volume too.

After a couple updates, the situation is much better. Very minor Windows (11) complains about a hard drive to be repair but most of others are fine. Gone are most of the .chk files. I am using the latest kernel and I have seen, if I recall correctly, that there was an update of the ntfs-3g driver with kernel 6.2. Not sure, but definitely reassuring.

There is a difference between the available ntfs drivers

  • ntfs is readonly kernel space
  • ntfs3 is readwrite kernel space (2021) (linux515)
  • ntfs-3g is user space (2006)

The future of the kernel driver is somewhat undecided as of 2022-04-28T22:00:00Z and described at Linux kernel NTFS driver author goes silent • The Register