Manjaro dual boot option

OK it doesn’t like the x a 1 w q

Maybe it’s required to clarify one point:
If done properly the Calamares installer only will install grub’s MBR in the MBR of the disk you intended to install Manjaro, it’s not at all affecting the Windoze installation on the other disk. If this got wrong on your system you most likely selected the wrong disk for the boot loader installation, so next time you install Manjaro take care! If you are not sure - ask upfront. Saves you a lot of time. :wink:

1 Like

Have you tried to use a Win 10 boot repair from a USB instead of DVD?
The Win 10 install ISO contains a boot repair tool.

we need to remove the boot flag from /dev/sdb1
this can be done using many partitioning tools, but gparted is probably the easiest if you have it installed.

fdisk is my preferred, but gparted would probably be easier for you.

He’s got bootable partitions on both disks so it seems like manjaro/calamares has done the right thing.
I feel @kokanee doesn’t really understand how MBR systems boot and has his boot priority in his BIOS set incorrectly despite his retorts to the contrary.

I have ample extended experience and knowledge of PCs, MBR boot settings, BIOS settings/implementation, boot device priority , hardware and software. I am a bit rusty with Linux now as I have not utilized it for 20 years. I would prefer to reset and reinstate my position in the support forum so I may receive continued assistance from the forum.
The issue seems to be the os probe function for grub 2.06 and the partitions for MSDOS of the hard disk Manjaro dual boot function. I tried disabling os probe of grub however I do not know if I succeeded, the dual boot option is still active. At this point I am thinking the hard disk MSDOS partitions need to be removed or modified for the Manjaro hard disk. Suggestions/actions now?

I have deleted the boot flag /dev/sdb1. The dual boot option in Manjaro is still active. It seems that at this point my remaining option is to delete all the partitions on /dev/sdb to remove dual boot option and Manjaro.

Switch from Windows - how to use GNU/Linux:

1 Like

MBR booting works as follows

BIOS selects first boot device & checks for a bootable MBR on that device.
If none is found, the BIOS then moves to the next Boot device.
The bootable MBR then reads the boot record of the partition on that device flagged as “bootable”.
if no bootable partition is found, the BIOS then goes to the next boot device.
this continues until a bootable MBR & partition combo are found.

If you’re continuing to have Grub load, then you’ve somehow managed to install grub over the partition loader for windows.
In which case you need to boot to windows recovery media to restore this.
If you cannot boot to windows recovery media, it’s because you haven’t set that media as the primary boot device, there is no room for debate on this.

Boot priority needs to be set within your BIOS, not just from the “quick select” menu.
You could also try disconnecting drives to force your BIOS to boot to a particular drive.

@kokanee I want to test our assumption that this is actually a legacy BIOS system that’s booting from MBR.

Can you please post the output of

mount | grep efivars

no output or listing

I got the repair DVD to boot and run to repair Win10. Unfortunately I had delete the boot partition in Manjaro but I can partition and reinstall Manjaro. TY andreas85 for posting the tutorial, very interesting and informative. A good read.