Manjaro Dual Boot Loader

#1

I have a dual boot setup for Manjaro GNome and Cinnamon. No problem with either one works perfectly easy to do.

Where I am running into not so much an issue is on the Boot Loader. So I can tell which one I am booting to.

Where is says
Manjaro Linux change to Manjaro GNome
Manjaro Linux (18.0) (on /dev/sda1) change to Manjaro Cinnamon

Also want to change the Advance options for …

Did it once by manually changing it in the grub.cfg file and it worked until updates were ran and it also updated the boot loader and it changed them back.

What I am looking for is how to make it permit (if it can be done).

Thanks
Rustys

#2

Maybe you will find the relevant info on the Arch wiki, section 3.

From what I quickly saw, you will need to re-generate the grub.cfg file each time grub is updated…

#3

At both Manjaro OS’s, change /etc/default/grub and /etc/lsb-release

GRUB_DISTRIBUTOR=""
and
DISTRIB_DESCRIPTION=“Manjaro Linux”
respectively

Do ‘update-grub’ at both.
If uefi and you want to have distinct efibootentry names
Do at both OS with different bootloader-id names
sudo grub-install --bootloader-id=yourDE

[EDIT] - correction -

We should change /etc/os-release as well as lsb-release.
upstream grub uses os-release
old manjaro modified grub uses lsb-release
new manjaro grub (aka ‘fedora-grub’, aka ‘silent-grub’, aka ‘flicker-free’ grub) reverts to using os-release.

2 Likes
#4

Have not had time to get this taken care of yet thank you both for your assistance.

Will let you know the results when things calm down.

1 Like
#5

For my curiosity: why dual boot Manjaro Gnome and Cinnamon, and not have just one Manjaro with both DE installed?

#6

Did not know that could be done.

Could you explain or link to more information.

Granted I get the basic two shells one OS.

#7

I open Gnome and make the changes then switch to Cinnamon and open the files and they show the changes that I just made in Gnome.

What am I missing and yes I did do two separate installs and told it to install along side.

#8

Changed 3 things at both OS’s?

#9

Does it not work ?

I tested again (I normally do not use Manjaro’s grub and I normally disable os-prober) on 3 new manjaro installs and this is what I have…
(called them April, May and June) - [name of 3 foreign girls I know - not biblically]

From the ‘originating’ OS grub (April)


### BEGIN /etc/grub.d/10_linux ###
menuentry 'April ext4 Linux' --class april 
.
.

menuentry 'May btrfs (on /dev/sdc5)' --class may 
.
.


menuentry 'June f2fs (18.0.1) (on /dev/sdc6)' --class junef2fs
.
.

From os-prober (not from April, but another ‘normal’ Manjaro OS)

[pop@Eight ~]$ sudo os-prober
/dev/sda10:KaOS (rolling):KaOS:linux
/dev/sda11:Manjaro Linux (18.0.1):ManjaroLinux:linux
/dev/sda12:Manjaro Linux (18.0.1):ManjaroLinux1:linux
/dev/sda8:Ubuntu 18.10 (18.10):Ubuntu:linux
/dev/sda9:Manjaro Linux (18.0.1):ManjaroLinux2:linux
/dev/sdb1:Windows 8:Windows:chain
/dev/sdb10:Manjaro Linux (18.0.1):ManjaroLinux3:linux
/dev/sdb11:KaOS (rolling):KaOS1:linux
/dev/sdb12:Bodhi Linux 5 (18.04):Ubuntu1:linux
/dev/sdb2:Mageia 7 (7):Mageia:linux
/dev/sdb3:Ubuntu 18.10 (18.10):Ubuntu2:linux
/dev/sdb7:Solus (3.9999):Solus:linux
/dev/sdb9:Ubuntu 18.04.1 LTS (18.04):Ubuntu3:linux
/dev/sdc4:April ext4 (18.0.1):Aprilext4:linux
/dev/sdc5:May btrfs:May:linux:btrfs:UUID=4609fa94-7ea7-4c21-85d2-02dcf52e06b5:subvol=@
/dev/sdc6:June f2fs (18.0.1):Junef2fs:linux
/dev/sdc9:KaOS (rolling):KaOS2:linux
[pop@Eight ~]$ 

As you can see, it works for me.

#10

Yes, that is very simple.

You just install new desktop environments in one of your Manjaro install, following the wiki instructions here.

You just have to tweak things a bit sometime, but other than that it just works most of the time. For instance I have XFCE and tried KDE, Open Box, and Enlightment, and currently have i3 as my main DE. It works like a charm.

Don’t hesitate to search the forum if you have tiny configuration problems (sometime it’s the icon set that is different, a common configuration file, or something like that…), as someone most probably have tried that before you.

You can then switch between DE at the user login screen, on the bottom right there is an icon to select the DE.

I will recommend doing that because it will avoid maintaining two versions of Manjaro and probably be better for a day to day use (only one home folder, etc…)

1 Like
Grub_problems
#11

Don’t know, not possible, the files may be on a common partition .

Maybe show us the result of the command os-prober so we can tell more?

#12

Had to do the os-prober on each one would not list like the one did for gohlip.

Here is GNome

[rustys@ManjaroGnome ~]$ sudo os-prober
/dev/sda1:Manjaro Linux (18.0.1):ManjaroLinux:linux
[rustys@ManjaroGnome ~]$

Here is Cinnamon

rustys@ManjaroCinnamon ~]$ sudo os-prober
/dev/sda3:Manjaro Linux (18.0.1):ManjaroLinux:linux
[rustys@ManjaroCinnamon ~]$

#13

Let me attempt it again starting with GNome the Cinnamon now that I have it printed out for easier reference. (ok for me it is).

Edit:
Did the changes in both. Made the changes in GNome and when I went to edit the files under Cinnamon they were already change to what I changed under GNome.

Made the changes to them again and now I get the following screen.

Screenshot%20from%202018-12-29%2016-05-15

#14

Just turned on the system and now it is showing as.

Screenshot%20from%202018-12-29%2018-11-26

If I select Manjaro Cinnamon Linux it loads GNome and when ever I check the files you said to change they are what ever I change them to in the other versions.

Example if I change it in GNome and then open the file to make changes in Cinnamon the changes are there to what I made them to in GNome. (hoping that all makes sense).

#15

I get the IDIOT prize of the year.

I got it done correctly and it is right on the money.

Here where I was going wrong was not selecting the File System. I was opening the information under Device which sent me to the same files that I kept changing.

Thank you both for your help and suggestions. Will definitely look at the other way of doing this looks and sounds SOOOO much easier. That will be for a different day now must get wireless printer working with both and pound head on wall.

2 Likes
closed #16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.