Manjaro doesn't start after the last update

Hi! Can anybody help me, please?

I’ve been using Manjaro BSPWM since last year and I am very happy with it. However, yesterday in the night, my laptop received the last updates (I think kernel updated too). As an update has never broke my system, I didn’t pay attention, wait for the updates and shut dow the laptop.

Since today in the morning, when I start my computer, the grub appears and whatever kernel I choose (I have 5.9 and 5.10), I only get a black screen and the fan gets louder. I tried to wait to see if something happen, but I end shutting down the laptop with the power button. My windows partition works fine. The problem is only with Manjaro.

Somebody knows what is happening? I didn’t found my situation in the forum!

EDIT: I solved it using a live usb and installing another kernel (5.4 LTS) using chroot. If anyone has this problem, the solution is that way.


Just curious, is this something Timeshift can restore? If so, i would get into the habit of backing up the system with it before each new system update.

You can use “timeshift-autosnap” to do it automatically.

1 Like

I have timeshift previously, but I think that not in this machine. I have a live usb, is there a way to enter to the system as root and reinstall the kernel or install and LTS?