Manjaro doesn't start after kernel update

Hi everyone,

After Manjaro update, system notified me that kernel 5.13 is not supported so I update it to 5.15. After this update I change it to 5.15 having flickering in my screen after screens goes dark or after ivernate. So I tried to install 15.10 amd remove 5.15. But I think I didn’t run no kernel or I don’t really know but Manjaro gets stucked flickering just after booting so I cannot start de OS to change the kernel.

How can I fix this please? I cannot see neither the manjaro boot options when escaping the boot on start.

Need help as I don’t have much knowledge :confused:

Thanks a lot

Update: Now I see manjaro boot options, I got within advance section Kernel 5.10.84-1-x64 and the same one but says - fallback initramfs. I got a recovery USB as well in case it helps

Also yesterday I deleted opencl-mesa and install intel runtime drivers as I couldn’t use davinci resolve. After did this everything worked well and davinci recogniced iris xe graphics gpu. So I cannot think this is due to this change but I don’t really know

Branch: Stable

Desktop Environment: KDE Plasma 5.23

CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700GHz

GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics]

Kernel: 5.10.84-1-MANJARO

Architecture : x86

I cannot enter to the OS to have more specs sorry…

1 Like

Do Not Attempt To Remove a Running Kernel.


Yeah now I can see… What can I do now to recover it? I have some important documents…

Sorry but I started to learn linux just one year ago and I didn’t now this. How can I fix it?

if you are able to enter grub advanced options then you can get into manjaro with any available kernel. if not present then boot with a live usb:

sudo manjaro-chroot -a
pacman -Syyu
mhwd-kernel -i linux54 #install the 5.4 lts
mhwd-kernel -li #verify if correctly installed
exit #end-chroot

side note if you are not able to see grub on boot then:

sudo manjaro-chroot -a
vim /etc/default/grub
#change GRUB_TIMEOUT_STYLE from hidden to menu
update-grub #this is a command




Switch from Windows:

1 Like

I am in Manjaro Advance Options, and I see three options:

  • Manjaro Linux, which starts normaly so have the same issue
  • Advance options for Manjaro Linux, there I got Kernel 5.10.84 and the same as fallback initramfs. None do the trick…
  • UEFI Firmware settings

And above E = Edit Boot Options C = GRUB command line…

How to proceed there? So sorry for my ignorance :frowning:

should have worked with 5.10 :thinking:

have you installed 5.10 in chroot env??

Sorry don’t know what’s that. I just installed it by Manjaro’s System Settings > Kernel. But did it wrongly installing 5.10 and removing 5.15 which was the one running at that point. So I reboot and now I cannot enter. I noticed that using recovery USB which has kernel 5.13 starts but withing the USB so I dont know if there, using the terminal I can do something with the kernel like you said or it just affects the USB’s Manjaro? I feel very stupid after done that…

we can enter a broken (or unbootable in your case) system from the live usb and fix it. here is guide:

follow these steps and install linux5.4 lts from the internet through the usb to your system (kernel version of live iso on usb doesn’t matter)

1 Like

Thank you, I am going to try that And will let you know…

1 Like

After synchronize package databases, I do the command to install linux54 within chroot but after synchronizing it prompts “error: target not especified”.

Also I got this error message after “sudo manjaro-chroot -a”:
Grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your
Mounting (ManjaroLinux) [/dev/nvme0n1p2]
mount: [/mnt]
mount: [/mnt/boot/efi]

Don’t know if this is ok…

this is fine. no need to worry.

try now :point_down:

sudo manjaro-chroot -a
pacman -Syyu
pacman -S linux54 linux54-headers linux54-extramodules
pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')
pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-extramodules"}' ORS=' ')
exit #end-chroot

Man you the boss now its working.

What should I do now? Stick with this kernel or just don’t removing a running one I can try wich one fits better to prevent image flickering after screen goes off? This kernel works well in this case

Have one question, when removing a kernel all its dependencies and extramodules go away as well?

The way to change the kernel is at booting like I’ve done or can I do it at System Settings GUI? In case I want to try differents…

Thank you a lot

1 Like

Did you know that Manjaro has a very nice wiki? It would certainly be a good idea to take a look there. Among other things it contains a guide on how to manage kernels.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.