Manjaro doesn't seem to be using my RTX 3080 Ti card (Intel thingy instead)

Hey folks! I’m confused as heck. I have an ASUS Scar 17 SE laptop (G733CX-LL016W) which has an RTX 3080 Ti mobile graphics card. I’m not 100% sure if this is an Optimus card or not. What baffles me is that even after installing Nvidia drivers, Manjaro Cinnamon’s system info tells me this:

Shouldn’t it state the name of my graphics card there? If it’s not an Optimus card, shouldn’t there be only one card listed here? And it it’s an Optimus card, shouldn’t nvidia-settings offer me the option to switch? This is all I get:

Now, I have a theory. I think the two graphics cards are (1) the Nvidia card and (2) one embedded in the CPU. My full system report suggests this, and also, it suggests the Intel thingy is the one in use:

I tried installing optimus-manager-qt, but that led to a boot freeze and, being new to Manjaro, the only recourse I saw was to reinstall the system. So I’m wary about touching that again.

I can say for sure that performance seems a bit choppy even just in normal desktop mode, e.g. when I trigger the window spread, the animation is slightly choppy while it’s buttery smooth on my 8 year old desktop with a 1080 Ti.

So my questions are:

  1. How do I know if this even is an Optimus card?
  2. Why does the System Info not recognize/show the card’s name?
  3. Why won’t nvidia-settings let me switch graphics adapters?
    4. Most importantly, how do I tell Manjaro to use the 3080 Ti?

Output of lspci: 0000:00:00.0 Host bridge: Intel Corporation Device 4637 (rev 02) DeviceName: O -
System report: System: Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2. -
Terminal output while installing Nvidia driver: $ sudo mhwd -a pci nonfree 0300[sudo] password for thebrightside: > Using co -

Any thoughts on this would be greatly appreciated! I’m out of ideas.

1 Like

If you are using a laptop that contains a NVIDIA GPU, it is optimus. You have an iGPU (integrated GPU) which is the Intel, and a dGPU (discrete GPU) which is the NVIDIA.

By default everything on your computer uses the iGPU, as the dGPU is not really necessary for normal work and it uses significantly more power. You can check to make sure that the dGPU is actually available to be used by running nvidia-smi, which will give an error if the dGPU is unavailable.

Instead of trying to switch your system to use the dGPU, I highly recommend instead only running programs you need (e.g. games) with it. You can do this by prepending


to the command. In Steam, you can edit the launch command to be


You have an Alder Lake iGPU, so it is powerful enough to handle normal desktop use and even many games. Your lag issue is most likely caused by something else.

Thanks for explaining! This is a completely new system, there’s nothing at all installed on it beyond what comes with Manjaro, just the Nvidia drivers. So I’m at a loss as to what might be causing the choppy performance.

So, basically, my options are to either run e.g. Darktable, Gimp, Kdenlive or games from the terminal, prepending those variables to the commands - or to write .sh scripts for all these programs?

On my older laptop (RTX 2070), nvidia-settings offered a way to switch with GPU I wanted to use, it looked like this:


Do I understand correctly that this being MIA is a Manjaro thing, or does it have to do with my new laptop?

You can also edit the desktop entries so that they launch with dGPU by default, or to add a right click > run with dGPU option.

Many beginner-friendly distros do a bit more work to make optimus run smoother. Some implement by default a way to right click > run with dGPU. Particularly, Ubuntu has a set of custom scripts that make things a lot easier. I personally haven’t had any problems using optimus on Manjaro, but I only use it for games so it’s very easy for me to manage.

Just to cover our bases, we can run a quick benchmark. Try running glxgears, it is a very simple benchmark so the framerate should be good. You can also run intel_gpu_top to see load on the iGPU.

If these two tests don’t turn up anything, I am not really sure where to go from here. However, you can get help from others on the forum. It will be easiest if you make a new thread that more accurately describes the problem, which will draw people who know how to solve it. Probably best to link this thread in the new one just in case I’m stupid and it somehow is an issue with the iGPU, and just generally to provide some more context.

Thanks! I appreciate the help. I’m starting to think I might not be this distro’s target audience. I tried Darktable and it shows no OpenCL available whether I run it straight from the menu or from the terminal using the command,

$ __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia /usr/bin/darktable

By now, I’ve reinstalled 3 times and it seems every time I solve one problem, another pops up. I’m happy to tinker, but after 2 days, I wanna get on with my life. Mint’s live USB crashes on boot, so I’ll try Zorin OS and Ubuntu Cinnamon next. If they don’t work, I think I’ll just use Windows until Mint catches up with my PC.

Anyway, sorry about ranting. Thanks for your help!

by default you are on intel and nvidia is ‘dormant’…
you can use prime-run command to run specific programs on nvidia, for example:
prime-run firefox
and check with nvidia-smi if its running…
you also need ibt=off parameter since you are on newer kernel than 5.15…
you are also running on RAID instead of AHCI:

  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6
    bus-ID: 0000:00:0e.0 chip-ID: 8086:467f

so in bios switch from raid to ahci… dont switch if you have installed windows, otherwise you will not be able to boot…
and optimus-manager-qt is just for switching using a gui, you also need optimus-manager:

sudo pacman -S optimus-manager optimus-manager-qt

if you get stuck at a black screen, enter into tty: ctrl+alt+f2 or f1-f6 keys, enter your username and password and remove optimus:

sudo pacman -Rs optimus-manager optimus-manager-qt

That is for you to decide, and it’s totally fine if you want to go with something a bit easier. A word from the wise, though: the first week or so with a distro is always the hardest, and is not an accurate representation of how much work you will actually need to do to manage it. Each distro has its own quirks that need to be ironed out, but once you get past those you will typically find your experience much smoother. Manjaro is definitely not a set-it-and-forget-it system, but it’s not intended to be a mountain to climb like Arch.

The issues you are having on Mint can probably be fixed if you try asking on their forums or doing some googling (especially including some of your specs or laptop brand). I encourage you to give it another try, it has a reputation of being newbie-friendly for a reason.

Don’t get me wrong, I’ve been a very happy Linux user for 14 years. Switched from Ubuntu to Mint a couple years ago and I think it’s fantastic. However, its live USB won’t boot due to the “out of memory” bug in Ubuntu 20.04, and I’ve tried all the measures I could find (except for a few that went way over my head). That’s why I spent the past few days distro-hopping.

(EDIT: here’s my thread on the Mint forums re. the “out of memory” bug: LM 21.1 Live USB: "Out of memory" error - Linux Mint Forums)

I tried Manjaro once before, I think in 2019, for a few days and even then, I determined it was too complicated for me. It’s true, Ubuntu and its derivatives make things comparably easy, a lot seems to be there at the tip of your fingers that you need to go through complicated setups to achieve in Manjaro. Still, I’m drawn to it! It’s obviously a very powerful system. And I appreciate your friendly and helpful responses.

For now, I’m trying Zorin OS and it works out of the box, but it’s less customizable than Mint. Jury’s still out on where I’ll end up eventually.