Manjaro doesn't boot, boots to a black screen, or stops at a message

While there are many potential reasons why your Manjaro installation doesn’t boot to a desktop, the primary reason is that the graphics drivers haven’t loaded correctly so your login/display manager (DM) doesn’t start. This is why you get a “black screen” or stuck at an

[   OK   ] Started some service

message.

The normal reason for this is that you have the incorrect driver version for the kernel. This happens when the mirror you are updating from is not fully synchronised and so has different sets of packages in [core] and [extra]. This means the driver extramodule package in [extra] has been built for a different kernel point-release than that in [core].

The first thing to try

Switch to a text console with CTRL+ALT+F2, log in with your normal username and password, then run a full update:

sudo pacman-mirrors -f3
sudo pacman -Syyu

The first command will refresh your mirror list, picking three of the most recently updated mirrors (so those mirrors will all be up-to-date).

The second command will force a download of the current package lists, then perform an update if any updated packages are available.

If any packages were updated, reboot.

Note: If you can’t log in to a text console, use a chroot instead.

The second thing to try

Log into a text console as above and run startx. This should either start X, in which case the issue lies with your Display Manager (e.g. GDM, LightDM, SDDM), OR you will be presented with some output and returned to the console. Of particular interest are Error (EE) lines.

If you can’t see anything obvious

If neither approach helps fix this issue (which the first one will in 90% of cases) then search the forum (https://forum.manjaro.org/search?q=black%20screen), and, if you can’t find anything, start a new thread mentioning what you have already tried.

If you want more detailed instructions

Read this thread:

22 Likes
4.19 Black screen
Stuck at ‘Started TLP system startup/shutdown’ after latest update (not during installation)
Having boot problems, no GUI login but text console OK [solved]
[BOOT] boot doesn't go farther than TLP startup [RESOLVED]
Grub cannot find kernel
Manjaro stuck on boot after latest update
Stuck at boot screen after updating packages
Unable to boot ..."machine has amw0_guid1"
Deepin Desktop freezes on login
Manjaro KDE boots to black screen with only cursor.
No terminal on tty1 after install, is it safe to enable it?
Black Screen Plasma 5.16 Manjaro Testing
Manjaro doesn't boot after system upgrade
Error during boot
Newbie here. Computer won't boot after latest update
Is it possible to install the open source drivers for an AMD GPU from live environment?
After upgrade from Kernel 4.14 to 4.19: No login, just mouse pointer and black screen
Manjaro Doesn't Boot in triple boot
After installing Manjaro Kde at start wont recognize grub
Installation problem Manjaro KDE / XFCE
Manjaro Won't Boot After uninstalling Bumblebee and trying to install Nvidia drivers using MHWD
Kernel Panic, System not booting
No image after GPU update to RX 5700XT
My manjaro doesn't boot after i download a package for gpu
Manjaro KDE freezes after "started tlp system startup / shutdown"
Can't reboot with Manjaro Architect
AMD laptop not starting at first boot, starts after many consecutive boots
Manjaro Gnome fail to boot(?)
Newly installed, boots to blank wallpaper
I need help with my Manjaro
Why can't I log in? Says failed to start session
Manjaro won’t boot anymore
Manjaro won’t boot anymore
(SOLVED) Updated kernel not booting
[SOLVED] New install, boot stuck on Started TLP system startup/shutdown
[Stable Update i686] 2019-01-25 - The Pretty Much Everything™ 2 Update
Problem after restart
Installed a bad graphics driver
Failed to start Light Display Manager help?
ASUS TUF Gaming FX505DY / Manjaro Install / Compatibility
Problem on load desktop
I messed up with some packages and manjaro is booting on tty1 and cannot see my GUI
Unable to boot into manjaro due to shared libraries issue
Stuck in starting TLP system startup/shutdown
[Yet another] Black screen on fresh Manjaro install
mount: /usr/lib/libmount.so.1:version `MOUNT_23.4` not found
I think I Broke manjaro some how
Blank screen after updating system - dell inspiron 11
Boot issues (cannot boot)
[SOLVED]After install, Manjaro is stuck at "Started TLP system startup/shutdown"
OS not booting. Lighted black screen with white underscore
Installation problems with Manjaro on Dell G3
No login screen after latest 18.0.0 update
Manjaro don't start
My Manjaro black screened after the latest update
Software update stalled, blank screen, had to reboot, now Network Manager fails, hangs on boot
No display after update
only booting into (tty1)
Bbswitch: No suitable _DSM call found - error
Bildschirm wird mehrmals schwarz nach Login, kein Login-Bildschirm nach Logout
I seem to have broken my system
Boot Failure - Unrecognizable Error
Stuck on Generating mirrorlist on boot
Laptop doesn't boot after installing amdgpu-experimental
Kernel LTS 4.19 boot up xfce 10 minutes black screen
Today's update crashes system?
Can't boot stuck after grub
Manjaro boots to black screen after messing up my xorg config
Can't request region for resources mem 0xfed
Black screen on boot after update
Reboot stuck at black screen with login
Light Display Manager Failed
[SOLVED]Desktop acting funny after update;no desktop icons upon login
Manjaro on Asus UX580GE
Light Display Manager is lost - how i can repair?
No graphical login screen
Unable to boot Live USB install on new machine
Stuck on boot mesaage Started TLP system startup/shutdown
Can no longer login after update
Fail to boot after latest updates, ethernet fail too
Error with login screen
Cannot boot beyond the login screen
Manjaro OS booting failed and faced the black screen
Problems after upgrading [SOLVED]
Manjaro wont boot after update
[SOLVED] Boot Stuck at Started TLP system startup/shutdown
[Testing Update i686] 2018-12-19 to 2019-01-25 - Systemd, Kernels, LibreOffice Fresh, Readline, Firefox
Can't boot into my into my Manjaro Gnome installation
I am unable to log in
[Unstable Update] 2019-01-13 - Kernels, Cinnamon, Systemd, Readline, KDE Frameworks, Python
Upgrade to kernel 5.0 broke display
Manjaro doesn't launch after attempting an update that didn't finish
Help Please Wiki Page / Nvidia Drivers
Gnome black screen after installing Nvidia Proprietary drivers + Prime
Why do I have to update python, ms fonts, kernel, etc just to install oracle xe?
Can not boot Manjaro
Failed to boot after installing Nvidia proprietary driver 340xx
Unable to load Manjaro
Boot error after update: "Failed to Start Load Kernel Modules"
dual boot with windows 7 (MBR)
Latest resort nvidia drivers
all of a sudden, Manjaro loads only the commandline
[SOLVED] Manjaro boots to blank screen after update
[Stable Update] 2019-05-26 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice
[SOLVED] Setting custom resolution for second monitor via xorg.conf
Manjaro Keeps Freezing
2 fails on Manjaro XFCE boot (failed to start LightDM)
Can't init my laptop after add a file to blacklist
SDDM Fails to Open Authorization File
Stuck at boot "Started WPA supplicant."
Dell XPS 8900 _"after upgrade"_ the computer go to an unusable KDE window_
[Solved] Blank screen after logging in, can't get to desktop
Triple Boot - Advice before commitment please
System won't boot after installing nVidia display driver
Manjaro no longer starts x, I have to log into a shell and `startx`
Stuck at 'Started TLP system startup/shutdown.' - nvidia drivers
Using a Second Monitor with Gnome
Manjaro won't boot after 1st restart
Stuck at "Started TLP system startup/shutdown"
Boot process halts, ACPI errors?
Screen Paused when delete linux-video driver, and install nvidia Bumblebee driver.
"Failed to start Light Display Manager"
System froze, now it won't boot
black screen with only cursor
Screen brightness on macbook pro 2010
[solved] system won't start after reboot
How to backup from chroot to internal HDD?
full update from chroot
[solved] system won't start after reboot
After update not starting
a start job is running for tlp system startup/shutdown
PCIE bus error. Unable to boot
PCIE bus error. Unable to boot
Was using Manjaro, now not booting
Booting stuck at "Started TLP system startup/shutdown" after update
Fresh Manjaro desktop manager broken
Grub restore after hardware swap
I installed aud2u and my pc didnt start again!
TLP system startup/shutdown on an Acer laptop
Boot stuck at motherboard splash screen
Black Screen after latest update on old Desktop PC
Stuck in the login screen
Can't boot. Black screen
black screen on login i3
Manjaro fails to start after 2019-10-10 update
Help can't boot
Computer stuck at Dell logo after update, tried startx with no luck
Manjaro stuck on motherboard logo
Black screen and no grub menu when booting
Cant boot up on Live USB : stuck on udev kernel device manager
LiveUSB: not booting when entering the "Boot to Manjaro"
Laptop Freezes at Login Screen, Manjaro, Keyboard and mouse also doesn't work
cant install video-nvidia-435xx
Issues after power outage
Manjaro install from usb stuck

A post was split to a new topic: Pamac - mirrorcheck

Forum kindly sponsored by