Manjaro doesn't boot anymore after update


#1

Once again, my manjaro doesn’t boot anymore after the today system update. It’s already the second time it happens. Take a look at the screenshot:

What is it? What can I do against it? It doesn’t make sens for me, when I have to re-install manjaro every 2-3 weeks… :-/


#2

Post your inxi -Fzxc0 for starters so we know what hardware we are dealing with. Also are you dual booting? Also are you reading the announcement before updating?


#3

have you try :

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

#4

Okay, this is my inxi -Fzxc0:

System:
  Host: Maschine Kernel: 4.14.39-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 7.3.1 Console: N/A Distro: Manjaro Linux 17.1.9 Hakoila 
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-78LMT-S2 v: x.x serial: N/A 
  BIOS: Award v: F5 date: 10/19/2012 
CPU:
  Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 42208 
  Speed: 1406 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1405 2: 1406 
  3: 1406 4: 1406 5: 1402 6: 1406 
Graphics:
  Card-1: NVIDIA GF119 [GeForce GT 610] driver: N/A bus ID: 01:00.0 
  Display: server: X.org 1.19.6 driver: nvidia tty: 80x30 
  Message: Advanced graphics data unavailable in console for root. 
Audio:
  Card-1: AMD SBx00 Azalia driver: snd_hda_intel v: kernel bus ID: 00:14.2 
  Card-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Card-3: Logitech QuickCam Pro 9000 type: USB 
  driver: uvcvideo,snd-usb-audio bus ID: 2:2 
  Sound Server: ALSA v: k4.14.39-1-MANJARO 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: de00 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  HDD Total Size: 1.13 TiB used: 21.67 GiB (1.9%) 
  ID-1: /dev/sda model: SanDisk_SDSSDA12 size: 111.79 GiB 
  ID-2: /dev/sdb model: WDC_WD10EZEX-00B size: 931.51 GiB 
  ID-3: /dev/sdc model: SanDisk_SDSSDA12 size: 111.79 GiB 
Partition:
  ID-1: / size: 100.87 GiB used: 21.67 GiB (21.5%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 26.2 C mobo: N/A gpu: temp:  C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 119 Uptime: 5m Memory: 7.79 GiB used: 263.5 MiB (3.3%) 
  Init: systemd Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07

I use dual booting (Grub 2 manages Win7 and Manjaro) and no, I have not read announcement before updating… :-/


#5

No. What exactly does it do?


#6

@dingsong : random internal tests may on some architecture reboot kernel ,
time is very long on startup , you should add it.

NEVER APPLY AN UPGRADE BEFORE READING ANNOUNCEMENT OR ERRATA

this is applies in all systems ( Windows , Apple , Unix , BSD , and Linux ! )

if you have lost graphical video

check the news

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24 support for the old Fermi cards got dropped 11. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

#7

Your nvidia gpu, GeForce GT 610 (GF119), is a Fermi family card.

You can work this out by finding it here …

https://nouveau.freedesktop.org/wiki/CodeNames/

The latest nvidia driver series, 396, dropped support for Fermi cards. For Fermi cards there is now a 390 legacy driver.

You will have to remove the 396 driver and install the 390 legacy driver.

This info was provided in the second post of the update thread … you should always read this before updating, so you are aware of possible issues that may arise.

You can either run these commands from tty2 or a chroot live environment.

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

#8

@sueridgepipe: Thx, this worked and saved definitly my ass! :wink:
@stephane, sueridgepipe & nadb: I understood it and learned: read the announcement before updating. Thx guys!


#9

Same problem, manjaro i3, nvidia gtx 570, desktop PC, no hybrid graphics.

I downgraded to 390xx through chroot live.

Now, boot is stuck at “Started TLP system startup/shutdown”.

As I found, this error also somehow related with video drivers. Any suggestions?


#10

Upd.

Tried to reinstall 390xx, but seems I can’t do it, because files already exist in system, and I get “error: failed to commit transaction (conflicting files)” from pacman, when running mhwd -i.

Looks like mhwd -r video-nvidia-360xx wasn’t best idea. It was removed from drivers list, but not from pacman, and files are still in system.

After, tried to unnistall “mhwd-nvidia-390xx” through pacman -R, but can’t, because “mhwd” package itself depends on nvidia package.

So now, regarding to mhwd -li I don’t have nvidia driver installed, but also I can’t reinstall it, because, regarding to pacman it’s already installed and other packages depends on it.

Wery nice update… Again, maybe any suggestions?


#11

use USB install ,
open terminal

manjaro-chroot -a
sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

if ok 
Exit 
else 
report Here 

#12

I already did that, and reported here about failure.


#13

have you try

no free drivers
sudo mhwd -a pci nonfree 0300

or 
free drivers
sudo mhwd -a pci free 0300

#14

Hello,

  1. booted live media with the lastest Manjaro install image (17.1.10 as we speaking) => OK
  2. open a terminal => OK
  3. manjaro-chroot -a ==> ERROR: You can’t mount 0!

Seems that chroot isn’t working on Manjaro ???


#15

@piratu
nothing wrong on boot ( error on Bios or EFI )

manjaro-chroot -a should works


#16

Try manually mounting your root partition first.

sudo mount /dev/sdXX /mnt
sudo manjaro-chroot /mnt

#17

Hello,

Shoud work doesn’t mean that it’s working !

There’s nothing wrong with the boot sequence, I’m using BIOS as long as it’s possible on the 3 of my 4 machines. I’ve tested this procedure on all 3 and the same result. 2 of them are installed with KDE and the third with XFCE. The one with EFI is installed with XFCE but I didn’t encountered any issue as it has an AMD CPU with an integrated ATI videocard and is not touched by this Nvidia issue.

Here’s the output of “manjaro-chroot /mnt”:

[manjaro@manjaro /]$ sudo manjaro-chroot /mnt
mount: /mnt/proc: mount point does not exist.
==> ERROR: failed to setup API filesystems in chroot /mnt
umount: bad usage
Try ‘umount --help’ for more information.
[manjaro@manjaro /]$

Any further ideas?


#18

boot from USB install

on this wiki
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

dont forget mkdir /mnt before !
–> point 3 to get manually in your system by chroot

@philm can you have look on this , manjaro-chroot is on all DE ( Xfce , KDE , Gnome )