Manjaro doesn't boot after system upgrade

Thanks, but that didn’t help, all my packages are up-to-date.

So you couldn’t get in to a text console? And so you couldn’t try running startx from a console? Ah, well, best bet is a reinstall then. If you’ve made a load of random changes it’s going to be much easier to do that than try and unpick everything.

I’m in a chroot environment from a live USB stick. I thought that would do.

startx yields the following output:

xauth:  error in locking authority file /run/user/1000/gdm/Xauthority
xauth:  error in locking authority file /run/user/1000/gdm/Xauthority
xauth:  error in locking authority file /run/user/1000/gdm/Xauthority
xauth:  error in locking authority file /run/user/1000/gdm/Xauthority

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE) 
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 7 requests (7 known processed) with 0 events remaining.
xauth:  error in locking authority file /run/user/1000/gdm/Xauthority

Is that startx from within the chroot? If so, yeah, that’s not going to work.

1 Like

OK, so I tried it during boot, here startx gives a different error: failed to set IOPL for I/O (Operation not permitted) Fatal server error: no screens found

OK, but the key thing is that you have reached a text console and you can log in as your normal user?

If so, this means your system is probably fixable.

Yes, Ctrl+Alt+F2 works.

OK, so get logged in and run:

sudo pacman-mirrors -f3
sudo pacman -Syyu

Then, reinstall the drivers for your graphics card using mhwd.

I reinstalled the graphics drivers (video-linux and video-vesa), but didn’t help.
When I boot Manjaro, it doesn’t look like it’s doing anything.

I’d remove this one. You don’t need both and IIRC it will conflict and cause issues.

1 Like

Wow, it’s working again, thank you :slight_smile:

Yesterday, installed a kernel update, and it broke my system AGAIN: I got the error message

failed to mount /boot/efi: unknown filesystem type ‘vfat’

This time, I was able to fix it by myself by removing everything in /boot/ and re-installing grub, efibootmgr and linux419 from a chroot environment, then executing grub-install and grub-mkconfig.

Do you have any idea, why I am experiencing this problem? Is there a way to fix it permanently? I don’t want to do this every time I update my 4.19 kernel.

@Aloso, if your problem is just graphics, there is no need to reinstall grub, efibootmgr, etc…
Let’s take a look at some other things as well.
At Manjaro terminal, please provide (print) output of

LANG=C
sudo parted -l
sudo blkid
efibootmgr -v
cat /proc/cmdline
findmnt -s
kate /boot/grub/grubenv
kate /etc/default/grub

All output (all disks, do not omit) and if error message, print out error message as well and continue to next command. Oh… if you have other OS, tell us and what partition are they on.

ps: it may take a day to respond after you reply.

1 Like

I’m pretty sure it is not because of graphics, when /boot/efi can’t be mounted because ‘vfat’ is unknown.

$ sudo parted -l
Model: ATA TEAM L3 EVO SSD (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 
Number  Start   End    Size    File system     Name           Flags
 1      1049kB  211MB  210MB   fat32           UEFI_SYSTEM    boot, esp
 2      211MB   479MB  268MB   ext4            ANTERGOS_BOOT
 3      479MB   112GB  112GB   ext4            ANTERGOS_ROOT
 4      112GB   120GB  7841MB  linux-swap(v1)  ANTERGOS_SWAP


Model: ATA TOSHIBA DT01ACA1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 1      1049kB  500GB   500GB  primary  ext4
 3      500GB   710GB   210GB  primary  ext4
 2      710GB   1000GB  290GB  primary  ext4

Don’t be surprised about the names of the partitions, they are from a previous system.

$ sudo blkid
/dev/sda1: UUID="24C2-2456" TYPE="vfat" PARTLABEL="UEFI_SYSTEM" PARTUUID="36070759-a23c-415f-a734-f864851cfd35"
/dev/sda2: UUID="ed9d2455-0d21-408b-8b70-a2e25fd8e6cb" TYPE="ext4" PARTLABEL="ANTERGOS_BOOT" PARTUUID="99fa1712-2a5c-4962-9c5f-c67762502887"
/dev/sda3: UUID="07340206-056b-44ad-8e09-410bf51696f2" TYPE="ext4" PARTLABEL="ANTERGOS_ROOT" PARTUUID="c700b6a7-613e-443b-85af-65b4844fae6f"
/dev/sda4: UUID="35ccfa0b-a60b-4a5f-8cd1-9eaf09361804" TYPE="swap" PARTLABEL="ANTERGOS_SWAP" PARTUUID="3d8c5d67-19de-4720-955c-0e45082d18a4"
/dev/sdb1: LABEL="Partbone" UUID="fde12136-c3f5-4833-bae9-8a46c12d8f77" TYPE="ext4" PARTUUID="73969ed3-01"
/dev/sdb2: LABEL="Cinema" UUID="16c38672-f461-46a8-a620-8b795746350e" TYPE="ext4" PARTUUID="73969ed3-02"
/dev/sdb3: LABEL="Hickup" UUID="ba0cd67a-cfb9-4902-9cb6-d52e053c717e" TYPE="ext4" PARTUUID="73969ed3-03"
$ efibootmgr -v
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0000,0004,0006,0003,0001
Boot0000* GRUB  HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\GRUB\GRUBX64.EFI)
Boot0001* Hard Drive    BBS(HD,,0x0)..GO..NO........o.T.E.A.M. .L.3. .E.V.O. .S.S.D. .1.2.0.G.B....................A...........................>..Gd-.;.A..MQ..L.F.2.6.A.7.0.6.6.3.1.8.0.4.0.5.8.3.9.6.4........BO..NO........o.T.O.S.H.I.B.A. .D.T.0.1.A.C.A.1.0.0....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . .8. .R.6.0.V.P.G.S.N........BO
Boot0003* CD/DVD Drive  BBS(CDROM,,0x0)..GO..NO........o.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.4.N.S.D.1....................A...........................>..Gd-.;.A..MQ..L.9.K.G.6.H.3.3.G.4.5. .2. . . . . . . . ........BO
Boot0004* Windows Boot Manager  HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO
Boot0006* UEFI OS       HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\BOOT\BOOTX64.EFI)..BO

I’m not using Windows, I was just too lazy to remove it completely. I had a dual boot installation before.

$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=07340206-056b-44ad-8e09-410bf51696f2 rw quiet resume=UUID=35ccfa0b-a60b-4a5f-8cd1-9eaf09361804
$ findmnt -s
TARGET            SOURCE                                    FSTYPE OPTIONS
/boot/efi         UUID=24C2-2456                            vfat   defaults,noatime
/boot             UUID=ed9d2455-0d21-408b-8b70-a2e25fd8e6cb ext4   defaults,noatime,discard
/                 UUID=07340206-056b-44ad-8e09-410bf51696f2 ext4   defaults,noatime,discard
swap              UUID=35ccfa0b-a60b-4a5f-8cd1-9eaf09361804 swap   defaults,noatime,discard
/home             /dev/sdb1                                 ext4   defaults,noatime
/run/media/Cinema /dev/sdb2                                 ext4   defaults,noatime
/run/media/Hickup /dev/sdb3                                 ext4   noatime
$ kate /boot/grub/grubenv
Ausgabe in Kate:
# GRUB Environment Block
boot_indeterminate=2
boot_success=1
###################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################
$ kate /etc/default/grub
Ausgabe in Kate:
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=35ccfa0b-a60b-4a5f-8cd1-9eaf09361804"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/boot/grub/themes/breeze"
# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Alright. Got it.
Before we start, seeing your output, we need some clarification.

  1. Is this on Antergos or Manjaro?
    It’s okay if you are on Antergos, but Antergos grub works differently.
    You have to tell us if it is actually Antergos, it is important.
  2. It (output) shows you have a separate /boot partition (sda2)
    Please verify that you have kernels listed in sda2 and not in sda3 (your root partition)
    And that your grub.cfg shows something like
    root - sda2 (the search line & uuid of sda2)
    linux-line and initrd-line shows /vmlinuz-4.19.xxxx (& /initramfs-4.19.xxx…img)
    not /boot/vmlinuz-4.19.xxxxx & /boot/initramfs-4.19.xxx.img
    If unsure print out the first entry of /boot/grub/grub.cfg
    If kde, you have to use…(otherwise you cannot assess it - kde nanny distro - wants to protect us from ourselves)
    SUDO_EDITOR=kate sudoedit /boot/grub/grub.cfg

ps: (for note 2). Hopefully the ‘new’ grub (fedora for manjaro) handles separate /boot partition well. I do not have separate /boot partition and I cannot test it. Not many have separate /boot partition and anyway, it is unnecessary.

If you are very sure it is Manjaro and not Antergos and that grub.cfg has /vmlinuz-xxxx and /initramfs-4.19.xxxxxx (not /boot/vmlinuz-xxx ), then only proceed below.
.
.
.
.

  1. I assume you system is all updated. (pacman -Syyu)
    If not, please do so first, particularly “pacman -Q grub” gives “2.03.2-1”
  2. Make/Add/Comment_out these changes in /etc/default/grub
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu
#GRUB_SAVEDEFAULT=true
GRUB_TERMINAL_OUTPUT=gfxterm
GRUB_GFXMODE=1024x768x32
GRUB_GFXPAYLOAD_LINUX=1024x768x32

ps: some of them (the changes) are not related to your issue, but since we’re here, might as well make them better. :slightly_smiling_face: but GRUB_TIMEOUT=10 & GRUB_TIMEOUT_STYLE=menu is important.

  1. At terminal,
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0
sudo grub-install 
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
  1. Reboot.
    .
    .
    .
    .
    .
    .
    .

After all is done, reboot and print out for us (again)

efibootmgr

Also the first entry for /boot/grub/grub.cfg (since I didn’t ask the first time, thinking it is a normal non-boot_partition setup.

Good luck.

reference: here.

1 Like

It’s Manjaro (KDE). I had Antergos installed before, and when I installed Manjaro, I didn’t change the names of these partitions.

I compared the UUIDs and the paths to vmlinuz and initramfs. It looks alright.

That’s right.

Done. I just wonder why I need a resolution smaller than the native screen resolution.

Steps 3 and 4 done, no problems. Thanks for your help.

Reason for lower grub resolution is that uefi bios use only this resolution. Please search forum on this. (I am not at desktop).

Sorry, forgot that

$ efibootmgr -v
BootCurrent: 0008
Timeout: 2 seconds
BootOrder: 0008,0000,0004,0006,0003,0001,0002,0005,0007
Boot0000* GRUB  HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\GRUB\GRUBX64.EFI)
Boot0001* Hard Drive    BBS(HD,,0x0)..GO..NO........o.T.E.A.M. .L.3. .E.V.O. .S.S.D. .1.2.0.G.B....................A...........................>..Gd-.;.A..MQ..L.F.2.6.A.7.0.6.6.3.1.8.0.4.0.5.8.3.9.6.4........BO..NO........o.T.O.S.H.I.B.A. .D.T.0.1.A.C.A.1.0.0....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . .8. .R.6.0.V.P.G.S.N........BO
Boot0002* UEFI:CD/DVD Drive     BBS(129,,0x0)
Boot0003* CD/DVD Drive  BBS(CDROM,,0x0)..GO..NO........o.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.4.N.S.D.1....................A...........................>..Gd-.;.A..MQ..L.9.K.G.6.H.3.3.G.4.5. .2. . . . . . . . ........BO
Boot0004* Windows Boot Manager  HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO
Boot0005* UEFI:Removable Device BBS(130,,0x0)
Boot0006* UEFI OS       HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot0007* UEFI:Network Device   BBS(131,,0x0)
Boot0008* manjaro       HD(1,GPT,36070759-a23c-415f-a734-f864851cfd35,0x800,0x64000)/File(\EFI\MANJARO\GRUBX64.EFI)

Good. Noticed ‘manjaro’ is now listed and at top of bootorder?
Cheers, take care.

This topic was automatically closed after 180 days. New replies are no longer allowed.